FAQ
Hi folks,

I am using Cloudera Manager Free and trying to add a new host to CDH4.1.2
cluster. After installing the new host, host inspector said "there are
mismatched versions cross the system.", and I cannot enable datanode since
task tracker cannot be started. My previous MR version is 552 but version
of the new host is 556. Even I ran "Re-run Host Upgrade Wizard", the
problem cannot be resolved (seems nothing changed, still version mismatch).

What should I do to resolve this problem?

Search Discussions

  • Philip Zeyliger at Feb 10, 2013 at 9:54 pm
    Hi Balto,

    What's happened is that your new machines ended up getting CDH4.1.3 and the
    old ones are still on CDH4.1.2.

    You can either upgrade the old ones (using yum update) or downgrade the new
    ones (by specifying the CDH4.1.2 repo and using yum downgrade). See
    https://ccp.cloudera.com/display/DOC/CDH+Version+and+Packaging+Information
    and
    https://ccp.cloudera.com/display/DOC/CDH+Packaging+Information+for+Previous+Releases
    for
    more information.

    Cheers,

    -- Philip


    On Sat, Feb 9, 2013 at 11:36 PM, wrote:

    Hi folks,

    I am using Cloudera Manager Free and trying to add a new host to CDH4.1.2
    cluster. After installing the new host, host inspector said "there are
    mismatched versions cross the system.", and I cannot enable datanode since
    task tracker cannot be started. My previous MR version is 552 but version
    of the new host is 556. Even I ran "Re-run Host Upgrade Wizard", the
    problem cannot be resolved (seems nothing changed, still version mismatch).

    What should I do to resolve this problem?
  • Balto Jenna at Feb 14, 2013 at 10:00 am
    Thanks Philip!! It's resolved by downgrading CDH.

    在 2013年2月10日星期日UTC-8下午1时53分50秒,Philip Zeyliger写道:
    Hi Balto,

    What's happened is that your new machines ended up getting CDH4.1.3 and
    the old ones are still on CDH4.1.2.

    You can either upgrade the old ones (using yum update) or downgrade the
    new ones (by specifying the CDH4.1.2 repo and using yum downgrade). See
    https://ccp.cloudera.com/display/DOC/CDH+Version+and+Packaging+Information
    and
    https://ccp.cloudera.com/display/DOC/CDH+Packaging+Information+for+Previous+Releases for
    more information.

    Cheers,

    -- Philip


    On Sat, Feb 9, 2013 at 11:36 PM, <balto...@gmail.com <javascript:>> wrote:

    Hi folks,

    I am using Cloudera Manager Free and trying to add a new host to CDH4.1.2
    cluster. After installing the new host, host inspector said "there are
    mismatched versions cross the system.", and I cannot enable datanode since
    task tracker cannot be started. My previous MR version is 552 but version
    of the new host is 556. Even I ran "Re-run Host Upgrade Wizard", the
    problem cannot be resolved (seems nothing changed, still version mismatch).

    What should I do to resolve this problem?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedFeb 10, '13 at 7:36a
activeFeb 14, '13 at 10:00a
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Balto Jenna: 2 posts Philip Zeyliger: 1 post

People

Translate

site design / logo © 2022 Grokbase