FAQ
Dear all,

My cluster was working were well and out of no where it is not working.

Although the hbase health is good, in the log files:

HMAster

12:33:28.617 AM INFO org.apache.hadoop.hbase.catalog.CatalogTracker

Failed verification of .META.,,1 at
address=master1.medcloud.com,60020,1360016612056;
org.apache.hadoop.hbase.NotServingRegionException:
org.apache.hadoop.hbase.NotServingRegionException: Region is not
online: .META.,,1
  at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegion(HRegionServer.java:2859)
  at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegionInfo(HRegionServer.java:1755)
  at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  at java.lang.reflect.Method.invoke(Method.java:597)
  at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:364)
  at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1345)


  12:33:28.786 AM INFO org.apache.hadoop.hbase.catalog.CatalogTracker

Failed verification of .META.,,1 at
address=master1.medcloud.com,60020,1360016612056;
org.apache.hadoop.hbase.NotServingRegionException:
org.apache.hadoop.hbase.NotServingRegionException: Region is not
online: .META.,,1
  at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegion(HRegionServer.java:2859)
  at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegionInfo(HRegionServer.java:1755)
  at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  at java.lang.reflect.Method.invoke(Method.java:597)
  at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:364)
  at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1345)


I restarted the cluster several times and deployed client configs but still
I am facing problems, so any idea what to do??

Thanks :D

Search Discussions

  • Prasad p at Jun 7, 2013 at 2:55 am
    Hi Cloudera Exports,
         I am also having the same problem. could you please help us.

    Regards,
    Prasad.P
    On Monday, February 4, 2013 2:40:57 PM UTC-8, Dalia Hassan wrote:

    Dear all,

    My cluster was working were well and out of no where it is not working.

    Although the hbase health is good, in the log files:

    HMAster

    12:33:28.617 AM INFO org.apache.hadoop.hbase.catalog.CatalogTracker

    Failed verification of .META.,,1 at address=master1.medcloud.com,60020,1360016612056; org.apache.hadoop.hbase.NotServingRegionException: org.apache.hadoop.hbase.NotServingRegionException: Region is not online: .META.,,1
    at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegion(HRegionServer.java:2859)
    at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegionInfo(HRegionServer.java:1755)
    at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:364)
    at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1345)


    12:33:28.786 AM INFO org.apache.hadoop.hbase.catalog.CatalogTracker

    Failed verification of .META.,,1 at address=master1.medcloud.com,60020,1360016612056; org.apache.hadoop.hbase.NotServingRegionException: org.apache.hadoop.hbase.NotServingRegionException: Region is not online: .META.,,1
    at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegion(HRegionServer.java:2859)
    at org.apache.hadoop.hbase.regionserver.HRegionServer.getRegionInfo(HRegionServer.java:1755)
    at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:364)
    at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1345)


    I restarted the cluster several times and deployed client configs but
    still I am facing problems, so any idea what to do??

    Thanks :D
  • bc Wong at Jun 7, 2013 at 5:10 am

    On Thu, Jun 6, 2013 at 7:54 PM, prasad p wrote:
    Hi Cloudera Exports,
    I am also having the same problem. could you please help us.

    Hi Prasad,

    Could you try describe the problem with your own words? What's your CM
    and CDH version? Can you attach the master log?

    Cheers,
    bc
  • bc Wong at Jun 7, 2013 at 3:44 pm

    On Fri, Jun 7, 2013 at 7:06 AM, prasad p wrote:
    Hi Bc,
    Thank you for your time. I am using CDH-4.1.2 and
    Hbase-0.92.1-cdh-4.1.2. Please find the attached log file.
    THanks and Regards,
    Prasad,

    Please include scm-users in your replies (reply-all) so that future
    users would benefit from your experience.

    The log file looks fine to me. The stack traces are logged at INFO,
    and are transient issues when the master starts up. They went away
    very quickly and your master started fine. Do you observe an erroneous
    behaviour?

    Cheers,
    bc
    On Thursday, June 6, 2013 10:10:07 PM UTC-7, bc Wong wrote:
    On Thu, Jun 6, 2013 at 7:54 PM, prasad p wrote:

    Hi Cloudera Exports,
    I am also having the same problem. could you please help us.

    Hi Prasad,

    Could you try describe the problem with your own words? What's your CM
    and CDH version? Can you attach the master log?

    Cheers,
    bc
  • Prasad p at Jun 8, 2013 at 7:08 am
    Hi Bc,
        THanks for your time and inputs. It is working well.

    THanks and Regards,
    Prasad.P

    On Fri, Jun 7, 2013 at 8:43 AM, bc Wong wrote:
    On Fri, Jun 7, 2013 at 7:06 AM, prasad p wrote:
    Hi Bc,
    Thank you for your time. I am using CDH-4.1.2 and
    Hbase-0.92.1-cdh-4.1.2. Please find the attached log file.
    THanks and Regards,
    Prasad,

    Please include scm-users in your replies (reply-all) so that future
    users would benefit from your experience.

    The log file looks fine to me. The stack traces are logged at INFO,
    and are transient issues when the master starts up. They went away
    very quickly and your master started fine. Do you observe an erroneous
    behaviour?

    Cheers,
    bc
    On Thursday, June 6, 2013 10:10:07 PM UTC-7, bc Wong wrote:
    On Thu, Jun 6, 2013 at 7:54 PM, prasad p wrote:

    Hi Cloudera Exports,
    I am also having the same problem. could you please help us.

    Hi Prasad,

    Could you try describe the problem with your own words? What's your CM
    and CDH version? Can you attach the master log?

    Cheers,
    bc

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedFeb 4, '13 at 10:41p
activeJun 8, '13 at 7:08a
posts5
users3
websitecloudera.com
irc#hadoop

3 users in discussion

Prasad p: 2 posts bc Wong: 2 posts Dalia Hassan: 1 post

People

Translate

site design / logo © 2022 Grokbase