FAQ
+scm-users@cloudera.org

Mark,

Can you take a peek at one of the non-joining agents' logs
(/var/log/cloudera-scm-agent/cloudera-scm-agent.log) and tell us if
there are any errors being logged there?
On Wed, Jan 30, 2013 at 8:39 PM, Mark Aguiling wrote:
Hey there,

I am having trouble trying to add hosts to my cluster via Cloudera Manager.
Cloudera Manager successfully recognizes each nodes' IP address and can
install CDH, but after Host Inspector runs...there is still only one host in
my cluster ( The node with Cloudera Manager on it). I have read a couple
options and I'll let you know what I tried:

First, I edited my /etc/hosts file on each node to this:

127.0.0.1 localhost localhost.localdomain localhost4
localhost4.localdomain4
::1 localhost localhost.localdomain localhost6
localhost6.localdomain6
192.168.20.110 maestro1
192.168.20.144 maestro2
192.168.20.145 maestro3


The last 3 lines being the IP addresses of all 3 nodes. I read some where to
put the IP Addresses of all 3 machines in each of the hosts file in all 3
machines. ( Avoid a DNS server )

Then after that didn't work, I read that in order for the cluster nodes to
be able to reach port 7182 on the Cloudera Manager server to heartbeat... I
did this using the following code in the terminal as root:

iptables -A INPUT -p tcp --dport 7182 -j ACCEPT

Still, Cloudera Manager only recognizes the one host which is the host
Cloudera Manager is installed on...

Any suggestions please?

--
Mark Aguiling


--
Harsh J

Search Discussions

  • Avinash Kumar Singh at Jan 30, 2013 at 8:13 pm
    Hi Harsh,

    First of all u have to run the following command
    *chkconfig iptables off* on all the nodes
    then edit the following file

    /etc/selinux/config

    change

    *SELINUX= *disabled
    on all nodes by default it is enabled as shown in the file below. Hope it works

    # This file controls the state of SELinux on the system.
    # SELINUX= can take one of these three values:
    # enforcing - SELinux security policy is enforced.
    # permissive - SELinux prints warnings instead of enforcing.
    # disabled - No SELinux policy is loaded.*SELINUX= *enforcing
    # SELINUXTYPE= can take one of these two values:
    # targeted - Only targeted network daemons are protected.
    # strict - Full SELinux protection

    --
    ** Thanks & Regards
    Avinash Singh*

    Pa**x**cel** **Technologies Pvt Ltd.*
    Hartron Complex, Sector 18, Gurgaon, India.
    E-Mail: avinash.singh@paxcel.net <pooja.agarwal@paxcel.net>
    Mobile:+91 9803309575



    On Wed, Jan 30, 2013 at 11:52 PM, Harsh J wrote:

    +scm-users@cloudera.org

    Mark,

    Can you take a peek at one of the non-joining agents' logs
    (/var/log/cloudera-scm-agent/cloudera-scm-agent.log) and tell us if
    there are any errors being logged there?
    On Wed, Jan 30, 2013 at 8:39 PM, Mark Aguiling wrote:
    Hey there,

    I am having trouble trying to add hosts to my cluster via Cloudera Manager.
    Cloudera Manager successfully recognizes each nodes' IP address and can
    install CDH, but after Host Inspector runs...there is still only one host in
    my cluster ( The node with Cloudera Manager on it). I have read a couple
    options and I'll let you know what I tried:

    First, I edited my /etc/hosts file on each node to this:

    127.0.0.1 localhost localhost.localdomain localhost4
    localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6
    localhost6.localdomain6
    192.168.20.110 maestro1
    192.168.20.144 maestro2
    192.168.20.145 maestro3


    The last 3 lines being the IP addresses of all 3 nodes. I read some where to
    put the IP Addresses of all 3 machines in each of the hosts file in all 3
    machines. ( Avoid a DNS server )

    Then after that didn't work, I read that in order for the cluster nodes to
    be able to reach port 7182 on the Cloudera Manager server to
    heartbeat... I
    did this using the following code in the terminal as root:

    iptables -A INPUT -p tcp --dport 7182 -j ACCEPT

    Still, Cloudera Manager only recognizes the one host which is the host
    Cloudera Manager is installed on...

    Any suggestions please?

    --
    Mark Aguiling


    --
    Harsh J

    *Disclaimer:* This email and any files transmitted with it may contain
    privileged or confidential information. It is solely for use by the
    individual for whom it is intended even if addressed incorrectly. If you
    received this email in error please notify the sender, do not disclose,
    copy, distribute or take any action in reliance on the contents of this
    information; and delete it from your system. Any other use of this email
    is prohibited. Thank you for your compliance
  • Harsh J at Jan 30, 2013 at 8:41 pm
    +scm-users@cloudera.org

    Glad to know Mark, and thanks Avinash!
    On Thu, Jan 31, 2013 at 2:00 AM, Mark Aguiling wrote:
    I turned the iptables off earlier and it worked! I appreciate all the help and I'm sure I will have other questions. Thanks for everything.

    Sent from my iPhone
    On Jan 30, 2013, at 1:22 PM, Harsh J wrote:

    +scm-users@cloudera.org

    Mark,

    Can you take a peek at one of the non-joining agents' logs
    (/var/log/cloudera-scm-agent/cloudera-scm-agent.log) and tell us if
    there are any errors being logged there?
    On Wed, Jan 30, 2013 at 8:39 PM, Mark Aguiling wrote:
    Hey there,

    I am having trouble trying to add hosts to my cluster via Cloudera Manager.
    Cloudera Manager successfully recognizes each nodes' IP address and can
    install CDH, but after Host Inspector runs...there is still only one host in
    my cluster ( The node with Cloudera Manager on it). I have read a couple
    options and I'll let you know what I tried:

    First, I edited my /etc/hosts file on each node to this:

    127.0.0.1 localhost localhost.localdomain localhost4
    localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6
    localhost6.localdomain6
    192.168.20.110 maestro1
    192.168.20.144 maestro2
    192.168.20.145 maestro3


    The last 3 lines being the IP addresses of all 3 nodes. I read some where to
    put the IP Addresses of all 3 machines in each of the hosts file in all 3
    machines. ( Avoid a DNS server )

    Then after that didn't work, I read that in order for the cluster nodes to
    be able to reach port 7182 on the Cloudera Manager server to heartbeat... I
    did this using the following code in the terminal as root:

    iptables -A INPUT -p tcp --dport 7182 -j ACCEPT

    Still, Cloudera Manager only recognizes the one host which is the host
    Cloudera Manager is installed on...

    Any suggestions please?

    --
    Mark Aguiling


    --
    Harsh J


    --
    Harsh J
  • James Hogarth at Jan 31, 2013 at 12:50 pm

    On Wednesday, 30 January 2013 20:40:54 UTC, Harsh J wrote:
    +scm-...@cloudera.org <javascript:>

    Glad to know Mark, and thanks Avinash!
    On Thu, Jan 31, 2013 at 2:00 AM, Mark Aguiling wrote:
    I turned the iptables off earlier and it worked! I appreciate all the
    help and I'm sure I will have other questions. Thanks for everything.
    Sent from my iPhone
    If you're in an environment that enforces firewalls for audit/security
    reasons remember that the SCM agent (so on the nodes and any gateway
    systems added) listens on TCP/9000 so that must be open for CM to carry out
    the host inspection and get host health states...

    In addition if you want to audit selinux events (for security reasons) it's
    better to set it as permissive rather than disabled so that exceptions are
    still logged to audit.log and file contexts etc can still be checked (as a
    reminder to go from disabled to permissive you need to carry out a full
    system relabel... that can take a while)...

    James

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJan 30, '13 at 6:22p
activeJan 31, '13 at 12:50p
posts4
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase