FAQ
Praveen,



The problem is that your DNS server is set to a public DNS server (8.8.8.8)
which will not be able to resolve your internal names/IPs.



nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
Please point your hosts to an internal DNS server that can resolve the
servers.



*Brian Burton*

*Customer Operations Engineer, Cloudera*



*From:* Aaron T. Myers
*Sent:* Monday, January 21, 2013 1:53 PM
*To:* scm-users; praveensripati@gmail.com
*Subject:* Re: Problem setting up a Cloudera Cluster



+scm-users@

bcc: cdh-user@



Hi Praveen, moving this message over to scm-users@cloudera.org, which
should be able to help you out with this issue.




--

Aaron T. Myers

Software Engineer, Cloudera



On Mon, Jan 21, 2013 at 8:53 AM, Praveen Sripati wrote:

Hi,

I am using Cloudera Manager 4.1 to setup a small cluster. At some point
during the cluster installation I get the below message

--
Inspect hosts for correctness
Inspector ran on all 0 hosts.
The inspector failed to run on all hosts.
--

Not exactly sure why. But, the documentation says that both forward and
reverse DNS should work. So, I tried nslookup followed by the IP address of
a different machine to get the below error message

training@guest1:/etc/network$ nslookup 192.168.1.101
Server: 8.8.8.8
Address: 8.8.8.8#53
server can't find 101.1.168.192.in-addr.arpa.: NXDOMAIN

An entry has been added to the /etc/hosts for the ip and I am able to ping
the machine by name. But, still the nslookup doesn't work.

How to get around this problem? BTW, I am using Ubuntu 12.04 Server.

Thanks,
Praveen

--

Search Discussions

  • Praveen Sripati at Jan 22, 2013 at 1:05 am
    Hi Brian,

    Thanks for the response.

    1) Is reverse DNS not working one of the reason why the below message comes
    during the installation of CDH?

    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.

    2) I am a setting a small (2-node) CDH cluster. Is there any way to make
    some configuration changes on the 2 nodes and avoid setting up a DNS Server
    for reverse DNS?

    Thanks,
    Praveen
    On Tue, Jan 22, 2013 at 12:26 AM, Brian Burton wrote:

    Praveen,



    The problem is that your DNS server is set to a public DNS server
    (8.8.8.8) which will not be able to resolve your internal names/IPs.



    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.



    *Brian Burton*

    *Customer Operations Engineer, Cloudera*



    *From:* Aaron T. Myers
    *Sent:* Monday, January 21, 2013 1:53 PM
    *To:* scm-users; praveensripati@gmail.com
    *Subject:* Re: Problem setting up a Cloudera Cluster



    +scm-users@

    bcc: cdh-user@



    Hi Praveen, moving this message over to scm-users@cloudera.org, which
    should be able to help you out with this issue.




    --

    Aaron T. Myers

    Software Engineer, Cloudera



    On Mon, Jan 21, 2013 at 8:53 AM, Praveen Sripati wrote:

    Hi,

    I am using Cloudera Manager 4.1 to setup a small cluster. At some point
    during the cluster installation I get the below message

    --
    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.
    --

    Not exactly sure why. But, the documentation says that both forward and
    reverse DNS should work. So, I tried nslookup followed by the IP address of
    a different machine to get the below error message

    training@guest1:/etc/network$ nslookup 192.168.1.101
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    server can't find 101.1.168.192.in-addr.arpa.: NXDOMAIN

    An entry has been added to the /etc/hosts for the ip and I am able to ping
    the machine by name. But, still the nslookup doesn't work.

    How to get around this problem? BTW, I am using Ubuntu 12.04 Server.

    Thanks,
    Praveen

    --




  • Adam Smieszny at Jan 22, 2013 at 6:56 pm
    Hi Praveen,

    You should be able to use /etc/hosts file in place of DNS on a small test
    cluster. I have done so successfully numerous times.

    Ensure that your /etc/hosts file contains correct IP addresses to shortname
    mappings - and that it is the same /etc/hosts on all machines
    Ensure that /etc/nsswitch.conf has line like "hosts: files dns"
    Ensure that /etc/host.conf has a line like "order hosts, bind"

    Thanks,
    Adam


    On Mon, Jan 21, 2013 at 8:05 PM, Praveen Sripati
    wrote:
    Hi Brian,

    Thanks for the response.

    1) Is reverse DNS not working one of the reason why the below message
    comes during the installation of CDH?


    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.

    2) I am a setting a small (2-node) CDH cluster. Is there any way to make
    some configuration changes on the 2 nodes and avoid setting up a DNS Server
    for reverse DNS?

    Thanks,
    Praveen

    On Tue, Jan 22, 2013 at 12:26 AM, Brian Burton wrote:

    Praveen,



    The problem is that your DNS server is set to a public DNS server
    (8.8.8.8) which will not be able to resolve your internal names/IPs.



    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.



    *Brian Burton*

    *Customer Operations Engineer, Cloudera*



    *From:* Aaron T. Myers
    *Sent:* Monday, January 21, 2013 1:53 PM
    *To:* scm-users; praveensripati@gmail.com
    *Subject:* Re: Problem setting up a Cloudera Cluster



    +scm-users@

    bcc: cdh-user@



    Hi Praveen, moving this message over to scm-users@cloudera.org, which
    should be able to help you out with this issue.




    --

    Aaron T. Myers

    Software Engineer, Cloudera



    On Mon, Jan 21, 2013 at 8:53 AM, Praveen Sripati <
    praveensripati@gmail.com> wrote:

    Hi,

    I am using Cloudera Manager 4.1 to setup a small cluster. At some point
    during the cluster installation I get the below message

    --
    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.
    --

    Not exactly sure why. But, the documentation says that both forward and
    reverse DNS should work. So, I tried nslookup followed by the IP address of
    a different machine to get the below error message

    training@guest1:/etc/network$ nslookup 192.168.1.101
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    server can't find 101.1.168.192.in-addr.arpa.: NXDOMAIN

    An entry has been added to the /etc/hosts for the ip and I am able to
    ping the machine by name. But, still the nslookup doesn't work.

    How to get around this problem? BTW, I am using Ubuntu 12.04 Server.

    Thanks,
    Praveen

    --





    --
    Adam Smieszny
    Cloudera | Systems Engineer | http://www.linkedin.com/in/adamsmieszny
    917.830.4156
  • Praveen Sripati at Jan 22, 2013 at 11:19 pm
    Hi Adam,

    Thanks for the response. I have got the appropriate entries in the /etc/hosts
    file.

    According to the Cloudera documentation forward/reverse DNS should work for
    the Cluster to work. So, I tried nslookup to make sure that the reverse DNS
    works and got a error. Also, the nsswitch.conf and host.conf files have the
    proper configuration as speciefied. According to Brian
    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.

    So, I was not sure why reverse DNS was not working and if setting up a
    internal DNS Server is the only way to get around this problem.


    Thanks,
    Praveen

    Cloudera Certified Developer for Apache Hadoop CDH4 (95%)
    http://www.thecloudavenue.com/
    http://stackoverflow.com/users/614157/praveen-sripati

    If you aren’t taking advantage of big data, then you don’t have big data,
    you have just a pile of data.

    On Wed, Jan 23, 2013 at 12:26 AM, Adam Smieszny wrote:

    Hi Praveen,

    You should be able to use /etc/hosts file in place of DNS on a small test
    cluster. I have done so successfully numerous times.

    Ensure that your /etc/hosts file contains correct IP addresses to
    shortname mappings - and that it is the same /etc/hosts on all machines
    Ensure that /etc/nsswitch.conf has line like "hosts: files dns"
    Ensure that /etc/host.conf has a line like "order hosts, bind"

    Thanks,
    Adam


    On Mon, Jan 21, 2013 at 8:05 PM, Praveen Sripati <praveensripati@gmail.com
    wrote:
    Hi Brian,

    Thanks for the response.

    1) Is reverse DNS not working one of the reason why the below message
    comes during the installation of CDH?


    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.

    2) I am a setting a small (2-node) CDH cluster. Is there any way to make
    some configuration changes on the 2 nodes and avoid setting up a DNS Server
    for reverse DNS?

    Thanks,
    Praveen

    On Tue, Jan 22, 2013 at 12:26 AM, Brian Burton wrote:

    Praveen,



    The problem is that your DNS server is set to a public DNS server
    (8.8.8.8) which will not be able to resolve your internal names/IPs.



    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.



    *Brian Burton*

    *Customer Operations Engineer, Cloudera*



    *From:* Aaron T. Myers
    *Sent:* Monday, January 21, 2013 1:53 PM
    *To:* scm-users; praveensripati@gmail.com
    *Subject:* Re: Problem setting up a Cloudera Cluster



    +scm-users@

    bcc: cdh-user@



    Hi Praveen, moving this message over to scm-users@cloudera.org, which
    should be able to help you out with this issue.




    --

    Aaron T. Myers

    Software Engineer, Cloudera



    On Mon, Jan 21, 2013 at 8:53 AM, Praveen Sripati <
    praveensripati@gmail.com> wrote:

    Hi,

    I am using Cloudera Manager 4.1 to setup a small cluster. At some point
    during the cluster installation I get the below message

    --
    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.
    --

    Not exactly sure why. But, the documentation says that both forward and
    reverse DNS should work. So, I tried nslookup followed by the IP address of
    a different machine to get the below error message

    training@guest1:/etc/network$ nslookup 192.168.1.101
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    server can't find 101.1.168.192.in-addr.arpa.: NXDOMAIN

    An entry has been added to the /etc/hosts for the ip and I am able to
    ping the machine by name. But, still the nslookup doesn't work.

    How to get around this problem? BTW, I am using Ubuntu 12.04 Server.

    Thanks,
    Praveen

    --





    --
    Adam Smieszny
    Cloudera | Systems Engineer | http://www.linkedin.com/in/adamsmieszny
    917.830.4156
  • Brian Burton at Jan 23, 2013 at 3:40 pm
    Hi Praveen,



    My apologies, I should probably have been be more clear. The /etc/hosts
    file is sufficient for cluster communication. However, nslookup is a DNS
    tool, and will not query your /etc/hosts file. If you want to verify
    cluster communication, you can use ping, which does use the /etc/hosts file.



    Not using DNS should not prevent the inspector from working. Check the
    ‘logs’ directory for the Host Inspector process for information. Navigate
    to /var/run/cloudera-scm-agent/process/ and run “ls -ltrd *inspector”. The
    last directory in the list will be the most recent run. Inside that
    directory will be a ‘logs’ directory, with stdout.log and stderr.log. Check
    those for error messages.



    Thank you,



    *Brian Burton*

    *Customer Operations Engineer, Cloudera*



    *From:* Praveen Sripati
    *Sent:* Tuesday, January 22, 2013 6:19 PM
    *To:* Adam Smieszny
    *Cc:* scm-users
    *Subject:* Re: Problem setting up a Cloudera Cluster



    Hi Adam,

    Thanks for the response. I have got the appropriate entries in the
    /etc/hosts file.

    According to the Cloudera documentation forward/reverse DNS should work for
    the Cluster to work. So, I tried nslookup to make sure that the reverse DNS
    works and got a error. Also, the nsswitch.conf and host.conf files have the
    proper configuration as speciefied. According to Brian
    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.

    So, I was not sure why reverse DNS was not working and if setting up a
    internal DNS Server is the only way to get around this problem.



    Thanks,
    Praveen

    Cloudera Certified Developer for Apache Hadoop CDH4 (95%)
    http://www.thecloudavenue.com/
    http://stackoverflow.com/users/614157/praveen-sripati

    If you aren’t taking advantage of big data, then you don’t have big data,
    you have just a pile of data.



    On Wed, Jan 23, 2013 at 12:26 AM, Adam Smieszny wrote:

    Hi Praveen,



    You should be able to use /etc/hosts file in place of DNS on a small test
    cluster. I have done so successfully numerous times.



    Ensure that your /etc/hosts file contains correct IP addresses to shortname
    mappings - and that it is the same /etc/hosts on all machines

    Ensure that /etc/nsswitch.conf has line like "hosts: files dns"

    Ensure that /etc/host.conf has a line like "order hosts, bind"



    Thanks,

    Adam



    On Mon, Jan 21, 2013 at 8:05 PM, Praveen Sripati wrote:

    Hi Brian,

    Thanks for the response.

    1) Is reverse DNS not working one of the reason why the below message comes
    during the installation of CDH?



    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.

    2) I am a setting a small (2-node) CDH cluster. Is there any way to make
    some configuration changes on the 2 nodes and avoid setting up a DNS Server
    for reverse DNS?

    Thanks,
    Praveen





    On Tue, Jan 22, 2013 at 12:26 AM, Brian Burton wrote:

    Praveen,



    The problem is that your DNS server is set to a public DNS server (8.8.8.8)
    which will not be able to resolve your internal names/IPs.



    nslookup does not use your /etc/hosts file. Its purpose is to query DNS.
    Please point your hosts to an internal DNS server that can resolve the
    servers.



    *Brian Burton*

    *Customer Operations Engineer, Cloudera*



    *From:* Aaron T. Myers
    *Sent:* Monday, January 21, 2013 1:53 PM
    *To:* scm-users; praveensripati@gmail.com
    *Subject:* Re: Problem setting up a Cloudera Cluster



    +scm-users@

    bcc: cdh-user@



    Hi Praveen, moving this message over to scm-users@cloudera.org, which
    should be able to help you out with this issue.




    --

    Aaron T. Myers

    Software Engineer, Cloudera



    On Mon, Jan 21, 2013 at 8:53 AM, Praveen Sripati wrote:

    Hi,

    I am using Cloudera Manager 4.1 to setup a small cluster. At some point
    during the cluster installation I get the below message

    --
    Inspect hosts for correctness
    Inspector ran on all 0 hosts.
    The inspector failed to run on all hosts.
    --

    Not exactly sure why. But, the documentation says that both forward and
    reverse DNS should work. So, I tried nslookup followed by the IP address of
    a different machine to get the below error message

    training@guest1:/etc/network$ nslookup 192.168.1.101
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    server can't find 101.1.168.192.in-addr.arpa.: NXDOMAIN

    An entry has been added to the /etc/hosts for the ip and I am able to ping
    the machine by name. But, still the nslookup doesn't work.

    How to get around this problem? BTW, I am using Ubuntu 12.04 Server.

    Thanks,
    Praveen

    --












    --
    Adam Smieszny

    Cloudera | Systems Engineer | http://www.linkedin.com/in/adamsmieszny

    917.830.4156

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJan 21, '13 at 7:04p
activeJan 23, '13 at 3:40p
posts5
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase