FAQ
7180 port is not open to External. so I want to modify the default port
7180 to the other. I saw the detail in
http://grokbase.com/t/cloudera/scm-users/1289jt57w3/cloudera-scm-server-port-configuration-file
#
Use pgadmin or any other client to open the DB, there is a table called *
"settings"* inside *"scm"* DB.
You can see update the column *"http_port"* with the value you want.
#
but i cannot find the table "settings*" my table info:
scm-> \d
              List of relations
  Schema | Name | Type | Owner
--------+-------------------+-------+-------
  public | audits | table | scm
  public | client_configs | table | scm
  public | clusters | table | scm
  public | cm_version | table | scm
  public | commands | table | scm
  public | config_containers | table | scm
  public | config_revisions | table | scm
  public | configs | table | scm
  public | credentials | table | scm
  public | hosts | table | scm
  public | processes | table | scm
  public | roles | table | scm
  public | schema_version | table | scm
  public | services | table | scm
  public | user_roles | table | scm
  public | user_settings | table | scm
  public | users | table | scm

Just an addition: This is Cloudera Manager Free Edition
thanks

Search Discussions

  • Y-Hain Chang at Dec 31, 2012 at 2:32 am
    7180 port is not open to External. so I want to modify the default port
    7180 to the other. I saw the detail in
    http://grokbase.com/t/cloudera/scm-users/1289jt57w3/cloudera-scm-server-port-configuration-file
    #
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.
    #
    but i cannot find the table "settings*" my table info:
    scm-> \d
                  List of relations
      Schema | Name | Type | Owner
    --------+-------------------+-------+-------
      public | audits | table | scm
      public | client_configs | table | scm
      public | clusters | table | scm
      public | cm_version | table | scm
      public | commands | table | scm
      public | config_containers | table | scm
      public | config_revisions | table | scm
      public | configs | table | scm
      public | credentials | table | scm
      public | hosts | table | scm
      public | processes | table | scm
      public | roles | table | scm
      public | schema_version | table | scm
      public | services | table | scm
      public | user_roles | table | scm
      public | user_settings | table | scm
      public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition
    thanks
  • Vikas Singh at Jan 2, 2013 at 5:42 pm
    Go to CM web UI and click over "admin" button at top right corner (a "gear"
    icon). Then go to "Ports and Addresses" and change the port there and save
    new settings. Now restart CM server (service cloudera-scm-service restart)
    and the server should start at the new port.

    Make sure that the new port that you choose doesn't conflict with any
    existing service running on your machine.

    - Vikas

    On Sun, Dec 30, 2012 at 6:31 PM, Y-Hain Chang wrote:

    7180 port is not open to External. so I want to modify the default port
    7180 to the other. I saw the detail in
    http://grokbase.com/t/**cloudera/scm-users/1289jt57w3/**
    cloudera-scm-server-port-**configuration-file<http://grokbase.com/t/cloudera/scm-users/1289jt57w3/cloudera-scm-server-port-configuration-file>
    #
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.
    #
    but i cannot find the table "settings*" my table info:
    scm-> \d
    List of relations
    Schema | Name | Type | Owner
    --------+-------------------+-**------+-------
    public | audits | table | scm
    public | client_configs | table | scm
    public | clusters | table | scm
    public | cm_version | table | scm
    public | commands | table | scm
    public | config_containers | table | scm
    public | config_revisions | table | scm
    public | configs | table | scm
    public | credentials | table | scm
    public | hosts | table | scm
    public | processes | table | scm
    public | roles | table | scm
    public | schema_version | table | scm
    public | services | table | scm
    public | user_roles | table | scm
    public | user_settings | table | scm
    public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition
    thanks
  • Mx wang at Sep 26, 2013 at 3:13 pm
    Hi,
    I installed the CM server externally and only have the 8080 port open, so I
    can not login the Web UI and change the port.
    How can I change the port in database or conf file?

    Thanks,
    mingxue.
    On Wednesday, 2 January 2013 17:42:24 UTC, Vikas Singh wrote:

    Go to CM web UI and click over "admin" button at top right corner (a
    "gear" icon). Then go to "Ports and Addresses" and change the port there
    and save new settings. Now restart CM server (service cloudera-scm-service
    restart) and the server should start at the new port.

    Make sure that the new port that you choose doesn't conflict with any
    existing service running on your machine.

    - Vikas


    On Sun, Dec 30, 2012 at 6:31 PM, Y-Hain Chang <zhy...@gmail.com<javascript:>
    wrote:
    7180 port is not open to External. so I want to modify the default port
    7180 to the other. I saw the detail in
    http://grokbase.com/t/**cloudera/scm-users/1289jt57w3/**
    cloudera-scm-server-port-**configuration-file<http://grokbase.com/t/cloudera/scm-users/1289jt57w3/cloudera-scm-server-port-configuration-file>
    #
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.
    #
    but i cannot find the table "settings*" my table info:
    scm-> \d
    List of relations
    Schema | Name | Type | Owner
    --------+-------------------+-**------+-------
    public | audits | table | scm
    public | client_configs | table | scm
    public | clusters | table | scm
    public | cm_version | table | scm
    public | commands | table | scm
    public | config_containers | table | scm
    public | config_revisions | table | scm
    public | configs | table | scm
    public | credentials | table | scm
    public | hosts | table | scm
    public | processes | table | scm
    public | roles | table | scm
    public | schema_version | table | scm
    public | services | table | scm
    public | user_roles | table | scm
    public | user_settings | table | scm
    public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition
    thanks
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Philip Zeyliger at Sep 26, 2013 at 3:33 pm
    Easiest thing is to set up a port forward via SSH.

    Use "ssh -L 1234:cm_host:7180 cm_host" and connect locally to
    http://localhost:1234/ to change the port. Here's the doc:

          -L [bind_address:]port:host:hostport
                  Specifies that the given port on the local (client) host is to
    be for‐
                  warded to the given host and port on the remote side. This
    works by allo‐
                  cating a socket to listen to port on the local side,
    optionally bound to
                  the specified bind_address. Whenever a connection is made to
    this port,
                  the connection is forwarded over the secure channel, and a
    connection is
                  made to host port hostport from the remote machine. Port
    forwardings can
                  also be specified in the configuration file. IPv6 addresses
    can be speci‐
                  fied by enclosing the address in square brackets. Only the
    superuser can
                  forward privileged ports. By default, the local port is bound
    in accor‐
                  dance with the GatewayPorts setting. However, an explicit
    bind_address
                  may be used to bind the connection to a specific address. The
                  bind_address of “localhost” indicates that the listening port
    be bound for
                  local use only, while an empty address or ‘*’ indicates that
    the port
                  should be available from all interfaces.




    On Thu, Sep 26, 2013 at 8:13 AM, mx wang wrote:

    Hi,
    I installed the CM server externally and only have the 8080 port open, so
    I can not login the Web UI and change the port.
    How can I change the port in database or conf file?

    Thanks,
    mingxue.

    On Wednesday, 2 January 2013 17:42:24 UTC, Vikas Singh wrote:

    Go to CM web UI and click over "admin" button at top right corner (a
    "gear" icon). Then go to "Ports and Addresses" and change the port there
    and save new settings. Now restart CM server (service cloudera-scm-service
    restart) and the server should start at the new port.

    Make sure that the new port that you choose doesn't conflict with any
    existing service running on your machine.

    - Vikas

    On Sun, Dec 30, 2012 at 6:31 PM, Y-Hain Chang wrote:

    7180 port is not open to External. so I want to modify the default
    port 7180 to the other. I saw the detail in
    http://grokbase.com/t/**cloudera**/scm-users/1289jt57w3/**cloudera**
    -scm-server-port-**configuration**-file<http://grokbase.com/t/cloudera/scm-users/1289jt57w3/cloudera-scm-server-port-configuration-file>
    #
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.
    #
    but i cannot find the table "settings*" my table info:
    scm-> \d
    List of relations
    Schema | Name | Type | Owner
    --------+-------------------+-****------+-------
    public | audits | table | scm
    public | client_configs | table | scm
    public | clusters | table | scm
    public | cm_version | table | scm
    public | commands | table | scm
    public | config_containers | table | scm
    public | config_revisions | table | scm
    public | configs | table | scm
    public | credentials | table | scm
    public | hosts | table | scm
    public | processes | table | scm
    public | roles | table | scm
    public | schema_version | table | scm
    public | services | table | scm
    public | user_roles | table | scm
    public | user_settings | table | scm
    public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition
    thanks
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Mx wang at Sep 26, 2013 at 4:20 pm
    Thank you for your quick reply.

    I have tried the tunnel out the 7180 via SSH.
    However, there are two gateways between the client and the CM server. I can
    tunnel out the 80 port.
    Any help on configuring the CM UI default port?

    Thank you,
    mingxue

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Philip Zeyliger at Sep 26, 2013 at 4:32 pm
    You can also forward locally: make port 8080 forward to 7180 once you're
    logged into that machine over ssh. Something like "ssh -L
    8080:localhost:7180 localhost"

    If you insist on the database approach, I think the following query works:

    mysql> insert into CONFIGS (CONFIG_ID, ATTR, VALUE, REVISION_ID,
    CONFIG_CONTAINER_ID) VALUES ( *10001*, "http_port", "1235", (SELECT
    CONFIG_REVISION_ID FROM CONFIG_CONTAINERS WHERE CONFIG_TYPE="SCM"), (SELECT
    CONFIG_CONTAINER_ID FROM CONFIG_CONTAINERS WHERE CONFIG_TYPE="SCM"));
    Query OK, 1 row affected (1.09 sec)

    Replace *10001* with the value of "SELECT MAX(CONFIG_ID) + 1 FROM CONFIGS".

    I tried this on MySQL (on CM 4.7) as you can see, because that's what I had
    handy, but postgresql shouldn't be noticeably different. Possibly the
    nested selects wouldn't, but there are only 2 of them, so run the select
    separately and copy and paste the value.





    On Thu, Sep 26, 2013 at 9:20 AM, mx wang wrote:

    Thank you for your quick reply.

    I have tried the tunnel out the 7180 via SSH.
    However, there are two gateways between the client and the CM server. I
    can tunnel out the 80 port.
    Any help on configuring the CM UI default port?

    Thank you,
    mingxue

    To unsubscribe from this group and stop receiving emails from it, send an
    email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedDec 31, '12 at 2:31a
activeSep 26, '13 at 4:32p
posts7
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase