FAQ
Hello,

Is there a way to configure replication, either master or slave, from
within the CM Free GUI? Or do I need to edit hbase-site.xml directly?

Thanks.

--Brennon

Search Discussions

  • bc Wong at Dec 27, 2012 at 7:23 pm

    On Thu, Dec 27, 2012 at 10:46 AM, Brennon Church wrote:

    Hello,

    Is there a way to configure replication, either master or slave, from
    within the CM Free GUI? Or do I need to edit hbase-site.xml directly?

    Thanks.

    --Brennon
    Hi Brennon,

    You can edit the "HBase Service Configuration Safety Valve for
    hbase-site.xml", paste in the "hbase.replication=true" XML snippet. The
    rest of the steps are manual on the CLI
    https://ccp.cloudera.com/display/CDH4DOC/HBase+Replication.

    Cheers,
    bc
  • Brennon Church at Dec 27, 2012 at 8:09 pm
    I must be missing something. I've added this:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>

    to the "HBase Service Configuration Safety Valve" box in service-wide,
    advanced configuration section. Then no matter what I do I can't seem to
    get it to deploy to the systems. Downloading a zipped file of the newly
    generated configs lacks the change I made. The same is true if I restart
    the hbase service entirely or deploy the client configuration. The files
    get updated, but the change isn't included.

    Thanks.

    --Brennon

    On Thu, Dec 27, 2012 at 11:22 AM, bc Wong wrote:
    On Thu, Dec 27, 2012 at 10:46 AM, Brennon Church wrote:

    Hello,

    Is there a way to configure replication, either master or slave, from
    within the CM Free GUI? Or do I need to edit hbase-site.xml directly?

    Thanks.

    --Brennon
    Hi Brennon,

    You can edit the "HBase Service Configuration Safety Valve for
    hbase-site.xml", paste in the "hbase.replication=true" XML snippet. The
    rest of the steps are manual on the CLI
    https://ccp.cloudera.com/display/CDH4DOC/HBase+Replication.

    Cheers,
    bc
  • bc Wong at Dec 27, 2012 at 8:36 pm

    On Thu, Dec 27, 2012 at 12:09 PM, Brennon Church wrote:

    I must be missing something. I've added this:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>

    to the "HBase Service Configuration Safety Valve" box in service-wide,
    advanced configuration section. Then no matter what I do I can't seem to
    get it to deploy to the systems. Downloading a zipped file of the newly
    generated configs lacks the change I made. The same is true if I restart
    the hbase service entirely or deploy the client configuration. The files
    get updated, but the change isn't included.
    If you go to HBase -> Master -> Processes -> Configuration
    Files/Environment -> hbase-site.xml, you should see it.

    This safety valve is for the server-side config only, and does not show up
    in /etc/hbase/conf or generated client config.

    Cheers,
    bc

    On Thu, Dec 27, 2012 at 11:22 AM, bc Wong wrote:
    On Thu, Dec 27, 2012 at 10:46 AM, Brennon Church wrote:

    Hello,

    Is there a way to configure replication, either master or slave, from
    within the CM Free GUI? Or do I need to edit hbase-site.xml directly?

    Thanks.

    --Brennon
    Hi Brennon,

    You can edit the "HBase Service Configuration Safety Valve for
    hbase-site.xml", paste in the "hbase.replication=true" XML snippet. The
    rest of the steps are manual on the CLI
    https://ccp.cloudera.com/display/CDH4DOC/HBase+Replication.

    Cheers,
    bc
  • Brennon Church at Dec 27, 2012 at 8:48 pm
    Got it. Had to add it to the client config to get it to work. Thanks.

    --Brennon

    On Thu, Dec 27, 2012 at 12:35 PM, bc Wong wrote:
    On Thu, Dec 27, 2012 at 12:09 PM, Brennon Church wrote:

    I must be missing something. I've added this:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>

    to the "HBase Service Configuration Safety Valve" box in service-wide,
    advanced configuration section. Then no matter what I do I can't seem to
    get it to deploy to the systems. Downloading a zipped file of the newly
    generated configs lacks the change I made. The same is true if I restart
    the hbase service entirely or deploy the client configuration. The files
    get updated, but the change isn't included.
    If you go to HBase -> Master -> Processes -> Configuration
    Files/Environment -> hbase-site.xml, you should see it.

    This safety valve is for the server-side config only, and does not show up
    in /etc/hbase/conf or generated client config.

    Cheers,
    bc

    On Thu, Dec 27, 2012 at 11:22 AM, bc Wong wrote:
    On Thu, Dec 27, 2012 at 10:46 AM, Brennon Church wrote:

    Hello,

    Is there a way to configure replication, either master or slave, from
    within the CM Free GUI? Or do I need to edit hbase-site.xml directly?

    Thanks.

    --Brennon
    Hi Brennon,

    You can edit the "HBase Service Configuration Safety Valve for
    hbase-site.xml", paste in the "hbase.replication=true" XML snippet. The
    rest of the steps are manual on the CLI
    https://ccp.cloudera.com/display/CDH4DOC/HBase+Replication.

    Cheers,
    bc

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedDec 27, '12 at 6:46p
activeDec 27, '12 at 8:48p
posts5
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Brennon Church: 3 posts bc Wong: 2 posts

People

Translate

site design / logo © 2022 Grokbase