FAQ
my installation of oozie through seems to be successful. The webconsole is
up and -status returns NORMAL.

the config file includes

<property>
<name>oozie.service.HadoopAccessorService.nameNode.whitelist </name>
<value>ip-123.us-west-2.compute.internal:8020</value></property>


But, when i tried to configure one of the provided examples. I edited
examples/apps/map-reduce/job.properties property to property point to
this namenode. I get the error that this namenode is not whitelisted.

Not sure if this is something the cloudera manager is causing. I
wanted to wildcard the whitelist values. But, the limitation was i
couldnt seem to override these default values through manager. When
using the safety valve, you can add arbitrary xml to be inserted. But,
i am not sure what the behavior is for name,values defined twice. In
anycase it didnt take effect.

But, i had to resort to setting up my oozie manually with empty
values( wildcard ) for the whitelist.


thanks

Arun

Search Discussions

  • Arun Ramakrishnan at Dec 7, 2012 at 7:36 pm
    The exact error code is " E0901:
    Namenode [XXXXX:8020] not allowed, not in Oozies
    whitelist "

    On Fri, Dec 7, 2012 at 11:34 AM, Arun Ramakrishnan wrote:

    my installation of oozie through seems to be successful. The webconsole is
    up and -status returns NORMAL.

    the config file includes

    <property>
    <name>oozie.service.HadoopAccessorService.nameNode.whitelist </name>
    <value>ip-123.us-west-2.compute.internal:8020</value></property>


    But, when i tried to configure one of the provided examples. I edited examples/apps/map-reduce/job.properties property to property point to this namenode. I get the error that this namenode is not whitelisted.

    Not sure if this is something the cloudera manager is causing. I wanted to wildcard the whitelist values. But, the limitation was i couldnt seem to override these default values through manager. When using the safety valve, you can add arbitrary xml to be inserted. But, i am not sure what the behavior is for name,values defined twice. In anycase it didnt take effect.

    But, i had to resort to setting up my oozie manually with empty values( wildcard ) for the whitelist.


    thanks

    Arun
  • Udai Kiran Potluri at Dec 7, 2012 at 7:48 pm
    Hello Arun,

    Can you confirm that you have the same FQDN mentioned in your
    job.properties as you have in the safety valve?

    Thanks,
    Udai

    On Fri, Dec 7, 2012 at 11:36 AM, Arun Ramakrishnan wrote:

    The exact error code is " E0901:
    Namenode [XXXXX:8020] not allowed, not in Oozies
    whitelist "


    On Fri, Dec 7, 2012 at 11:34 AM, Arun Ramakrishnan <
    sinchronized.arun@gmail.com> wrote:
    my installation of oozie through seems to be successful. The webconsole
    is up and -status returns NORMAL.

    the config file includes

    <property>
    <name>oozie.service.HadoopAccessorService.nameNode.whitelist </name>
    <value>ip-123.us-west-2.compute.internal:8020</value></property>


    But, when i tried to configure one of the provided examples. I edited examples/apps/map-reduce/job.properties property to property point to this namenode. I get the error that this namenode is not whitelisted.

    Not sure if this is something the cloudera manager is causing. I wanted to wildcard the whitelist values. But, the limitation was i couldnt seem to override these default values through manager. When using the safety valve, you can add arbitrary xml to be inserted. But, i am not sure what the behavior is for name,values defined twice. In anycase it didnt take effect.

    But, i had to resort to setting up my oozie manually with empty values( wildcard ) for the whitelist.


    thanks

    Arun

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedDec 7, '12 at 7:34p
activeDec 7, '12 at 7:48p
posts3
users2
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase