FAQ
Hi,

I have installed HBASE, HDFS and Zookeeper on a single node. Now, I am
giving command
hbase shell;
next, when I fire command "list" at hbase prompt, I get this weird exception

ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able
to connect to ZooKeeper but the connection closes immediately. This could
be a sign that the server has too many connections (30 is the default).
Consider inspecting your ZK server logs for that error and then make sure
you are reusing HBaseConfiguration as often as you can. See HTable's
javadoc for more information.


Please help! Kindly direct me to the logs which I need to check! I am not
able to solve it from day before yesterday. Still today I am without luck!

Regards,
Shouvanik

--
Thanks,
*Shouvanik*

Search Discussions

  • bc Wong at Dec 4, 2012 at 6:35 pm

    On Tue, Dec 4, 2012 at 3:14 AM, Shouvanik Haldar wrote:

    Hi,

    I have installed HBASE, HDFS and Zookeeper on a single node. Now, I am
    giving command
    hbase shell;
    next, when I fire command "list" at hbase prompt, I get this weird
    exception

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able
    to connect to ZooKeeper but the connection closes immediately. This could
    be a sign that the server has too many connections (30 is the default).
    Consider inspecting your ZK server logs for that error and then make sure
    you are reusing HBaseConfiguration as often as you can. See HTable's
    javadoc for more information.


    Please help! Kindly direct me to the logs which I need to check! I am not
    able to solve it from day before yesterday. Still today I am without luck!
    For mailing list reference, this is a continuation of
    https://groups.google.com/a/cloudera.org/forum/?hl=en&fromgroups=#!topic/scm-users/Tbd0SPJ-45A
  • Shouvanik Haldar at Dec 4, 2012 at 6:41 pm
    please help me Wong.!

    On Wed, Dec 5, 2012 at 12:05 AM, bc Wong wrote:

    On Tue, Dec 4, 2012 at 3:14 AM, Shouvanik Haldar <
    shouvanik.haldar@gmail.com> wrote:
    Hi,

    I have installed HBASE, HDFS and Zookeeper on a single node. Now, I am
    giving command
    hbase shell;
    next, when I fire command "list" at hbase prompt, I get this weird
    exception

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is
    able to connect to ZooKeeper but the connection closes immediately. This
    could be a sign that the server has too many connections (30 is the
    default). Consider inspecting your ZK server logs for that error and then
    make sure you are reusing HBaseConfiguration as often as you can. See
    HTable's javadoc for more information.


    Please help! Kindly direct me to the logs which I need to check! I am not
    able to solve it from day before yesterday. Still today I am without luck!
    For mailing list reference, this is a continuation of
    https://groups.google.com/a/cloudera.org/forum/?hl=en&fromgroups=#!topic/scm-users/Tbd0SPJ-45A


    --
    Thanks,
    *Shouvanik*

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedDec 4, '12 at 11:14a
activeDec 4, '12 at 6:41p
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Shouvanik Haldar: 2 posts bc Wong: 1 post

People

Translate

site design / logo © 2022 Grokbase