FAQ
Did you make sure to disable Oozie version from CDH?

sudo service oozie stop
sudo update-rc.d -f oozie remove

reboot and try again with the .zip version of ext in the path.
On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards wrote:
I'm trying to get the Web UI for oozie working.

I've downloaded ext-2.2 to /var/lib/oozie/libext

I've tried extracting it directly to /var/lib/oozie/libext/,
then /var/lib/oozie/libext/ext-2.2
then simply placing the zip under /var/lib/oozie/libext

I've enabled the UI in CM.

Each time I restart oozie, visit the webUI and it always sys that I need to
install extJS

Thoughts?

Jesse


--
Ioan Eugen Stan / CTO / http://axemblr.com

Search Discussions

  • Jesse Edwards at Oct 29, 2012 at 6:03 pm
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that I need to
    install extJS

    Thoughts?

    Jesse
  • Jesse Edwards at Oct 29, 2012 at 6:54 pm
    I was trying to get everything working via CM. I setup the cluster via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via oozie-setup.sh
    but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.
    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that I need to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com
  • Joey Echeverria at Oct 29, 2012 at 5:35 pm
    If you're using CM, you need to follow these directions:

    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console

    -Joey
    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards wrote:
    I was trying to get everything working via CM. I setup the cluster via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.
    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that I need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Jesse Edwards at Oct 29, 2012 at 6:13 pm
    Joey-

    I followed the dirs and the interesting thing was there wasn't a /var/lib/oozie/oozie-server/
    folder at all I created these and gave the permissions still no go.

    Jesse
    On Monday, October 29, 2012 10:28:52 AM UTC-7, Joey Echeverria wrote:

    If you're using CM, you need to follow these directions:

    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console

    -Joey
    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards wrote:
    I was trying to get everything working via CM. I setup the cluster via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as
    zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.
    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that I
    need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Joey Echeverria at Oct 29, 2012 at 6:54 pm
    I don't have the oozie-server folder there either, but it works for
    me. Here's what I see:

    [root@centos62 oozie]# ls -l
    total 8
    drwxr-xr-x 5 oozie oozie 4096 Oct 29 14:49 data
    drwxr-xr-x 9 oozie oozie 4096 Aug 4 2008 ext-2.2

    Make sure that the zip file was extracted such that it created the
    ext-2.2 directory and then restart the service in CM after checking
    the box in the configuration GUI.

    -Joey
    On Mon, Oct 29, 2012 at 1:44 PM, Jesse Edwards wrote:
    Joey-

    I followed the dirs and the interesting thing was there wasn't a
    /var/lib/oozie/oozie-server/ folder at all I created these and gave the
    permissions still no go.

    Jesse
    On Monday, October 29, 2012 10:28:52 AM UTC-7, Joey Echeverria wrote:

    If you're using CM, you need to follow these directions:

    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console

    -Joey
    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards wrote:
    I was trying to get everything working via CM. I setup the cluster via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as
    zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.

    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards <jle.e...@gmail.com>
    wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that I
    need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Jesse Edwards at Oct 29, 2012 at 7:31 pm
    Verified that i had the ext-2.2 folder. Restarted same issue.

    So I removed the service using CM and reinstalled it to a different
    machine. Placed the ext-2.2 folder in the correct loc set permissions and
    started. Still no luck =(

    Jesse
    On Monday, October 29, 2012 11:54:10 AM UTC-7, Joey Echeverria wrote:

    I don't have the oozie-server folder there either, but it works for
    me. Here's what I see:

    [root@centos62 oozie]# ls -l
    total 8
    drwxr-xr-x 5 oozie oozie 4096 Oct 29 14:49 data
    drwxr-xr-x 9 oozie oozie 4096 Aug 4 2008 ext-2.2

    Make sure that the zip file was extracted such that it created the
    ext-2.2 directory and then restart the service in CM after checking
    the box in the configuration GUI.

    -Joey
    On Mon, Oct 29, 2012 at 1:44 PM, Jesse Edwards wrote:
    Joey-

    I followed the dirs and the interesting thing was there wasn't a
    /var/lib/oozie/oozie-server/ folder at all I created these and gave the
    permissions still no go.

    Jesse
    On Monday, October 29, 2012 10:28:52 AM UTC-7, Joey Echeverria wrote:

    If you're using CM, you need to follow these directions:
    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console
    -Joey
    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards wrote:
    I was trying to get everything working via CM. I setup the cluster
    via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as
    zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.

    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards <jle.e...@gmail.com>
    wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that
    I
    need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Joey Echeverria at Oct 30, 2012 at 7:29 pm
    Hi Jesse,

    I think you found a bug.

    I just started from scratch and did the following:

    cd /usr/lib/oozie/libext
    wget http://extjs.com/deploy/ext-2.2.zip
    unzip ext-2.2.zip
    chown -R oozie:oozie ext-2.2
    rm ext-2.2.zip

    I then popped over to the CM GUI and clicked the checkbox to enable
    the web console (see the screenshot).

    Finally, I restarted Oozie from CM, but the UI didn't come up.

    I was able to work around the issue by doing the following:

    cd /usr/lib/oozie/webapps/oozie
    ln -s /usr/lib/oozie/libext/ext-2.2

    I'll file an internal bug. This appears to be regression from version 4.0.

    -Joey
    On Mon, Oct 29, 2012 at 3:31 PM, Jesse Edwards wrote:
    Verified that i had the ext-2.2 folder. Restarted same issue.

    So I removed the service using CM and reinstalled it to a different machine.
    Placed the ext-2.2 folder in the correct loc set permissions and started.
    Still no luck =(

    Jesse

    On Monday, October 29, 2012 11:54:10 AM UTC-7, Joey Echeverria wrote:

    I don't have the oozie-server folder there either, but it works for
    me. Here's what I see:

    [root@centos62 oozie]# ls -l
    total 8
    drwxr-xr-x 5 oozie oozie 4096 Oct 29 14:49 data
    drwxr-xr-x 9 oozie oozie 4096 Aug 4 2008 ext-2.2

    Make sure that the zip file was extracted such that it created the
    ext-2.2 directory and then restart the service in CM after checking
    the box in the configuration GUI.

    -Joey
    On Mon, Oct 29, 2012 at 1:44 PM, Jesse Edwards wrote:
    Joey-

    I followed the dirs and the interesting thing was there wasn't a
    /var/lib/oozie/oozie-server/ folder at all I created these and gave the
    permissions still no go.

    Jesse
    On Monday, October 29, 2012 10:28:52 AM UTC-7, Joey Echeverria wrote:

    If you're using CM, you need to follow these directions:


    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console

    -Joey

    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards <jle.e...@gmail.com>
    wrote:
    I was trying to get everything working via CM. I setup the cluster
    via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it as
    zip.
    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan wrote:

    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.

    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards <jle.e...@gmail.com>
    wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys that
    I
    need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Jesse at Oct 30, 2012 at 7:27 pm
    Joey-

    Thanks for your work on this. I did the work around you mentioned and got
    this working

    Jesse
    On Tue, Oct 30, 2012 at 10:39 AM, Joey Echeverria wrote:

    Hi Jesse,

    I think you found a bug.

    I just started from scratch and did the following:

    cd /usr/lib/oozie/libext
    wget http://extjs.com/deploy/ext-2.2.zip
    unzip ext-2.2.zip
    chown -R oozie:oozie ext-2.2
    rm ext-2.2.zip

    I then popped over to the CM GUI and clicked the checkbox to enable
    the web console (see the screenshot).

    Finally, I restarted Oozie from CM, but the UI didn't come up.

    I was able to work around the issue by doing the following:

    cd /usr/lib/oozie/webapps/oozie
    ln -s /usr/lib/oozie/libext/ext-2.2

    I'll file an internal bug. This appears to be regression from version 4.0.

    -Joey
    On Mon, Oct 29, 2012 at 3:31 PM, Jesse Edwards wrote:
    Verified that i had the ext-2.2 folder. Restarted same issue.

    So I removed the service using CM and reinstalled it to a different machine.
    Placed the ext-2.2 folder in the correct loc set permissions and started.
    Still no luck =(

    Jesse

    On Monday, October 29, 2012 11:54:10 AM UTC-7, Joey Echeverria wrote:

    I don't have the oozie-server folder there either, but it works for
    me. Here's what I see:

    [root@centos62 oozie]# ls -l
    total 8
    drwxr-xr-x 5 oozie oozie 4096 Oct 29 14:49 data
    drwxr-xr-x 9 oozie oozie 4096 Aug 4 2008 ext-2.2

    Make sure that the zip file was extracted such that it created the
    ext-2.2 directory and then restart the service in CM after checking
    the box in the configuration GUI.

    -Joey
    On Mon, Oct 29, 2012 at 1:44 PM, Jesse Edwards wrote:
    Joey-

    I followed the dirs and the interesting thing was there wasn't a
    /var/lib/oozie/oozie-server/ folder at all I created these and gave
    the
    permissions still no go.

    Jesse
    On Monday, October 29, 2012 10:28:52 AM UTC-7, Joey Echeverria wrote:

    If you're using CM, you need to follow these directions:

    https://ccp.cloudera.com/display/FREE41DOC/Enabling+the+Oozie+Web+Console
    -Joey

    On Mon, Oct 29, 2012 at 1:19 PM, Jesse Edwards <jle.e...@gmail.com>
    wrote:
    I was trying to get everything working via CM. I setup the cluster
    via
    Cloudera Manager and configured oozie via this.

    I looked at doing the option of passing the location to ext via
    oozie-setup.sh but this file does not appear to be on the server.

    CDH4 directions specifically say to extract the file not leave it
    as
    zip.

    On Monday, October 29, 2012 10:07:24 AM UTC-7, Ioan Eugen Stan
    wrote:
    Did you make sure to disable Oozie version from CDH?

    sudo service oozie stop
    sudo update-rc.d -f oozie remove

    reboot and try again with the .zip version of ext in the path.

    On Mon, Oct 29, 2012 at 7:04 PM, Jesse Edwards <
    jle.e...@gmail.com>
    wrote:
    I'm trying to get the Web UI for oozie working.

    I've downloaded ext-2.2 to /var/lib/oozie/libext

    I've tried extracting it directly to /var/lib/oozie/libext/,
    then /var/lib/oozie/libext/ext-2.2
    then simply placing the zip under /var/lib/oozie/libext

    I've enabled the UI in CM.

    Each time I restart oozie, visit the webUI and it always sys
    that
    I
    need
    to
    install extJS

    Thoughts?

    Jesse


    --
    Ioan Eugen Stan / CTO / http://axemblr.com


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.


    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedOct 29, '12 at 5:12p
activeOct 30, '12 at 7:29p
posts9
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase