FAQ
Hi All,

I'm setting up Hadoop on GCE clusters using Cloudera Manager. While I
was going through the installation guide, It was mentioned that the
port used for the web UI by Cloudera Manager Server is 7180. However,
in our institutue it is not open. Can we use the standard 80 port. If
so, how do I change the port configurations.

Thanks,
Ranjani

Search Discussions

  • Philip Zeyliger at Oct 16, 2012 at 4:47 am
    Hi Ranjani,

    The port is configurable from the UI itself. If you can't connect there (a
    common trick is to use ssh to do port forwarding), you can edit the
    database configured in /etc/cloudera-scm-server/db.properites directly:

    mysql> update SETTINGS set HTTP_PORT=80;
    Query OK, 0 rows affected (0.08 sec)
    Rows matched: 1 Changed: 0 Warnings: 0

    Note that this only applies to versions 3.7-4.0.

    Cheers,

    -- Philip
    On Mon, Oct 15, 2012 at 8:24 PM, Ranjani Malayankulam Ramesh wrote:

    Hi All,

    I'm setting up Hadoop on GCE clusters using Cloudera Manager. While I
    was going through the installation guide, It was mentioned that the
    port used for the web UI by Cloudera Manager Server is 7180. However,
    in our institutue it is not open. Can we use the standard 80 port. If
    so, how do I change the port configurations.

    Thanks,
    Ranjani
  • Ranjani Malayankulam Ramesh at Oct 16, 2012 at 4:00 am
    Thank you so much.

    I wanted to try to change it from UI so I tried installing Cloudera
    manger using the following instructions.

    1. Download cloudera-manager-installer.bin from the Cloudera Downloads
    page to the
    host where you want to install the Cloudera Manager Server that is
    on your cluster or is
    accessible to your cluster over your network. Install Cloudera
    Manager on a single host.
    2. After downloading cloudera-manager-installer.bin, change it to have
    executable
    permission.

    Command: chmod u+x coudera-manager-installer.bin

    3. Run cloudera-manager-installer.bin.

    Command: sudo ./cloudera-manager-installer.bin
    4. Read the Cloudera Manager Readme and then press Enter to choose
    Next.

    Read the Cloudera Manager License and then press Enter to choose
    Next. Use the arrow keys
    and press Enter to choose Yes to confirm you accept the license.

    5. Read the Oracle Binary Code License Agreement and then press Enter
    to choose Next. Use the
    arrow keys and press Enter to choose Yes to confirm you accept the
    Oracle Binary Code License Agreement.


    All these went fine. But then I get a fatal error when it tries to
    refresh the packages.
    I get the following error.

    "...rr http://archive.cloudera.com precise-cm4 Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)"

    I'm new to Linux programming . It would be great if you can help me
    resolve this.

    Thanks,
    Ranjani

    On Oct 16, 11:51 am, Philip Zeyliger wrote:
    Hi Ranjani,

    The port is configurable from the UI itself.  If you can't connect there (a
    common trick is to use ssh to do port forwarding), you can edit the
    database configured in /etc/cloudera-scm-server/db.properites directly:

    mysql> update SETTINGS set HTTP_PORT=80;
    Query OK, 0 rows affected (0.08 sec)
    Rows matched: 1  Changed: 0  Warnings: 0

    Note that this only applies to versions 3.7-4.0.

    Cheers,

    -- Philip

    On Mon, Oct 15, 2012 at 8:24 PM, Ranjani Malayankulam Ramesh <







    ranjanimr1...@gmail.com> wrote:
    Hi All,
    I'm setting up Hadoop on GCE clusters using Cloudera Manager. While I
    was going through the installation guide, It was mentioned that the
    port used for the web UI by Cloudera Manager Server is 7180. However,
    in our institutue it is not open. Can we use the standard 80 port. If
    so, how do I change the port configurations.
    Thanks,
    Ranjani

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedOct 16, '12 at 3:24a
activeOct 16, '12 at 4:47a
posts3
users2
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase