FAQ
Hi , I have installed Cloudera CM 4 on an independent machine. On a
seperate machine I have installed datanode and tasktracker. I have an
embedded postgresql 8.4 installed. Now that I have installed cloudera
scm-agent installed on my data node and start the service on it , it
starts with no issues but in the cloudera server manager console , it
dosnt show up under managed hosts. I have restarted the CM server but
still no effect, also changed the cloudera-scm-agent config file to
put the FQDN of the server in it. In the log for cloudera-scm-agent
log I get the following error :

[12/Sep/2012 12:27:04 +0000] 13840 MainThread agent ERROR
Heartbeating to cm.diacs.ssa.gov:7180 failed.
Traceback (most recent call last):
File "/usr/lib64/cmf/agent/src/cmf/agent.py", line 564, in
send_heartbeat
response = self.requestor.request('heartbeat',
dict(request=heartbeat))
File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
avro-1.6.3-py2.6.egg/avro/ipc.py", line 145, in request
return self.issue_request(call_request, message_name,
request_datum)
File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
avro-1.6.3-py2.6.egg/avro/ipc.py", line 256, in issue_request
call_response = self.transceiver.transceive(call_request)
File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
avro-1.6.3-py2.6.egg/avro/ipc.py", line 485, in transceive
result = self.read_framed_message()
File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
avro-1.6.3-py2.6.egg/avro/ipc.py", line 491, in read_framed_message
framed_message = response_reader.read_framed_message()
File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
avro-1.6.3-py2.6.egg/avro/ipc.py", line 419, in read_framed_message
raise ConnectionClosedException("Reader read 0 bytes.")
ConnectionClosedException: Reader read 0 bytes.

BTW : All my versions are updated i.e 4.0.4-1cm404.p079.x86_64

Any Ideas ?

Thanks in Advance

Search Discussions

  • Philip Zeyliger at Sep 12, 2012 at 5:32 pm
    Hi there,

    The heartbeating typically goes to port 7182, not 7180. 7180 is typically
    the web UI, and the heartbeat port is typically 7182. What's your
    /etc/cloudera-scm-agent/config.ini look like?
    On Wed, Sep 12, 2012 at 10:26 AM, LinuxLife wrote:

    Hi , I have installed Cloudera CM 4 on an independent machine. On a
    seperate machine I have installed datanode and tasktracker. I have an
    embedded postgresql 8.4 installed. Now that I have installed cloudera
    scm-agent installed on my data node and start the service on it , it
    starts with no issues but in the cloudera server manager console , it
    dosnt show up under managed hosts. I have restarted the CM server but
    still no effect, also changed the cloudera-scm-agent config file to
    put the FQDN of the server in it. In the log for cloudera-scm-agent
    log I get the following error :

    [12/Sep/2012 12:27:04 +0000] 13840 MainThread agent ERROR
    Heartbeating to cm.diacs.ssa.gov:7180 failed.
    Traceback (most recent call last):
    File "/usr/lib64/cmf/agent/src/cmf/agent.py", line 564, in
    send_heartbeat
    response = self.requestor.request('heartbeat',
    dict(request=heartbeat))
    File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
    avro-1.6.3-py2.6.egg/avro/ipc.py", line 145, in request
    return self.issue_request(call_request, message_name,
    request_datum)
    File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
    avro-1.6.3-py2.6.egg/avro/ipc.py", line 256, in issue_request
    call_response = self.transceiver.transceive(call_request)
    File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
    avro-1.6.3-py2.6.egg/avro/ipc.py", line 485, in transceive
    result = self.read_framed_message()
    File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
    avro-1.6.3-py2.6.egg/avro/ipc.py", line 491, in read_framed_message
    framed_message = response_reader.read_framed_message()
    File "/usr/lib64/cmf/agent/build/env/lib/python2.6/site-packages/
    avro-1.6.3-py2.6.egg/avro/ipc.py", line 419, in read_framed_message
    raise ConnectionClosedException("Reader read 0 bytes.")
    ConnectionClosedException: Reader read 0 bytes.

    BTW : All my versions are updated i.e 4.0.4-1cm404.p079.x86_64

    Any Ideas ?

    Thanks in Advance
  • LinuxLife at Sep 12, 2012 at 6:52 pm
    Hi Philip !

    $ cat /etc/cloudera-scm-agent/config.ini

    [General]
    # Hostname of Cloudera SCM Server
    server_host=cm.x.x.x
    # Port that server is listening on
    server_port=7180

    ## It should not normally be necessary to modify these.
    # Port that Agent should listen on
    # listening_port=9000

    # IP Address that Agent should listen on
    # listening_ip=

    # Hostname that Agent reports as its hostname
    # listening_hostname=

    # Log file
    # log_file=/var/log/cloudera-scm-agent/cloudera-scm-agent.log

    # Heartbeat optimizations.
    # enable_eager_heartbeats=true

    # Monitoring max collection wait in seconds.
    max_collection_wait_seconds=10.0

    # Monitoring metric collection timeout in seconds.
    metrics_url_timeout_seconds=30.0

    # Monitoring task collection timeout in seconds.
    task_metrics_timeout_seconds=5.0

    [Security]
    use_tls=0
    # verify_cert_file=
    # client_key_file=
    # client_keypw_file=
    # client_cert_file=

    ## Location of Hadoop files. These are the CDH locations.
    #[Hadoop]
    #cdh_hadoop_home=/usr/lib/hadoop
    #cdh_mr1_home=/usr/lib/hadoop-0.20-mapreduce
    #cdh_hdfs_home=/usr/lib/hadoop-hdfs
    #cdh_httfs_home=/usr/lib/hadoop-httpfs
    #cdh_mr2_home=/usr/lib/hadoop-mapreduce
    #cdh_yarn_home=/usr/lib/hadoop
    #cdh_hbase_home=/usr/lib/hbase
    #cdh_zookeeper_home=/usr/lib/zookeeper
    #cdh_hive_home=/usr/lib/hive
    #hive_default_xml=/usr/lib/hive/conf/hive-default.xml
    #cdh_hue_home=/usr/share/hue
    #tomcat_home=/usr/lib/bigtop-tomcat
    #cdh_oozie_home=/usr/lib/oozie
    #jsvc_home=/usr/libexec/bigtop-utils

    ## Location of Cloudera Management Suite Binaries
    #[Cloudera]
    #mgmt_home=/usr/share/cmf

    Thanks
  • Philip Zeyliger at Sep 12, 2012 at 6:48 pm

    On Wed, Sep 12, 2012 at 11:46 AM, LinuxLife wrote:

    Hi Philip !

    $ cat /etc/cloudera-scm-agent/config.ini

    [General]
    # Hostname of Cloudera SCM Server
    server_host=cm.x.x.x
    # Port that server is listening on
    server_port=7180
    This should almost certainly be 7182. In your server settings, it's this
    one:

    [image: Inline image 1]


    ## It should not normally be necessary to modify these.
    # Port that Agent should listen on
    # listening_port=9000

    # IP Address that Agent should listen on
    # listening_ip=

    # Hostname that Agent reports as its hostname
    # listening_hostname=

    # Log file
    # log_file=/var/log/cloudera-scm-agent/cloudera-scm-agent.log

    # Heartbeat optimizations.
    # enable_eager_heartbeats=true

    # Monitoring max collection wait in seconds.
    max_collection_wait_seconds=10.0

    # Monitoring metric collection timeout in seconds.
    metrics_url_timeout_seconds=30.0

    # Monitoring task collection timeout in seconds.
    task_metrics_timeout_seconds=5.0

    [Security]
    use_tls=0
    # verify_cert_file=
    # client_key_file=
    # client_keypw_file=
    # client_cert_file=

    ## Location of Hadoop files. These are the CDH locations.
    #[Hadoop]
    #cdh_hadoop_home=/usr/lib/hadoop
    #cdh_mr1_home=/usr/lib/hadoop-0.20-mapreduce
    #cdh_hdfs_home=/usr/lib/hadoop-hdfs
    #cdh_httfs_home=/usr/lib/hadoop-httpfs
    #cdh_mr2_home=/usr/lib/hadoop-mapreduce
    #cdh_yarn_home=/usr/lib/hadoop
    #cdh_hbase_home=/usr/lib/hbase
    #cdh_zookeeper_home=/usr/lib/zookeeper
    #cdh_hive_home=/usr/lib/hive
    #hive_default_xml=/usr/lib/hive/conf/hive-default.xml
    #cdh_hue_home=/usr/share/hue
    #tomcat_home=/usr/lib/bigtop-tomcat
    #cdh_oozie_home=/usr/lib/oozie
    #jsvc_home=/usr/libexec/bigtop-utils

    ## Location of Cloudera Management Suite Binaries
    #[Cloudera]
    #mgmt_home=/usr/share/cmf

    Thanks
  • LinuxLife at Sep 12, 2012 at 7:01 pm
    ok Philip , I changed the value of "server_port=7180 " to
    server_port=7182" and it worked like a charm.
    Thanks for pointing that out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedSep 12, '12 at 5:32p
activeSep 12, '12 at 7:01p
posts5
users2
websitecloudera.com
irc#hadoop

2 users in discussion

LinuxLife: 3 posts Philip Zeyliger: 2 posts

People

Translate

site design / logo © 2022 Grokbase