FAQ
I have been successfully running a CDH4 cluster, and after recently trying
to run the host upgrade wizard I came across this error on one of my nodes
(it runs namenode, datanode, oozie server, jobtracker, and tasktracker).

It looks like I have some python libs installed, but a newer version:

[root@hadoop-dev-node01 ~]# yum list installed *python-lib*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.lstn.net
* epel: mirrors.xmission.com
* extras: mirrors.adams.net
* updates: mirrors.xmission.com
Installed Packages
python-libs.x86_64
2.6.6-29.el6_2.2
@updates

Any ideas? I saw a similar thread relating to a CDH3 installation, but that
solution won't work for me.




Installing cloudera-manager-agent package...BEGIN yum info
cloudera-manager-agent
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.lstn.net
* epel: mirrors.xmission.com
* extras: mirrors.adams.net
* updates: mirrors.xmission.com
Installed Packages
Name : cloudera-manager-agent
Arch : x86_64
Version : 4.0.2
Release : 1.cm402.p0.26
Size : 16 M
Repo : installed
From repo : cloudera-manager
Summary : The Cloudera Manager Agent
URL : http://www.cloudera.com
License : Proprietary
Description : The Cloudera Manager Agent.
:
: The Agent is deployed to machines running services managed by
: Cloudera Manager.

Available Packages
Name : cloudera-manager-agent
Arch : x86_64
Version : 4.0.4
Release : 1.cm404.p0.79
Size : 3.6 M
Repo : cloudera-manager
Summary : The Cloudera Manager Agent
URL : http://www.cloudera.com
License : Proprietary
Description : The Cloudera Manager Agent.
:
: The Agent is deployed to machines running services managed by
: Cloudera Manager.

END (0)
BEGIN yum list installed cloudera-manager-agent
Loaded plugins: fastestmirror
Installed Packages
cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
END (0)
BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
cloudera-manager-agent
cloudera-manager-agent cloudera-manager-daemons
END (0)
BEGIN yum -y install cloudera-manager-agent
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.lstn.net
* epel: mirrors.xmission.com
* extras: mirrors.adams.net
* updates: mirrors.xmission.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will be
updated
---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will be an
update
--> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
--> Finished Dependency Resolution
Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
(cloudera-manager)
Requires: libpython2.4.so.1.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
END (1)
remote package cloudera-manager-agent could not be installed, giving up

Search Discussions

  • Dan Richelson at Sep 4, 2012 at 3:48 pm
    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:

    I have been successfully running a CDH4 cluster, and after recently trying
    to run the host upgrade wizard I came across this error on one of my nodes
    (it runs namenode, datanode, oozie server, jobtracker, and tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...BEGIN yum info
    cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up
  • Vivek Shrivastava at Sep 4, 2012 at 8:34 pm
    Please check if you have Python2.4 installed or not. I think some config in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path )
    and see if it works..
    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson wrote:

    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:

    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...BEGIN yum info
    cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-**1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-**1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up
  • Dan Richelson at Sep 4, 2012 at 7:36 pm
    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:
    Please check if you have Python2.4 installed or not. I think some config in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path )
    and see if it works..
    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson wrote:

    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:

    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up


    --
    Dan Richelson, Software Engineer

    Tendril
    2560 55th St. | Boulder, Colorado 80301
    M 303-709-2214
    www.tendrilinc.com

    This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
    If you have received this email in error please notify the sender.
    Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
    Finally, the recipient should check this email and any attachments for the presence of viruses.
    The company accepts no liability for any damage caused by any virus transmitted by this email.
  • Casey Ching at Sep 4, 2012 at 7:52 pm
    It looks like your system was detected as a centos/rhel 5 instead of 6.
    Near the top of the "Details" of the install script, there should be
    some OS detection info, can you post that info?

    Or you can post this info --

    [root@centos62-5 ~]# cat /etc/redhat-release
    CentOS release 6.2 (Final)

    [root@centos62-5 ~]# lsb_release -a
    LSB Version:
    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
    Distributor ID: CentOS
    Description: CentOS release 6.2 (Final)
    Release: 6.2
    Codename: Final

    If yours looks the same, you might try "yum clean all".
    On Tue 04 Sep 2012 12:36:48 PM PDT, Dan Richelson wrote:

    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:
    Please check if you have Python2.4 installed or not. I think some
    config in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path )
    and see if it works..

    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson <drichelson@tendrilinc.com>
    wrote:

    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:


    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on
    one of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26
    will be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79
    will be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up
  • Dan Richelson at Sep 4, 2012 at 8:31 pm
    Thanks.. It looks like it is finding CentOS 6 ok:

    Detecting distribution...
    BEGIN grep Tikanga /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 5' /etc/redhat-release
    END (1)
    BEGIN grep Santiago /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS Linux release 6' /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 6' /etc/redhat-release
    CentOS release 6.2 (Final)
    END (0)
    /etc/redhat-release ==> CentOS 6
    On Tue, Sep 4, 2012 at 1:52 PM, Casey Ching wrote:
    It looks like your system was detected as a centos/rhel 5 instead of 6. Near
    the top of the "Details" of the install script, there should be some OS
    detection info, can you post that info?

    Or you can post this info --

    [root@centos62-5 ~]# cat /etc/redhat-release
    CentOS release 6.2 (Final)

    [root@centos62-5 ~]# lsb_release -a
    LSB Version:
    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
    Distributor ID: CentOS
    Description: CentOS release 6.2 (Final)
    Release: 6.2
    Codename: Final

    If yours looks the same, you might try "yum clean all".

    On Tue 04 Sep 2012 12:36:48 PM PDT, Dan Richelson wrote:


    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:

    Please check if you have Python2.4 installed or not. I think some config
    in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path )
    and see if it works..

    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson <drichelson@tendrilinc.com>
    wrote:


    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:



    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one
    of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will
    be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will
    be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up


    --
    Dan Richelson, Software Engineer

    Tendril
    2560 55th St. | Boulder, Colorado 80301
    M 303-709-2214
    www.tendrilinc.com

    This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
    If you have received this email in error please notify the sender.
    Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
    Finally, the recipient should check this email and any attachments for the presence of viruses.
    The company accepts no liability for any damage caused by any virus transmitted by this email.
  • Casey Ching at Sep 4, 2012 at 8:37 pm
    Can you check that there aren't any cloudera related .repo files in
    /etc/yum.repos.d/

    I verified that our centos 6 package doesn't require that centos 5 file.

    [root@centos62-5 tmp]# wget
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/4/RPMS/x86_64/cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm
    --2012-09-04 13:30:50--
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/4/RPMS/x86_64/cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm
    Resolving archive.cloudera.com... 75.101.147.51
    Connecting to archive.cloudera.com|75.101.147.51|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 2984488 (2.8M) [application/x-redhat-package-manager]
    Saving to: “cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm”

    100%[====================================================================================================================================================================>]
    2,984,488 1.69M/s in 1.7s

    2012-09-04 13:30:52 (1.69 MB/s) -
    “cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm” saved
    [2984488/2984488]

    [root@centos62-5 tmp]# rpm -qpR
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm | grep libpython
    warning: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm: Header
    V4 DSA/SHA1 Signature, key ID e8f86acd: NOKEY
    libpython2.6.so.1.0()(64bit)
    On Tue 04 Sep 2012 01:25:16 PM PDT, Dan Richelson wrote:

    Thanks.. It looks like it is finding CentOS 6 ok:

    Detecting distribution...
    BEGIN grep Tikanga /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 5' /etc/redhat-release
    END (1)
    BEGIN grep Santiago /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS Linux release 6' /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 6' /etc/redhat-release
    CentOS release 6.2 (Final)
    END (0)
    /etc/redhat-release ==> CentOS 6
    On Tue, Sep 4, 2012 at 1:52 PM, Casey Ching wrote:

    It looks like your system was detected as a centos/rhel 5 instead of
    6. Near
    the top of the "Details" of the install script, there should be some OS
    detection info, can you post that info?

    Or you can post this info --

    [root@centos62-5 ~]# cat /etc/redhat-release
    CentOS release 6.2 (Final)

    [root@centos62-5 ~]# lsb_release -a
    LSB Version:
    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
    Distributor ID: CentOS
    Description: CentOS release 6.2 (Final)
    Release: 6.2
    Codename: Final

    If yours looks the same, you might try "yum clean all".

    On Tue 04 Sep 2012 12:36:48 PM PDT, Dan Richelson wrote:



    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:


    Please check if you have Python2.4 installed or not. I think some
    config
    in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your
    path )
    and see if it works..

    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson
    <drichelson@tendrilinc.com>
    wrote:



    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:




    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one
    of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3
    installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will
    be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will
    be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed,
    giving up


  • Dan Richelson at Sep 5, 2012 at 12:01 am
    Thanks!
    I did 2 things:
    1. I followed Casey's advice and installed the rpm
    2. When the upgrade wizard starts, I specified:
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/4/ as the repo

    Upgrade wizard completed successfully and my cluster is back up

    On Tue, Sep 4, 2012 at 2:37 PM, Casey Ching wrote:
    Can you check that there aren't any cloudera related .repo files in
    /etc/yum.repos.d/

    I verified that our centos 6 package doesn't require that centos 5 file.

    [root@centos62-5 tmp]# wget
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/4/RPMS/x86_64/cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm
    --2012-09-04 13:30:50--
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/4/RPMS/x86_64/cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm
    Resolving archive.cloudera.com... 75.101.147.51
    Connecting to archive.cloudera.com|75.101.147.51|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 2984488 (2.8M) [application/x-redhat-package-manager]
    Saving to: “cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm”

    100%[====================================================================================================================================================================>]
    2,984,488 1.69M/s in 1.7s

    2012-09-04 13:30:52 (1.69 MB/s) -
    “cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm” saved
    [2984488/2984488]

    [root@centos62-5 tmp]# rpm -qpR
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm | grep libpython
    warning: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64.rpm: Header V4
    DSA/SHA1 Signature, key ID e8f86acd: NOKEY
    libpython2.6.so.1.0()(64bit)

    On Tue 04 Sep 2012 01:25:16 PM PDT, Dan Richelson wrote:


    Thanks.. It looks like it is finding CentOS 6 ok:

    Detecting distribution...
    BEGIN grep Tikanga /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 5' /etc/redhat-release
    END (1)
    BEGIN grep Santiago /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS Linux release 6' /etc/redhat-release
    END (1)
    BEGIN grep 'CentOS release 6' /etc/redhat-release
    CentOS release 6.2 (Final)
    END (0)
    /etc/redhat-release ==> CentOS 6
    On Tue, Sep 4, 2012 at 1:52 PM, Casey Ching wrote:


    It looks like your system was detected as a centos/rhel 5 instead of 6.
    Near
    the top of the "Details" of the install script, there should be some OS
    detection info, can you post that info?

    Or you can post this info --

    [root@centos62-5 ~]# cat /etc/redhat-release
    CentOS release 6.2 (Final)

    [root@centos62-5 ~]# lsb_release -a
    LSB Version:

    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
    Distributor ID: CentOS
    Description: CentOS release 6.2 (Final)
    Release: 6.2
    Codename: Final

    If yours looks the same, you might try "yum clean all".

    On Tue 04 Sep 2012 12:36:48 PM PDT, Dan Richelson wrote:




    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:



    Please check if you have Python2.4 installed or not. I think some
    config
    in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path
    )
    and see if it works..

    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson
    <drichelson@tendrilinc.com>
    wrote:




    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:





    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one
    of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation,
    but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will
    be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will
    be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving
    up





    --
    Dan Richelson, Software Engineer

    Tendril
    2560 55th St. | Boulder, Colorado 80301
    M 303-709-2214
    www.tendrilinc.com

    This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
    If you have received this email in error please notify the sender.
    Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
    Finally, the recipient should check this email and any attachments for the presence of viruses.
    The company accepts no liability for any damage caused by any virus transmitted by this email.
  • Philip Zeyliger at Sep 4, 2012 at 8:41 pm
    Hi Dan,

    You're using RH5 RPMs on a RH6 system. Use
    http://archive.cloudera.com/cm4/redhat/5/x86_64/cm/ for RH5 and
    http://archive.cloudera.com/cm4/redhat/6/x86_64/cm/ for RH6.

    Let me us know if that doesn't make sense; I assume you've done a
    mirror of our repo, since our installer should have picked the right
    stuff for you automatically.

    Cheers,

    -- Philip


    On Tue, Sep 4, 2012 at 12:36 PM, Dan Richelson
    wrote:
    It looks like I don't have python 2.4 installed- It seems like this is
    necessary for cloudera manager. I can start looking for a yum repo
    that will allow me to install it.

    [root@hadoop-dev-node01 bin]# python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# ls /usr/bin/python*
    /usr/bin/python /usr/bin/python2 /usr/bin/python2.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]# /usr/bin/python2 --version
    Python 2.6.6
    [root@hadoop-dev-node01 bin]#


    [root@hadoop-dev-node01 bin]# yum list installed *python*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python.x86_64
    2.6.6-29.el6_2.2
    @updates
    [root@hadoop-dev-node01 bin]#


    On Tue, Sep 4, 2012 at 1:29 PM, Vivek Shrivastava
    wrote:
    Please check if you have Python2.4 installed or not. I think some config in
    yum is python2.4 dependent. If Python2.4 is already installed, please
    symlink /usr/bin/python to /usr/bin/python2.4 ( please adjust your path )
    and see if it works..

    On Tue, Sep 4, 2012 at 8:41 AM, Dan Richelson <drichelson@tendrilinc.com>
    wrote:
    Apologies, I forgot to include some basic info on my hosts:
    CentOS 6.2 64-bit


    On Tuesday, September 4, 2012 9:37:33 AM UTC-6, Dan Richelson wrote:

    I have been successfully running a CDH4 cluster, and after recently
    trying to run the host upgrade wizard I came across this error on one of my
    nodes (it runs namenode, datanode, oozie server, jobtracker, and
    tasktracker).

    It looks like I have some python libs installed, but a newer version:

    [root@hadoop-dev-node01 ~]# yum list installed *python-lib*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    python-libs.x86_64
    2.6.6-29.el6_2.2
    @updates

    Any ideas? I saw a similar thread relating to a CDH3 installation, but
    that solution won't work for me.




    Installing cloudera-manager-agent package...

    BEGIN yum info cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Installed Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.2
    Release : 1.cm402.p0.26
    Size : 16 M
    Repo : installed
    From repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    Available Packages
    Name : cloudera-manager-agent
    Arch : x86_64
    Version : 4.0.4
    Release : 1.cm404.p0.79
    Size : 3.6 M
    Repo : cloudera-manager
    Summary : The Cloudera Manager Agent
    URL : http://www.cloudera.com
    License : Proprietary
    Description : The Cloudera Manager Agent.
    :
    : The Agent is deployed to machines running services managed by
    : Cloudera Manager.

    END (0)
    BEGIN yum list installed cloudera-manager-agent
    Loaded plugins: fastestmirror
    Installed Packages
    cloudera-manager-agent.x86_64 4.0.2-1.cm402.p0.26 @cloudera-manager
    END (0)
    BEGIN echo cloudera-manager-agent cloudera-manager-daemons | grep
    cloudera-manager-agent
    cloudera-manager-agent cloudera-manager-daemons
    END (0)
    BEGIN yum -y install cloudera-manager-agent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.lstn.net
    * epel: mirrors.xmission.com
    * extras: mirrors.adams.net
    * updates: mirrors.xmission.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cloudera-manager-agent.x86_64 0:4.0.2-1.cm402.p0.26 will be
    updated
    ---> Package cloudera-manager-agent.x86_64 0:4.0.4-1.cm404.p0.79 will be
    an update
    --> Processing Dependency: libpython2.4.so.1.0()(64bit) for package:
    cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    --> Finished Dependency Resolution
    Error: Package: cloudera-manager-agent-4.0.4-1.cm404.p0.79.x86_64
    (cloudera-manager)
    Requires: libpython2.4.so.1.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    END (1)
    remote package cloudera-manager-agent could not be installed, giving up


    --
    Dan Richelson, Software Engineer

    Tendril
    2560 55th St. | Boulder, Colorado 80301
    M 303-709-2214
    www.tendrilinc.com

    This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
    If you have received this email in error please notify the sender.
    Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
    Finally, the recipient should check this email and any attachments for the presence of viruses.
    The company accepts no liability for any damage caused by any virus transmitted by this email.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedSep 4, '12 at 3:37p
activeSep 5, '12 at 12:01a
posts9
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase