FAQ
(bcc:cdh-user, +scm-users)

I'm moving this to scm-users@cloudera.org since it's a Cloudera
Manager question.

Which version of CM are you running? We found a similar bug with
setting the wildcard for the namenode that was fixed in 4.0.4. Can you
try upgrading if you're not on the latest?

If you are on 4.0.4, then you probably found another bug. In the mean
time, you can work around it by copying the following into the safety
valve:

<property>
   <name>dfs.datanode.ipc.address</name>
   <value>0.0.0.0:50020</value>
</property>

<property>
   <name>dfs.datanode.address<name>
   <value>0.0.0.0:50010</value>
</property>

<property>
   <name>dfs.datanode.http.address</name>
   <value>0.0.0.0:50075</value>
</property>

<property>
   <name>dfs.http.address, dfs.namenode.http-address</name>
   <value>0.0.0.0:50070</value>
</property>

<property>
   <name>dfs.namenode.secondary.http-address</name>
   <value>0.0.0.0:50090</value>
</property>

-Joey
On Mon, Aug 27, 2012 at 10:11 AM, ansonism wrote:
I have separate VLANs for my hadoop cluster. When I set the Bind DataNode
to WildCard Address to true, i'd assume the ports would apply to all
Addresses (0.0.0.0). However when I look @ the ports:

TCP *:8020 (LISTEN)
TCP 192.168.1.101:50070 (LISTEN)
TCP 192.168.1.101:50010 (LISTEN)
TCP 192.168.1.101:50075 (LISTEN)
TCP 192.168.1.101:50020 (LISTEN)
TCP 192.168.1.101: 50090 (LISTEN)


DataNode Protocol Port (dfs.datanode.ipc.address) is 50020
DataNode Transceiver Port (dfs.datanode.address) is 50010
DataNode HTTP Web UI Port (dfs.datanode.http.address) is 50075
NameNode Web UI Port (dfs.http.address, dfs.namenode.http-address) is 50070
SecondaryNameNode Web UI Port (dfs.secondary.http.address,
dfs.namenode.secondary.http-address) is 50090


I was trying to do a distcp from another hadoop cluster. It only has access
to the 192.168.0 subnet. .1 is not available to anything except internal on
purpose. But when I do a distcp the transceiver port is using the .1 subnet
(192.168.1.101:50010). I'm @ a loss as to why this is. I thought by
setting the Bind Datanode to wildcard that it would force the Tranceiver
port to be wildcard (ie TCP *:50010 ). Is there anyway I can force it, w/o
having to add the other cluster on the same vlan?

--



--
Joey Echeverria
Principal Solutions Architect
Cloudera, Inc.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedAug 28, '12 at 11:37a
activeAug 28, '12 at 11:37a
posts1
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Joey Echeverria: 1 post

People

Translate

site design / logo © 2022 Grokbase