FAQ
All,


I'm trying to set the HDFS Safety Value to disable the dfs.permissions
flag. This is what I've inserted into the field:

<property>
   <name>dfs.permissions</name>
   <value>false</value>
</property>

The configuration saves fine, but when I try to restart the HDFS service I
get the following error:


Command failed to start:
com.cloudera.cmf.service.config.ConfigGenException: Unable to generate
config file hdfs-site.xml for role with type NAMENODE: Unable to parse XML
safety valve


I can't really find where I'm going wrong. Am I missing something or is
this a bug I need to file?

Thanks,
-Nik

Search Discussions

  • Harsh J at Aug 21, 2012 at 2:16 am
    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J
  • Nik Hodgkinson at Aug 21, 2012 at 2:23 am
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.
  • Harsh J at Aug 21, 2012 at 2:28 am
    Thanks for the quick update and the attachment Nik,

    Looks like windows newline characters are the issue, possibly:

    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>

    Was this copied from some text? Perhaps you can remove the \r
    characters (copy-paste to any text editor, ask editor to strip out the
    \rs and copy-paste back) and retry?
    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:

    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J


    --
    Harsh J
  • Harsh J at Aug 21, 2012 at 2:30 am
    Nik,

    (Or alternatively you can just erase the field and type it in
    manually. Browsers don't add \r AFAIK)

    Meanwhile, I've also filed for an improvement internally to perhaps
    catch and sanitize it automatically. Many thanks for reporting this
    in!
    On Tue, Aug 21, 2012 at 7:58 AM, Harsh J wrote:
    Thanks for the quick update and the attachment Nik,

    Looks like windows newline characters are the issue, possibly:

    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>

    Was this copied from some text? Perhaps you can remove the \r
    characters (copy-paste to any text editor, ask editor to strip out the
    \rs and copy-paste back) and retry?
    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:

    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J
  • Nik Hodgkinson at Aug 21, 2012 at 2:49 am
    How strange, I'm on a Mac and I typed it in manually. I'll see what's can do to strip out the carriage returns and get back to you.

    -N
    11xor6@gmail.com
    (913)927-4891
    On Aug 20, 2012, at 7:30 PM, Harsh J wrote:

    Nik,

    (Or alternatively you can just erase the field and type it in
    manually. Browsers don't add \r AFAIK)

    Meanwhile, I've also filed for an improvement internally to perhaps
    catch and sanitize it automatically. Many thanks for reporting this
    in!
    On Tue, Aug 21, 2012 at 7:58 AM, Harsh J wrote:
    Thanks for the quick update and the attachment Nik,

    Looks like windows newline characters are the issue, possibly:

    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>

    Was this copied from some text? Perhaps you can remove the \r
    characters (copy-paste to any text editor, ask editor to strip out the
    \rs and copy-paste back) and retry?
    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:

    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J
  • Harsh J at Aug 22, 2012 at 2:34 am
    Did it end up working Nik?
    On Tue, Aug 21, 2012 at 8:19 AM, Nik Hodgkinson wrote:
    How strange, I'm on a Mac and I typed it in manually. I'll see what's can do to strip out the carriage returns and get back to you.

    -N
    11xor6@gmail.com
    (913)927-4891
    On Aug 20, 2012, at 7:30 PM, Harsh J wrote:

    Nik,

    (Or alternatively you can just erase the field and type it in
    manually. Browsers don't add \r AFAIK)

    Meanwhile, I've also filed for an improvement internally to perhaps
    catch and sanitize it automatically. Many thanks for reporting this
    in!
    On Tue, Aug 21, 2012 at 7:58 AM, Harsh J wrote:
    Thanks for the quick update and the attachment Nik,

    Looks like windows newline characters are the issue, possibly:

    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>

    Was this copied from some text? Perhaps you can remove the \r
    characters (copy-paste to any text editor, ask editor to strip out the
    \rs and copy-paste back) and retry?
    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:

    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J
  • Nik Hodgkinson at Aug 22, 2012 at 6:23 pm
    Harsh,

    I just got the chance to restart the cluster (internal customers and all), but that still didn't fix the problem. I'm getting the exact same error as before. I've attached a cmf-dump with the config I tried.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 21, 2012, at 7:33 PM, Harsh J wrote:

    Did it end up working Nik?
    On Tue, Aug 21, 2012 at 8:19 AM, Nik Hodgkinson wrote:
    How strange, I'm on a Mac and I typed it in manually. I'll see what's can do to strip out the carriage returns and get back to you.

    -N
    11xor6@gmail.com
    (913)927-4891
    On Aug 20, 2012, at 7:30 PM, Harsh J wrote:

    Nik,

    (Or alternatively you can just erase the field and type it in
    manually. Browsers don't add \r AFAIK)

    Meanwhile, I've also filed for an improvement internally to perhaps
    catch and sanitize it automatically. Many thanks for reporting this
    in!
    On Tue, Aug 21, 2012 at 7:58 AM, Harsh J wrote:
    Thanks for the quick update and the attachment Nik,

    Looks like windows newline characters are the issue, possibly:

    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>

    Was this copied from some text? Perhaps you can remove the \r
    characters (copy-paste to any text editor, ask editor to strip out the
    \rs and copy-paste back) and retry?
    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:
    There aren't any special characters in the safety value, and the whitespace is just spaces. I've attached a cmf-dump.



    -N
    11xor6@gmail.com
    (913) 927-4891
    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:

    Hi Nik,

    Do you have some special characters in your safety valve? Are those
    spaces of indent actually tab characters or space ones, for example?
    Can you send across an "export"-ed configuration set as detailed in
    the first step here:
    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?
    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:
    All,


    I'm trying to set the HDFS Safety Value to disable the dfs.permissions flag.
    This is what I've inserted into the field:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    The configuration saves fine, but when I try to restart the HDFS service I
    get the following error:


    Command failed to start: com.cloudera.cmf.service.config.ConfigGenException:
    Unable to generate config file hdfs-site.xml for role with type NAMENODE:
    Unable to parse XML safety valve


    I can't really find where I'm going wrong. Am I missing something or is this
    a bug I need to file?

    Thanks,
    -Nik


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J


    --
    Harsh J
  • Omar Alrubaiyan at Sep 12, 2012 at 9:11 pm
    Hi Nik,

    Can you provide us with the CM server log around the time the error
    happened? the full stack trace might shed some light on this issue.

    Thanks,
    Omar
    On Wed, Aug 22, 2012 at 11:22 AM, Nik Hodgkinson wrote:

    Harsh,

    I just got the chance to restart the cluster (internal customers and all),
    but that still didn't fix the problem. I'm getting the exact same error as
    before. I've attached a cmf-dump with the config I tried.




    -N
    11xor6@gmail.com
    (913) 927-4891

    On Aug 21, 2012, at 7:33 PM, Harsh J wrote:

    Did it end up working Nik?

    On Tue, Aug 21, 2012 at 8:19 AM, Nik Hodgkinson wrote:

    How strange, I'm on a Mac and I typed it in manually. I'll see what's can
    do to strip out the carriage returns and get back to you.


    -N

    11xor6@gmail.com

    (913)927-4891


    On Aug 20, 2012, at 7:30 PM, Harsh J wrote:


    Nik,


    (Or alternatively you can just erase the field and type it in

    manually. Browsers don't add \r AFAIK)


    Meanwhile, I've also filed for an improvement internally to perhaps

    catch and sanitize it automatically. Many thanks for reporting this

    in!


    On Tue, Aug 21, 2012 at 7:58 AM, Harsh J wrote:

    Thanks for the quick update and the attachment Nik,


    Looks like windows newline characters are the issue, possibly:



    <property>\r\n<name>dfs.permissions</name>\r\n<value>false</value>\r\n</property>


    Was this copied from some text? Perhaps you can remove the \r

    characters (copy-paste to any text editor, ask editor to strip out the

    \rs and copy-paste back) and retry?


    On Tue, Aug 21, 2012 at 7:53 AM, Nik Hodgkinson wrote:

    There aren't any special characters in the safety value, and the
    whitespace is just spaces. I've attached a cmf-dump.




    -N

    11xor6@gmail.com

    (913) 927-4891


    On Aug 20, 2012, at 7:15 PM, Harsh J wrote:


    Hi Nik,


    Do you have some special characters in your safety valve? Are those

    spaces of indent actually tab characters or space ones, for example?

    Can you send across an "export"-ed configuration set as detailed in

    the first step here:


    https://ccp.cloudera.com/display/FREE4DOC/Importing+and+Exporting+Cloudera+Manager+Settings?


    On Tue, Aug 21, 2012 at 5:02 AM, Nik Hodgkinson wrote:

    All,



    I'm trying to set the HDFS Safety Value to disable the dfs.permissions
    flag.

    This is what I've inserted into the field:


    <property>

    <name>dfs.permissions</name>

    <value>false</value>

    </property>


    The configuration saves fine, but when I try to restart the HDFS service I

    get the following error:



    Command failed to start:
    com.cloudera.cmf.service.config.ConfigGenException:

    Unable to generate config file hdfs-site.xml for role with type NAMENODE:

    Unable to parse XML safety valve



    I can't really find where I'm going wrong. Am I missing something or is
    this

    a bug I need to file?


    Thanks,

    -Nik




    --

    Harsh J






    --

    Harsh J




    --

    Harsh J




    --
    Harsh J


Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedAug 20, '12 at 11:32p
activeSep 12, '12 at 9:11p
posts9
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase