FAQ
Hi,

I have installed Cloudera Manager with CDH3 in my CentOS 6.2 cluster. I
was able to browse the cloudera manager web UI from the host using
http://localhost:7180 address.
In order to test, I changed the default port to "*80*" from the web UI by
going to *Administration -> Properties* and edited the port for HTTP SCM
Server for external connection.
I saved the settings and logged out and tried restarting the
"cloudera-scm-server" service. Doing so, the service starts with a PID for
few seconds only and then dies.

"service cloudera-scm-server" gives me the error message
"cloudera-scm-server dead but pid file exists".

The "/var/log/cloudera-scm-server/cloudera-scm-server.log" file gives the
following log messages:

*2012-08-09 05:04:42,398 WARN [WebServerImpl:mortbay.log@76] failed **
selectchannelconnector@0.0.0.0:80* <selectchannelconnector@0.0.0.0:80>*:
java.net.SocketException: Permission denied
2012-08-09 05:04:42,398 WARN [WebServerImpl:mortbay.log@76] failed **
Server@4d9cfefb* <Server@4d9cfefb>*: java.net.SocketException: Permission
denied
2012-08-09 05:04:42,399 ERROR [WebServerImpl:cmf.WebServerImpl@207] Jetty
server failed. Quitting.
java.net.SocketException: Permission denied
         at sun.nio.ch.Net.bind(Native Method)
         at
sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
         at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
         at
org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:216)
         at
org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:315)
         at
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
         at org.mortbay.jetty.Server.doStart(Server.java:235)
         at
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
         at com.cloudera.server.cmf.WebServerImpl.run(WebServerImpl.java:204)
*

As now I am unable to run cloudera manager, is there any way that I can
change the cloudera-scm-server port back to the default, i.e, 7180 by
changing any configuration file from the file system?

Thanks,
Gaurav

Search Discussions

  • Gaurav Dasgupta at Aug 9, 2012 at 11:51 am
    Just an addition: This is Cloudera Manager Free Edition

    Thanks,
    Gaurav
  • Philip Langdale at Aug 9, 2012 at 4:56 pm
    Hi Gaurav,

    You've hit a bug I'm afraid. The server doesn't run as root so it can't
    bind to
    ports below 1024, but it can't start to allow you to change it. You can
    change
    it to run as root, either temporarily to change the value, or permanently if
    you really want to run on port 80.

    Edit /etc/init.d/cloudera-scm-server and change the USER=cloudera-scm line
    to USER=root.

    --phil


    On 9 August 2012 04:51, Gaurav Dasgupta wrote:

    Just an addition: This is Cloudera Manager Free Edition

    Thanks,
    Gaurav
  • Praveenesh kumar at Aug 10, 2012 at 7:48 am
    Or What you can do is perform the changes in the postgres table inside the
    database itself that cloudera uses by default.
    DB details can be found in /etc/cloudera-scm-server/db.properties
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.

    Then restart the cloudera manager. You should be able to restart it.

    Regards,
    Praveenesh

    On Thursday, August 9, 2012 10:25:58 PM UTC+5:30, Philip Langdale wrote:

    Hi Gaurav,

    You've hit a bug I'm afraid. The server doesn't run as root so it can't
    bind to
    ports below 1024, but it can't start to allow you to change it. You can
    change
    it to run as root, either temporarily to change the value, or permanently
    if
    you really want to run on port 80.

    Edit /etc/init.d/cloudera-scm-server and change the USER=cloudera-scm line
    to USER=root.

    --phil



    On 9 August 2012 04:51, Gaurav Dasgupta <gdsa...@gmail.com <javascript:>>wrote:
    Just an addition: This is Cloudera Manager Free Edition

    Thanks,
    Gaurav
  • Y-Hain Chang at Dec 31, 2012 at 5:09 am

    On Friday, August 10, 2012 3:48:45 PM UTC+8, Praveenesh Kumar wrote:
    Or What you can do is perform the changes in the postgres table inside the
    database itself that cloudera uses by default.
    DB details can be found in /etc/cloudera-scm-server/db.properties
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.

    Then restart the cloudera manager. You should be able to restart it.

    Regards,
    Praveenesh

    hi Praveenesh,
         I open the DB scm,but I cannot find the table "settings*" my table info:
    scm-> \d
                  List of relations
      Schema | Name | Type | Owner
    --------+-------------------+-------+-------
      public | audits | table | scm
      public | client_configs | table | scm
      public | clusters | table | scm
      public | cm_version | table | scm
      public | commands | table | scm
      public | config_containers | table | scm
      public | config_revisions | table | scm
      public | configs | table | scm
      public | credentials | table | scm
      public | hosts | table | scm
      public | processes | table | scm
      public | roles | table | scm
      public | schema_version | table | scm
      public | services | table | scm
      public | user_roles | table | scm
      public | user_settings | table | scm
      public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition.
  • bc Wong at Jan 2, 2013 at 6:40 am
    On Sun, Dec 30, 2012 at 9:09 PM, Y-Hain Chang wrote:
    On Friday, August 10, 2012 3:48:45 PM UTC+8, Praveenesh Kumar wrote:

    Or What you can do is perform the changes in the postgres table inside
    the database itself that cloudera uses by default.
    DB details can be found in /etc/cloudera-scm-server/db.**properties
    Use pgadmin or any other client to open the DB, there is a table called *
    "settings"* inside *"scm"* DB.
    You can see update the column *"http_port"* with the value you want.

    Then restart the cloudera manager. You should be able to restart it.

    Regards,
    Praveenesh

    hi Praveenesh,
    I open the DB scm,but I cannot find the table "settings*" my table
    info:
    scm-> \d
    List of relations
    Schema | Name | Type | Owner
    --------+-------------------+-**------+-------
    public | audits | table | scm
    public | client_configs | table | scm
    public | clusters | table | scm
    public | cm_version | table | scm
    public | commands | table | scm
    public | config_containers | table | scm
    public | config_revisions | table | scm
    public | configs | table | scm
    public | credentials | table | scm
    public | hosts | table | scm
    public | processes | table | scm
    public | roles | table | scm
    public | schema_version | table | scm
    public | services | table | scm
    public | user_roles | table | scm
    public | user_settings | table | scm
    public | users | table | scm

    Just an addition: This is Cloudera Manager Free Edition.
    The settings table is no more starting from CM 4.1. If you want to change
    the port, do it from the "admin settings" page in CM. Or, if you're in a
    stuck state and can't start CM, edit /etc/init.d/cloudera-scm-server and
    change the USER=cloudera-scm line to USER=root (as Philip suggested).

    Cheers,
    bc

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedAug 9, '12 at 11:48a
activeJan 2, '13 at 6:40a
posts6
users5
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase