FAQ
I'm new to Hadoop and Linux and am setting up a single node training
environment so I can learn. I have followed the instructions to the letter
to install Cloudera Manager 4. When running cloudera-manager-installer.bin
I've been getting -

Ign http://au.archive.ubuntu.com precise-backports InRelease
Err http://security.ubuntu.com precise-security Release.gpg
   Something wicked happened resolving 'server:http' (-5 - No address
associated with hostname)

Messages similar to this occur many times until the install fails.

I am running Ubuntu 12.04 LTS.

Any help would be greatly appreciated.
Alex

Search Discussions

  • Arvind Gupta at Aug 5, 2012 at 8:51 am
    Hi Alex
                 Try this, It's a short lived "sudo apt-get update" may resolv
    this.
      If it doesn't resolved below link may help you.

    http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Alex_of_oz at Aug 5, 2012 at 11:00 am
    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en
       Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex
    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may resolv
    this.
    If it doesn't resolved below link may help you.


    http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Arvind Gupta at Aug 5, 2012 at 11:11 am
    Alex
               Can you please change you please change your software sources
    from Australia to Main server?
       For doing this go to Ubuntu Sofware Center >Edit>Preference then look at
    the first tab, Ubuntu Software.
       Change it to server in Australia to Main server?
      Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind
    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may resolv
    this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions/142508/how-to-fix-5-**
    no-address-associated-with-**hostname-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Alex_of_oz at Aug 5, 2012 at 11:40 am
    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure that
    it is looking in the Main server for the software. But sadly I am getting a
    similar result, although this time I see that it is not looking for an
    Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU
       Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex
    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software sources
    from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then look
    at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind
    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions/142508/how-to-fix-5-**
    no-address-associated-with-**hostname-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Arvind Gupta at Aug 6, 2012 at 9:24 am
    Alex
             Is the problem solved?
    -arvind
    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:

    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure that
    it is looking in the Main server for the software. But sadly I am getting a
    similar result, although this time I see that it is not looking for an
    Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex

    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software sources
    from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then look
    at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind

    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions**/142508/how-to-fix-5-**no-**
    address-associated-with-**hostna**me-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Alex_of_oz at Aug 6, 2012 at 10:11 am
    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't
    working.

    Alex
    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:

    Alex
    Is the problem solved?
    -arvind
    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:

    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure
    that it is looking in the Main server for the software. But sadly I am
    getting a similar result, although this time I see that it is not looking
    for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex

    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software sources
    from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then look
    at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind

    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions**/142508/how-to-fix-5-**no-**
    address-associated-with-**hostna**me-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Jolly Chen at Aug 6, 2012 at 7:21 pm
    Hi Alex,

    It could be that you are behind some proxy that prevents you from accessing the external servers properly.

    Does http://archive.ubuntu.com resolve for you in a browser window?
    Also does 'ping http://archive.ubuntu.com' work for you?

    Does http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm resolve for you in a browser window?

    See instructions on https://ccp.cloudera.com/display/FREE4DOC/Automated+Installation+of+Cloudera+Manager+and+CDH for proxy configuration.

    - jolly
    On Aug 6, 2012, at 3:11 AM, alex_of_oz wrote:

    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't working.

    Alex

    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:
    Alex
    Is the problem solved?
    -arvind

    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:
    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure that it is looking in the Main server for the software. But sadly I am getting a similar result, although this time I see that it is not looking for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    At least I am learning stuff about navigating my way around Linux while trying to overcome this situation. :-)) It all seems so much easier on the mainframes I've worked with for the past 30 years. I'll be so pleased when I'm past this error condition. :-)) Trying to understand the cryptic message above, is it saying that I need to make my default language American English, or is that too literal?

    Thanks again,
    Alex


    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:
    Alex
    Can you please change you please change your software sources from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then look at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind


    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:
    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    I see that it is trying to connect to an Australian server. Could the problem be because I'm in Australia? As I'm new to Linux, I'm baffled by these messages.

    Alex


    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:
    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating

    -arvind

    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:
    I'm new to Hadoop and Linux and am setting up a single node training environment so I can learn. I have followed the instructions to the letter to install Cloudera Manager 4. When running cloudera-manager-installer.bin I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex

  • Alex_of_oz at Aug 7, 2012 at 12:45 am
    Hi Jolly,

    Thanks for your help.
    Yes, http://archive.ubuntu.com resolves in a browser window. And yes,
    http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm also resolves
    successfully.

    When I do the ping, which I assume is simply 'ping
    http://archive.ubuntu.com' in a terminal window, I get the response -

    ping: unknown host http://archive.ubuntu.com.

    I don't know if that is what I'm supposed to get, but I doubt it.

    I shall look at the link you provided for proxy configuration and let you
    know.

    Thanks again for your help. One day I'll look back to this experience and
    smile. "There's no place like home".

    Alex
    On Tuesday, 7 August 2012 05:21:50 UTC+10, Jolly Chen wrote:

    Hi Alex,

    It could be that you are behind some proxy that prevents you from
    accessing the external servers properly.

    Does http://archive.ubuntu.com resolve for you in a browser window?
    Also does 'ping http://archive.ubuntu.com' work for you?

    Does http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm resolve for
    you in a browser window?

    See instructions on
    https://ccp.cloudera.com/display/FREE4DOC/Automated+Installation+of+Cloudera+Manager+and+CDHfor proxy configuration.

    - jolly

    On Aug 6, 2012, at 3:11 AM, alex_of_oz wrote:

    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't
    working.

    Alex
    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:

    Alex
    Is the problem solved?
    -arvind
    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:

    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure
    that it is looking in the Main server for the software. But sadly I am
    getting a similar result, although this time I see that it is not looking
    for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex

    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software sources
    from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then
    look at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind

    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions**/142508/how-to-fix-5-**no-**
    address-associated-with-**hostna**me-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node training
    environment so I can learn. I have followed the instructions to the letter
    to install Cloudera Manager 4. When running cloudera-manager-installer.bin
    I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Alex_of_oz at Aug 7, 2012 at 1:03 am
    Jolly,

    I'm looking at the proxy information and yes, I have done that. I had
    worked carefully through each step of the installation instructions.
    However, it is this step that is most likely where I have made a mistake
    and where my lack of Linux experience shows. There was not a
    /etc/apt/apt.conf file in the folder. In /etc/apt , the only apt.conf that
    existed was another folder called apt.conf.d . That was not what the
    instructions were saying, so I used gedit to create a new file called
    /etc/apt/apt.conf that contains the required code " Acquire::http::Proxy "http://server:port/";
    "

    This is the most likely place that I'm doing something wrong. I'm open to
    any input you can provide.

    Alex
    On Tuesday, 7 August 2012 10:45:32 UTC+10, alex_of_oz wrote:

    Hi Jolly,

    Thanks for your help.
    Yes, http://archive.ubuntu.com resolves in a browser window. And yes,
    http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm also resolves
    successfully.

    When I do the ping, which I assume is simply 'ping
    http://archive.ubuntu.com' in a terminal window, I get the response -

    ping: unknown host http://archive.ubuntu.com.

    I don't know if that is what I'm supposed to get, but I doubt it.

    I shall look at the link you provided for proxy configuration and let you
    know.

    Thanks again for your help. One day I'll look back to this experience and
    smile. "There's no place like home".

    Alex
    On Tuesday, 7 August 2012 05:21:50 UTC+10, Jolly Chen wrote:

    Hi Alex,

    It could be that you are behind some proxy that prevents you from
    accessing the external servers properly.

    Does http://archive.ubuntu.com resolve for you in a browser window?
    Also does 'ping http://archive.ubuntu.com' work for you?

    Does http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm resolve for
    you in a browser window?

    See instructions on
    https://ccp.cloudera.com/display/FREE4DOC/Automated+Installation+of+Cloudera+Manager+and+CDHfor proxy configuration.

    - jolly

    On Aug 6, 2012, at 3:11 AM, alex_of_oz wrote:

    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't
    working.

    Alex
    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:

    Alex
    Is the problem solved?
    -arvind
    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:

    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure
    that it is looking in the Main server for the software. But sadly I am
    getting a similar result, although this time I see that it is not looking
    for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex

    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software
    sources from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then
    look at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind

    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions**/142508/how-to-fix-5-**no-**
    address-associated-with-**hostna**me-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node
    training environment so I can learn. I have followed the instructions to
    the letter to install Cloudera Manager 4. When running
    cloudera-manager-installer.bin I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No
    address associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex
  • Jolly Chen at Aug 7, 2012 at 10:31 pm
    Hi Alex,

    My instructions to you was erroneous (cut-and-paste error). The host you should be ping'ing is simply archive.ubuntu.com, not http://archive.ubuntu.com

    # ping archive.ubuntu.com
    PING archive.ubuntu.com (91.189.92.155) 56(84) bytes of data.
    64 bytes from taotie.canonical.com (91.189.92.155): icmp_req=1 ttl=50 time=170 ms
    ^C
    --- archive.ubuntu.com ping statistics ---
    2 packets transmitted, 1 received, 50% packet loss, time 1001ms
    rtt min/avg/max/mdev = 170.443/170.443/170.443/0.000 ms

    If the two links work for you in the browser, then it's probably not an access to the external site that's the problem.

    What are the contents of your /etc/apt/sources.list.d/ and /etc/apt/sources.list?

    Here is some general help for how to use apt-get with a http proxy:
    https://help.ubuntu.com/community/AptGet/Howto#Setting_up_apt-get_to_use_a_http-proxy
    On Aug 6, 2012, at 5:45 PM, alex_of_oz wrote:

    Hi Jolly,

    Thanks for your help.
    Yes, http://archive.ubuntu.com resolves in a browser window. And yes, http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm also resolves successfully.

    When I do the ping, which I assume is simply 'ping http://archive.ubuntu.com' in a terminal window, I get the response -

    ping: unknown host http://archive.ubuntu.com.

    I don't know if that is what I'm supposed to get, but I doubt it.

    I shall look at the link you provided for proxy configuration and let you know.

    Thanks again for your help. One day I'll look back to this experience and smile. "There's no place like home".

    Alex

    On Tuesday, 7 August 2012 05:21:50 UTC+10, Jolly Chen wrote:
    Hi Alex,

    It could be that you are behind some proxy that prevents you from accessing the external servers properly.

    Does http://archive.ubuntu.com resolve for you in a browser window?
    Also does 'ping http://archive.ubuntu.com' work for you?

    Does http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm resolve for you in a browser window?

    See instructions on https://ccp.cloudera.com/display/FREE4DOC/Automated+Installation+of+Cloudera+Manager+and+CDH for proxy configuration.

    - jolly
    On Aug 6, 2012, at 3:11 AM, alex_of_oz wrote:

    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't working.

    Alex

    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:
    Alex
    Is the problem solved?
    -arvind

    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:
    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure that it is looking in the Main server for the software. But sadly I am getting a similar result, although this time I see that it is not looking for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    At least I am learning stuff about navigating my way around Linux while trying to overcome this situation. :-)) It all seems so much easier on the mainframes I've worked with for the past 30 years. I'll be so pleased when I'm past this error condition. :-)) Trying to understand the cryptic message above, is it saying that I need to make my default language American English, or is that too literal?

    Thanks again,
    Alex


    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:
    Alex
    Can you please change you please change your software sources from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then look at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind


    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:
    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    I see that it is trying to connect to an Australian server. Could the problem be because I'm in Australia? As I'm new to Linux, I'm baffled by these messages.

    Alex


    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:
    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating

    -arvind

    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:
    I'm new to Hadoop and Linux and am setting up a single node training environment so I can learn. I have followed the instructions to the letter to install Cloudera Manager 4. When running cloudera-manager-installer.bin I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No address associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex

  • Alex_of_oz at Aug 9, 2012 at 11:18 am
    Thanks for the guidance Jolly.

    The new ping definitely worked. It came back with a trillion messages such
    as - 64 bytes from haetae.canonical.com (91.189.92.152): icmp_req=458
    ttl=42 time=473 ms. Then I realised I need to stop the ping. :-) I told you
    I was new to this. Once I stopped it, the statistics told me that I had a
    1% packet loss.

    The next bit, which I presume is - rt min/avg/max/mdev =
    170.443/170.443/170.443/0.000 ms - gave me -

    The program 'rt' can be found in the following packages:
      * rt3.8-clients
      * rt4-clients
    Try: apt-get install <selected package>

    My /etc/apt/sources.list.d/ and /etc/apt/sources.list contain - 2
    cloudera-manager.list files in source.list.d and the source.list contains a
    file that starts with -

    # deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64
    (20120425)]/ dists/precise/main/binary-i386/

    # deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64
    (20120425)]/ dists/precise/restricted/binary-i386/
    # deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64
    (20120425)]/ precise main restricted

    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://archive.ubuntu.com/ubuntu precise main restricted -

    Then much more after that.

    Please let me know what all of this means, so I know if I need to do the
    apt-get bit.

    Alex



    On Wednesday, 8 August 2012 08:31:42 UTC+10, Jolly Chen wrote:

    Hi Alex,

    My instructions to you was erroneous (cut-and-paste error). The host you
    should be ping'ing is simply archive.ubuntu.com, not
    http://archive.ubuntu.com

    # ping archive.ubuntu.com
    PING archive.ubuntu.com (91.189.92.155) 56(84) bytes of data.
    64 bytes from taotie.canonical.com (91.189.92.155): icmp_req=1 ttl=50
    time=170 ms
    ^C
    --- archive.ubuntu.com ping statistics ---
    2 packets transmitted, 1 received, 50% packet loss, time 1001ms
    rtt min/avg/max/mdev = 170.443/170.443/170.443/0.000 ms

    If the two links work for you in the browser, then it's probably not an
    access to the external site that's the problem.

    What are the contents of your /etc/apt/sources.list.d/ and
    /etc/apt/sources.list?

    Here is some general help for how to use apt-get with a http proxy:

    https://help.ubuntu.com/community/AptGet/Howto#Setting_up_apt-get_to_use_a_http-proxy

    On Aug 6, 2012, at 5:45 PM, alex_of_oz wrote:

    Hi Jolly,

    Thanks for your help.
    Yes, http://archive.ubuntu.com resolves in a browser window. And yes,
    http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm also resolves
    successfully.

    When I do the ping, which I assume is simply 'ping
    http://archive.ubuntu.com' in a terminal window, I get the response -

    ping: unknown host http://archive.ubuntu.com.

    I don't know if that is what I'm supposed to get, but I doubt it.

    I shall look at the link you provided for proxy configuration and let you
    know.

    Thanks again for your help. One day I'll look back to this experience and
    smile. "There's no place like home".

    Alex
    On Tuesday, 7 August 2012 05:21:50 UTC+10, Jolly Chen wrote:

    Hi Alex,

    It could be that you are behind some proxy that prevents you from
    accessing the external servers properly.

    Does http://archive.ubuntu.com resolve for you in a browser window?
    Also does 'ping http://archive.ubuntu.com' work for you?

    Does http://archive.cloudera.com/cm4/ubuntu/precise/amd64/cm resolve for
    you in a browser window?

    See instructions on
    https://ccp.cloudera.com/display/FREE4DOC/Automated+Installation+of+Cloudera+Manager+and+CDHfor proxy configuration.

    - jolly

    On Aug 6, 2012, at 3:11 AM, alex_of_oz wrote:

    Hi Arvind,

    Sadly, the same situation exists as in the last post. It still isn't
    working.

    Alex
    On Monday, 6 August 2012 19:24:27 UTC+10, Arvind Gupta wrote:

    Alex
    Is the problem solved?
    -arvind
    On Sun, Aug 5, 2012 at 5:10 PM, alex_of_oz wrote:

    Hi Arvind,

    Thanks very much for your help and I'm sorry to be such a pain.

    I have done the steps that you said and double checked them to ensure
    that it is looking in the Main server for the software. But sadly I am
    getting a similar result, although this time I see that it is not looking
    for an Australian server.

    Ign http://archive.ubuntu.com precise/multiverse TranslationIndex
    Err http://archive.cloudera.com precise-cm4/contrib Translation-en_AU

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    At least I am learning stuff about navigating my way around Linux while
    trying to overcome this situation. :-)) It all seems so much easier on the
    mainframes I've worked with for the past 30 years. I'll be so pleased when
    I'm past this error condition. :-)) Trying to understand the cryptic
    message above, is it saying that I need to make my default language
    American English, or is that too literal?

    Thanks again,
    Alex

    On Sunday, 5 August 2012 21:11:06 UTC+10, Arvind Gupta wrote:

    Alex
    Can you please change you please change your software
    sources from Australia to Main server?
    For doing this go to Ubuntu Sofware Center >Edit>Preference then
    look at the first tab, Ubuntu Software.
    Change it to server in Australia to Main server?
    Then **sudo apt-get update && sudo apt-get upgrade**

    regards
    Arvind

    On Sun, Aug 5, 2012 at 4:30 PM, alex_of_oz wrote:

    Hi Arvind,

    Thank-you for your suggestions.

    I have tried both and received a similar failure for both. Your first
    suggestion produced the following, and many other similar messages -

    Err http://au.archive.ubuntu.com precise/universe Translation-en

    Something wicked happened resolving 'server:http' (-5 - No address
    associated with hostname)

    I see that it is trying to connect to an Australian server. Could the
    problem be because I'm in Australia? As I'm new to Linux, I'm baffled by
    these messages.

    Alex

    On Sunday, 5 August 2012 18:51:10 UTC+10, Arvind Gupta wrote:

    Hi Alex
    Try this, It's a short lived "sudo apt-get update" may
    resolv this.
    If it doesn't resolved below link may help you.

    http://askubuntu.com/**questions**/142508/how-to-fix-5-**no-**
    address-associated-with-**hostna**me-error-while-updating<http://askubuntu.com/questions/142508/how-to-fix-5-no-address-associated-with-hostname-error-while-updating>

    -arvind
    On Sun, Aug 5, 2012 at 9:26 AM, alex_of_oz wrote:

    I'm new to Hadoop and Linux and am setting up a single node
    training environment so I can learn. I have followed the instructions to
    the letter to install Cloudera Manager 4. When running
    cloudera-manager-installer.bin I've been getting -

    Ign http://au.archive.ubuntu.com precise-backports InRelease
    Err http://security.ubuntu.com precise-security Release.gpg
    Something wicked happened resolving 'server:http' (-5 - No
    address associated with hostname)

    Messages similar to this occur many times until the install fails.

    I am running Ubuntu 12.04 LTS.

    Any help would be greatly appreciated.
    Alex

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedAug 5, '12 at 3:56a
activeAug 9, '12 at 11:18a
posts12
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase