FAQ
Hi Guys,

We have upgraded to IMPALA 1.1 via Cloudera Manger 4.6 using the parcels.
We now get the following error when querying LZOP tables via IMPALA.

Backend 0:Impala LZO library was built against* Impala version 1.2-INTERNAL*,
but the running Impala version is 1.1
Error loading impala-lzo library. Check that the impala-lzo library is at
version 1.1
Backend 1:Impala LZO library was built against Impala version 1.2-INTERNAL,
but the running Impala version is 1.1
Error loading impala-lzo library. Check that the impala-lzo library is at
version 1.1
Backend 2:Impala LZO library was built against Impala version 1.2-INTERNAL,
but the running Impala version is 1.1
Error loading impala-lzo library. Check that the impala-lzo library is at
version 1.1
Backend 3:Impala LZO library was built against Impala version 1.2-INTERNAL,
but the running Impala version is 1.1
Error loading impala-lzo library. Check that the impala-lzo library is at
version 1.1

HIVE has no problems.

This is our setup in /opt/cloudera/parcels after the upgrade

May 28 12:24 CDH-4.3.0-1.cdh4.3.0.p0.22
Jul 19 23:17 SOLR-0.9.2-1.cdh4.3.0.p0.318
Jul 24 23:15 IMPALA-1.1-1.p0.8
Jul 26 22:21 HADOOP_LZO-0.4.15-1.gplextras.p0.105
Aug 2 15:22 SOLR -> SOLR-0.9.2-1.cdh4.3.0.p0.318
Aug 2 15:22 IMPALA -> IMPALA-1.1-1.p0.8
Aug 2 15:22 HADOOP_LZO -> HADOOP_LZO-0.4.15-1.gplextras.p0.105
Aug 2 15:22 CDH -> CDH-4.3.0-1.cdh4.3.0.p0.22


Any ideas?

Thanks.

Search Discussions

  • Henry Robinson at Aug 2, 2013 at 4:09 pm
    Thanks for the report. This looks like a bug in the way we generated the
    LZO packages. I will check in with our packaging team and get back to you.

    Henry

    On 2 August 2013 06:46, wrote:

    Hi Guys,

    We have upgraded to IMPALA 1.1 via Cloudera Manger 4.6 using the parcels.
    We now get the following error when querying LZOP tables via IMPALA.

    Backend 0:Impala LZO library was built against* Impala version
    1.2-INTERNAL*, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is at
    version 1.1
    Backend 1:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is at
    version 1.1
    Backend 2:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is at
    version 1.1
    Backend 3:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is at
    version 1.1

    HIVE has no problems.

    This is our setup in /opt/cloudera/parcels after the upgrade

    May 28 12:24 CDH-4.3.0-1.cdh4.3.0.p0.22
    Jul 19 23:17 SOLR-0.9.2-1.cdh4.3.0.p0.318
    Jul 24 23:15 IMPALA-1.1-1.p0.8
    Jul 26 22:21 HADOOP_LZO-0.4.15-1.gplextras.p0.105
    Aug 2 15:22 SOLR -> SOLR-0.9.2-1.cdh4.3.0.p0.318
    Aug 2 15:22 IMPALA -> IMPALA-1.1-1.p0.8
    Aug 2 15:22 HADOOP_LZO -> HADOOP_LZO-0.4.15-1.gplextras.p0.105
    Aug 2 15:22 CDH -> CDH-4.3.0-1.cdh4.3.0.p0.22


    Any ideas?

    Thanks.


    --
    Henry Robinson
    Software Engineer
    Cloudera
    415-994-6679
  • Daneengel at Aug 5, 2013 at 9:57 am
    Hi Henry,

    It's working now, thanks a lot.
    On Saturday, August 3, 2013 2:52:01 AM UTC+2, Henry wrote:

    Hi -

    We checked into this, and found that we had published a recent nightly
    build of the LZO packages rather than the version directly compatible with
    Impala 1.1.

    We've corrected the error. CM should see that build 22 available, which
    should replace the erroneously released build 105.

    Sorry for the inconvenience, please let us know if you have any further
    problems.

    Thanks,
    Henry



    On 2 August 2013 09:09, Henry Robinson <he...@cloudera.com <javascript:>>wrote:
    Thanks for the report. This looks like a bug in the way we generated the
    LZO packages. I will check in with our packaging team and get back to you.

    Henry

    On 2 August 2013 06:46, <dane...@gmail.com <javascript:>> wrote:

    Hi Guys,

    We have upgraded to IMPALA 1.1 via Cloudera Manger 4.6 using the
    parcels. We now get the following error when querying LZOP tables via
    IMPALA.

    Backend 0:Impala LZO library was built against* Impala version
    1.2-INTERNAL*, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is
    at version 1.1
    Backend 1:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is
    at version 1.1
    Backend 2:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is
    at version 1.1
    Backend 3:Impala LZO library was built against Impala version
    1.2-INTERNAL, but the running Impala version is 1.1
    Error loading impala-lzo library. Check that the impala-lzo library is
    at version 1.1

    HIVE has no problems.

    This is our setup in /opt/cloudera/parcels after the upgrade

    May 28 12:24 CDH-4.3.0-1.cdh4.3.0.p0.22
    Jul 19 23:17 SOLR-0.9.2-1.cdh4.3.0.p0.318
    Jul 24 23:15 IMPALA-1.1-1.p0.8
    Jul 26 22:21 HADOOP_LZO-0.4.15-1.gplextras.p0.105
    Aug 2 15:22 SOLR -> SOLR-0.9.2-1.cdh4.3.0.p0.318
    Aug 2 15:22 IMPALA -> IMPALA-1.1-1.p0.8
    Aug 2 15:22 HADOOP_LZO -> HADOOP_LZO-0.4.15-1.gplextras.p0.105
    Aug 2 15:22 CDH -> CDH-4.3.0-1.cdh4.3.0.p0.22


    Any ideas?

    Thanks.


    --
    Henry Robinson
    Software Engineer
    Cloudera
    415-994-6679


    --
    Henry Robinson
    Software Engineer
    Cloudera
    415-994-6679

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedAug 2, '13 at 1:47p
activeAug 5, '13 at 9:57a
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Daneengel: 2 posts Henry Robinson: 1 post

People

Translate

site design / logo © 2021 Grokbase