FAQ
We have Impala 1.0 installed in our environment along with CDH4.2.1. This
morning we saw that not all the nodes had their metadata refreshed
automatically for a new table. The table was introduced yesterday. Is there
a reason that this happened? Is there a way to find out why this happened?
I was also wondering why each node has its own separate metadata cache.

Thanks,
Ben

Search Discussions

  • Greg Rahn at Jul 10, 2013 at 5:05 pm
    Metadata does not automatically refresh in v1.0. The "refresh" command is
    required to do so for each impalad process/node.
    More details in the documentation:
    http://www.cloudera.com/content/cloudera-content/cloudera-docs/Impala/latest/Installing-and-Using-Impala/ciiu_langref_sql.html#refresh_unique_1


    On Wed, Jul 10, 2013 at 9:51 AM, Benjamin Kim wrote:

    We have Impala 1.0 installed in our environment along with CDH4.2.1. This
    morning we saw that not all the nodes had their metadata refreshed
    automatically for a new table. The table was introduced yesterday. Is there
    a reason that this happened? Is there a way to find out why this happened?
    I was also wondering why each node has its own separate metadata cache.

    Thanks,
    Ben
  • Greg Rahn at Jul 10, 2013 at 6:39 pm
    Hard to speculate on that...

    On Wed, Jul 10, 2013 at 11:31 AM, Benjamin Kim wrote:

    Greg,

    Thanks. I guess I was mistaken. But, how come most nodes had their
    metadata updated without having to refresh?

    ~Ben
    On Wednesday, July 10, 2013 10:05:39 AM UTC-7, Greg Rahn wrote:

    Metadata does not automatically refresh in v1.0. The "refresh" command
    is required to do so for each impalad process/node.
    More details in the documentation:
    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/Impala/latest/**Installing-and-Using-Impala/**
    ciiu_langref_sql.html#refresh_**unique_1<http://www.cloudera.com/content/cloudera-content/cloudera-docs/Impala/latest/Installing-and-Using-Impala/ciiu_langref_sql.html#refresh_unique_1>


    On Wed, Jul 10, 2013 at 9:51 AM, Benjamin Kim wrote:

    We have Impala 1.0 installed in our environment along with CDH4.2.1.
    This morning we saw that not all the nodes had their metadata refreshed
    automatically for a new table. The table was introduced yesterday. Is there
    a reason that this happened? Is there a way to find out why this happened?
    I was also wondering why each node has its own separate metadata cache.

    Thanks,
    Ben

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedJul 10, '13 at 4:51p
activeJul 10, '13 at 6:39p
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Greg Rahn: 2 posts Benjamin Kim: 1 post

People

Translate

site design / logo © 2022 Grokbase