FAQ
When i m tryingto start impala-server
using sudo service impala-server start and then check the status, its
showing
* * Impala Server is dead and pid file exists*
My log file shows following error
*Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg*
*E0620 15:21:15.335482 12784 impala-server.cc:377] ERROR: short-circuit
local reads is disabled because*
* - dfs.client.read.shortcircuit is not enabled.*
*ERROR: block location tracking is not properly enabled because*
* - dfs.client.file-block-storage-locations.timeout is too low. It should
be at least 3000.*
*E0620 15:21:15.335868 12784 impala-server.cc:379] Impala is aborted due to
improper configurations.*

And i have already done the changes in hdfs-site xml and core-site xml as
mentioned
in http://www.cloudera.com/content/cloudera-content/cloudera-docs/Impala/latest/Installing-and-Using-Impala/ciiu_config_performance.html
How should i fix this problem?

My hdfs-site.xml files looks like

   <property>
     <name>dfs.replication</name>
     <value>1</value>
   </property>
   <!-- Immediately exit safemode as soon as one DataNode checks in.
        On a multi-node cluster, these configurations must be removed. -->
   <property>
     <name>dfs.safemode.extension</name>
     <value>0</value>
   </property>
   <property>
      <name>dfs.safemode.min.datanodes</name>
      <value>1</value>
   </property>
   <property>
      <name>hadoop.tmp.dir</name>
      <value>/var/lib/hdfs/cache/${user.name}</value>
   </property>
   <property>
  <property>
      <name>dfs.namenode.name.dir</name>
      <value>file:///var/lib/hdfs/cache/user/dfs/name</value>
   </property>
   <property>
      <name>dfs.namenode.checkpoint.dir</name>
      <value>file:///var/lib/hdfs/cache/user/dfs/namesecondary</value>
   </property>
   <property>
      <name>dfs.datanode.data.dir</name>
      <value>file:///var/lib/hdfs/cache/user/dfs/data</value>
   </property>
<property>
    <name>dfs.client.use.legacy.blockreader.local</name>
    <value>true</value>
</property>

<property>
    <name>dfs.datanode.data.dir.perm</name>
    <value>750</value>
</property>
<property>
    <name>dfs.block.local-path-access.user</name>
    <value>impala</value>
</property>

<property>
     <name>dfs.client.file-block-storage-locations.timeout</name>
     <value>3000</value>
</property>

Search Discussions

  • Sean Mackrory at Jun 20, 2013 at 3:22 pm
    The instructions you link to mention the following properties that
    need to be added to hdfs-site.xml, and I don't see those properties in
    the file you posted. Make sure you add those, then restart HDFS and
    Impala. Also don't forget to provide an up-to-date copy of this file
    for both HDFS (/etc/hadoop/conf) and Impala (/etc/impala/conf).

    <property>
         <name>dfs.client.read.shortcircuit</name>
         <value>true</value>
    </property>

    <property>
         <name>dfs.domain.socket.path</name>
         <value>/var/run/hadoop-hdfs/dn._PORT</value>
    </property>

    <property>
         <name>dfs.client.file-block-storage-locations.timeout</name>
         <value>3000</value>
    </property>
    On Thu, Jun 20, 2013 at 3:24 AM, wrote:
    When i m tryingto start impala-server
    using sudo service impala-server start and then check the status, its
    showing
    * Impala Server is dead and pid file exists
    My log file shows following error
    Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
    E0620 15:21:15.335482 12784 impala-server.cc:377] ERROR: short-circuit local
    reads is disabled because
    - dfs.client.read.shortcircuit is not enabled.
    ERROR: block location tracking is not properly enabled because
    - dfs.client.file-block-storage-locations.timeout is too low. It should be
    at least 3000.
    E0620 15:21:15.335868 12784 impala-server.cc:379] Impala is aborted due to
    improper configurations.

    And i have already done the changes in hdfs-site xml and core-site xml as
    mentioned in
    http://www.cloudera.com/content/cloudera-content/cloudera-docs/Impala/latest/Installing-and-Using-Impala/ciiu_config_performance.html
    How should i fix this problem?

    My hdfs-site.xml files looks like

    <property>
    <name>dfs.replication</name>
    <value>1</value>
    </property>
    <!-- Immediately exit safemode as soon as one DataNode checks in.
    On a multi-node cluster, these configurations must be removed. -->
    <property>
    <name>dfs.safemode.extension</name>
    <value>0</value>
    </property>
    <property>
    <name>dfs.safemode.min.datanodes</name>
    <value>1</value>
    </property>
    <property>
    <name>hadoop.tmp.dir</name>
    <value>/var/lib/hdfs/cache/${user.name}</value>
    </property>
    <property>
    <property>
    <name>dfs.namenode.name.dir</name>
    <value>file:///var/lib/hdfs/cache/user/dfs/name</value>
    </property>
    <property>
    <name>dfs.namenode.checkpoint.dir</name>
    <value>file:///var/lib/hdfs/cache/user/dfs/namesecondary</value>
    </property>
    <property>
    <name>dfs.datanode.data.dir</name>
    <value>file:///var/lib/hdfs/cache/user/dfs/data</value>
    </property>
    <property>
    <name>dfs.client.use.legacy.blockreader.local</name>
    <value>true</value>
    </property>

    <property>
    <name>dfs.datanode.data.dir.perm</name>
    <value>750</value>
    </property>
    <property>
    <name>dfs.block.local-path-access.user</name>
    <value>impala</value>
    </property>

    <property>
    <name>dfs.client.file-block-storage-locations.timeout</name>
    <value>3000</value>
    </property>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedJun 20, '13 at 10:24a
activeJun 20, '13 at 3:22p
posts2
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Nehasingh Ns12: 1 post Sean Mackrory: 1 post

People

Translate

site design / logo © 2021 Grokbase