FAQ
Hi all:
I'm preparing a impala cluster.
I've started statestored process.
#GLOG_v=1 nohup statestored -state_store_port=21500
Although I didn't see any log about statestored, It's ok when I
telneted the port 21500.

But I started impalad process, it failured.
the log is followed:
INFO : metastore - Trying to connect to metastore with URI
thrift://172.16.236.9:9083
INFO : metastore - Waiting 1 seconds before next connection attempt.
INFO : metastore - Connected to metastore.
DEBUG : MetaStoreClientPool - Creating MetaStoreClient. Pool Size = 4
INFO : metastore - Trying to connect to metastore with URI
thrift://172.16.236.9:9083
INFO : metastore - Waiting 1 seconds before next connection attempt.
INFO : metastore - Connected to metastore.
*E0307 22:07:43.188216 17691 impalad-main.cc:93] Impalad services did not
start correctly, exiting*

I downloaded impalad source code.
91 Status status = exec_env.StartServices();
92 if (!status.ok()) {
93 LOG(ERROR) << "Impalad services did not start correctly, exiting";
94 ShutdownLogging();
95 exit(1);
96 }

Apparently, It occured in exec_env.StartServices().
78 Status ExecEnv::StartServices() {
79 LOG(INFO) << "Starting global services";
80 // Start services in order to ensure that dependencies between them
are met
81 if (enable_webserver_) {
82 AddDefaultPathHandlers(webserver_.get());
83 RETURN_IF_ERROR(webserver_->Start());
84 } else {
85 LOG(INFO) << "Not starting webserver";
86 }
87
88 metrics_->Init(enable_webserver_ ? webserver_.get() : NULL);
89
90 if (FLAGS_use_statestore) RETURN_IF_ERROR(subscription_mgr_->Start());
91
92 if (scheduler_ != NULL) RETURN_IF_ERROR(scheduler_->Init());
93
94 return Status::OK;
95 }
I wanted to know where I was wrong and how to find error reason for
destined error code.

Thank you.

Search Discussions

  • Thiswym at Mar 7, 2013 at 9:45 am
    I resolved the problem.
    i altered the start cmdline such as: GLOG_v=1 nohup impalad
    -state_store_host=172.16.236.9 -state_store_port=21500 -nn=172.16.236.9
    -nn_port=8020 -hostname=s003 -ipaddress=127.0.0.1
    it's ok.
    For orginally, I don't add last two args.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedMar 7, '13 at 7:44a
activeMar 7, '13 at 9:45a
posts2
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Thiswym: 2 posts

People

Translate

site design / logo © 2022 Grokbase