FAQ
Hi all,

I am using Microstrategy ODBC driver to access impala from php. I am able
to get results from smaller table. But when i try to access pretty big
table which takes more than 30 second to process and return the result, the
ODBC is throwing timeout exception.

" Maximum execution time of 30 seconds exceeded"

Any idea to configure ODBC driver to have a high timeout limit?

Regards,
Suresh

Search Discussions

  • Udai Kiran Potluri at Jan 31, 2013 at 6:58 pm
    Suresh,

    I am looking into it and will get back to you.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 3:51 AM, Suresh K wrote:

    Hi all,

    I am using Microstrategy ODBC driver to access impala from php. I am able
    to get results from smaller table. But when i try to access pretty big
    table which takes more than 30 second to process and return the result, the
    ODBC is throwing timeout exception.

    " Maximum execution time of 30 seconds exceeded"

    Any idea to configure ODBC driver to have a high timeout limit?

    Regards,
    Suresh
  • Udai Kiran Potluri at Jan 31, 2013 at 7:10 pm
    Suresh,

    I believe you can circumvent this by adding the below line in your php.ini
    ini_set('max_execution_time', 123456);

    Let me know if that helps.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 10:58 AM, Udai Kiran Potluri wrote:

    Suresh,

    I am looking into it and will get back to you.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 3:51 AM, Suresh K wrote:

    Hi all,

    I am using Microstrategy ODBC driver to access impala from php. I am able
    to get results from smaller table. But when i try to access pretty big
    table which takes more than 30 second to process and return the result, the
    ODBC is throwing timeout exception.

    " Maximum execution time of 30 seconds exceeded"

    Any idea to configure ODBC driver to have a high timeout limit?

    Regards,
    Suresh
  • Udai Kiran Potluri at Jan 31, 2013 at 7:16 pm
    Suresh,

    As an addition to my suggestion -
    This is not specifically an ODBC driver parameter. This value is on the PHP
    client side.

    Hence the value for max_execution_time can be set on php.ini using
    ini_set('max_execution_time', 123456);

    where the value 123456 is in seconds to what you want the limit to be.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 11:10 AM, Udai Kiran Potluri wrote:

    Suresh,

    I believe you can circumvent this by adding the below line in your php.ini
    ini_set('max_execution_time', 123456);

    Let me know if that helps.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 10:58 AM, Udai Kiran Potluri wrote:

    Suresh,

    I am looking into it and will get back to you.

    Thanks,
    Udai

    On Thu, Jan 31, 2013 at 3:51 AM, Suresh K wrote:

    Hi all,

    I am using Microstrategy ODBC driver to access impala from php. I am
    able to get results from smaller table. But when i try to access pretty big
    table which takes more than 30 second to process and return the result, the
    ODBC is throwing timeout exception.

    " Maximum execution time of 30 seconds exceeded"

    Any idea to configure ODBC driver to have a high timeout limit?

    Regards,
    Suresh
  • Suresh K at Feb 1, 2013 at 10:01 am
    Hi Udai,

    Thanks very much. That solved the issue. It was not related to ODBC driver
    as you said.

    Regards,
    Suresh
    On Friday, 1 February 2013 00:46:20 UTC+5:30, Udai wrote:

    Suresh,

    As an addition to my suggestion -
    This is not specifically an ODBC driver parameter. This value is on the
    PHP client side.

    Hence the value for max_execution_time can be set on php.ini using
    ini_set('max_execution_time', 123456);

    where the value 123456 is in seconds to what you want the limit to be.

    Thanks,
    Udai


    On Thu, Jan 31, 2013 at 11:10 AM, Udai Kiran Potluri <ud...@cloudera.com<javascript:>
    wrote:
    Suresh,

    I believe you can circumvent this by adding the below line in your php.ini
    ini_set('max_execution_time', 123456);

    Let me know if that helps.

    Thanks,
    Udai


    On Thu, Jan 31, 2013 at 10:58 AM, Udai Kiran Potluri <ud...@cloudera.com<javascript:>
    wrote:
    Suresh,

    I am looking into it and will get back to you.

    Thanks,
    Udai


    On Thu, Jan 31, 2013 at 3:51 AM, Suresh K <sureshk...@gmail.com<javascript:>
    wrote:
    Hi all,

    I am using Microstrategy ODBC driver to access impala from php. I am
    able to get results from smaller table. But when i try to access pretty big
    table which takes more than 30 second to process and return the result, the
    ODBC is throwing timeout exception.

    " Maximum execution time of 30 seconds exceeded"

    Any idea to configure ODBC driver to have a high timeout limit?

    Regards,
    Suresh

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedJan 31, '13 at 11:51a
activeFeb 1, '13 at 10:01a
posts5
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Udai Kiran Potluri: 3 posts Suresh K: 2 posts

People

Translate

site design / logo © 2022 Grokbase