FAQ
For reference, my hdfs-site.xml is:

configuration>
<property>
<name>dfs.datanode.data.dir.perm</name>
<value>755</value>
</property>
<property>
<name>dfs.block.local-path-access.user</name>
<value>impala</value>
</property>
<!-- enable data locality tracking -->
<property>
<name>dfs.datanode.hdfs-blocks-metadata.enabled</name>
<value>true</value>
</property>
<property>
<name>dfs.block.size</name>
<value>134217728</value>
</property>
<property>
<name>dfs.datanode.du.reserved</name>
<value>1073741824</value>
</property>
<property>
<name>dfs.data.dir</name>
<value>/data0/hadoop/hdfs/data,/data1/hadoop/hdfs/data</value>
</property>
<property>
<name>dfs.name.dir</name>
<value>/data0/hadoop/hdfs/name,/data1/hadoop/hdfs/name</value>
</property>
<property>
<name>fs.checkpoint.dir</name>
<value>/data0/hadoop/hdfs/secondary,/data1/hadoop/hdfs/secondary</value>
</property>
</configuration>

--

Search Discussions

  • Rjustice at Feb 22, 2013 at 11:58 pm
    Steven,

    Does /varz on the Impala web page
    say dfs.datanode.hdfs-blocks-metadata.enabled=true? Could you
    try restarting the datanode to get it to register the below config?

    Thanks,
    Robert Justice
    On Thursday, January 24, 2013 4:41:00 PM UTC-6, Steven Wong wrote:

    For reference, my hdfs-site.xml is:

    configuration>
    <property>
    <name>dfs.datanode.data.dir.perm</name>
    <value>755</value>
    </property>
    <property>
    <name>dfs.block.local-path-access.user</name>
    <value>impala</value>
    </property>
    <!-- enable data locality tracking -->
    <property>
    <name>dfs.datanode.hdfs-blocks-metadata.enabled</name>
    <value>true</value>
    </property>
    <property>
    <name>dfs.block.size</name>
    <value>134217728</value>
    </property>
    <property>
    <name>dfs.datanode.du.reserved</name>
    <value>1073741824</value>
    </property>
    <property>
    <name>dfs.data.dir</name>
    <value>/data0/hadoop/hdfs/data,/data1/hadoop/hdfs/data</value>
    </property>
    <property>
    <name>dfs.name.dir</name>
    <value>/data0/hadoop/hdfs/name,/data1/hadoop/hdfs/name</value>
    </property>
    <property>
    <name>fs.checkpoint.dir</name>

    <value>/data0/hadoop/hdfs/secondary,/data1/hadoop/hdfs/secondary</value>
    </property>
    </configuration>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupimpala-user @
categorieshadoop
postedJan 24, '13 at 10:41p
activeFeb 22, '13 at 11:58p
posts2
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Steven Wong: 1 post Rjustice: 1 post

People

Translate

site design / logo © 2022 Grokbase