FAQ
Hi Abraham,

I wrote in my first mail :
"I partially solved this issue by *adding proxyuser hadoop config in
namenode* *core-site.xml* as described in hue installation guide, "


<property>
      <name>hadoop.proxyuser.hue.hosts</name>
      <value>*</value>
</property>
<property>
      <name>hadoop.proxyuser.hue.groups</name>
      <value>hdfs</value>
</property>


So I said that the same http 500 error occurs again and the log message
change from *User: hue is not allowed to impersonate hdfs* (error 401)
to *urlopen
error [Errno 111] Connection refused

*
Thanks for your help

Franck



2013/8/20 Abraham Elmahrek <abe@cloudera.com>
Hey Franck,

It looks like you're missing some configuration in your core-site.xml file:

<property>
<name>hadoop.proxyuser.hue.hosts</name>
<value>*</value>
</property>
<property>
<name>hadoop.proxyuser.hue.groups</name>
<value>*</value>
</property>

-Abe

On Tue, Aug 20, 2013 at 7:22 AM, Franck Gallos wrote:

Hi,

I partially solved this issue by adding proxyuser hadoop config in
namenode core-site.xml as described in hue installation guide, see
/var/log/hue/runcpserver.log below :

[20/Aug/2013 07:16:11 +0000] access INFO 10.11.144.153 hdfs -
"GET /filebrowser/ HTTP/1.0"
[20/Aug/2013 07:16:11 +0000] middleware INFO Processing exception:
SecurityException: Failed to obtain user group information:
org.apache.hadoop.security.authorize.AuthorizationException: *User: hue
is not allowed to impersonate hdfs* (error 401): Traceback (most recent
call last):
File
"/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
line 100, in get_response
response = callback(request, *callback_args, **callback_kwargs)
File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py", line
90, in index
if not request.fs.isdir(path):
File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
line 214, in isdir
sb = self._stats(path)
File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
line 199, in _stats
raise ex
WebHdfsException: SecurityException: Failed to obtain user group
information: org.apache.hadoop.security.authorize.AuthorizationException:
User: hue is not allowed to impersonate hdfs (error 401)




Is it no need to extend this config on all DNs ?
Cause the same http 500 error occurs again :



[20/Aug/2013 07:53:57 +0000] access INFO 10.11.144.153 hdfs -
"GET /filebrowser/ HTTP/1.0"
[20/Aug/2013 07:53:57 +0000] middleware INFO Processing exception: <
*urlopen error [Errno 111] Connection refused*>: Traceback (most recent
call last):
File
"/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
line 100, in get_response
response = callback(request, *callback_args, **callback_kwargs)
File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py", line
90, in index
if not request.fs.isdir(path):
File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
line 214, in isdir
sb = self._stats(path)
File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
line 199, in _stats
raise ex
WebHdfsException: <urlopen error [Errno 111] Connection refused>


/etc/hue/hue.ini filesystem config :

[[hdfs_clusters]]

[[[default]]]
# Enter the filesystem uri
fs_defaultfs=hdfs://172.20.42.1:8020

# Change this if your HDFS cluster is Kerberos-secured
## security_enabled=false

# Use WebHdfs/HttpFs as the communication mechanism.
# This should be the web service root URL, such as
# http://namenode:50070/webhdfs/v1
webhdfs_url=http://172.20.42.1:50070/webhdfs/v1/

# Settings about this HDFS cluster. If you install HDFS in a
# different location, you need to set the following.

# Defaults to $HADOOP_HDFS_HOME or /usr/lib/hadoop-hdfs
hadoop_hdfs_home=/usr/lib/hadoop

# Defaults to $HADOOP_BIN or /usr/bin/hadoop
hadoop_bin=/usr/bin/hadoop

# Defaults to $HADOOP_CONF_DIR or /etc/hadoop/conf
hadoop_conf_dir=/etc/hadoop/conf.cluster


What happens ?




Franck

To unsubscribe from this group and stop receiving emails from it, send an
email to hue-user+unsubscribe@cloudera.org.
To unsubscribe from this group and stop receiving emails from it, send an email to hue-user+unsubscribe@cloudera.org.

Search Discussions

  • Abraham Elmahrek at Aug 21, 2013 at 8:02 am
    Franck,

    Sorry, I missed this. You'll likely want to make
    "hadoop.proxyuser.hue.groups" value to "*". Also, please make sure webhdfs
    is enabled in the namenode. Add the following to "hdfs-site.xml":

    <property>
       <name>dfs.webhdfs.enabled</name>
       <value>true</value>
    </property>


    -Abe

    On Wed, Aug 21, 2013 at 12:36 AM, Franck Gallos wrote:

    Hi Abraham,

    I wrote in my first mail :

    "I partially solved this issue by *adding proxyuser hadoop config in
    namenode* *core-site.xml* as described in hue installation guide, "


    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>hdfs</value>
    </property>


    So I said that the same http 500 error occurs again and the log message
    change from *User: hue is not allowed to impersonate hdfs* (error 401) to
    *urlopen error [Errno 111] Connection refused

    *
    Thanks for your help

    Franck



    2013/8/20 Abraham Elmahrek <abe@cloudera.com>
    Hey Franck,

    It looks like you're missing some configuration in your core-site.xml
    file:

    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    -Abe

    On Tue, Aug 20, 2013 at 7:22 AM, Franck Gallos wrote:

    Hi,

    I partially solved this issue by adding proxyuser hadoop config in
    namenode core-site.xml as described in hue installation guide, see
    /var/log/hue/runcpserver.log below :

    [20/Aug/2013 07:16:11 +0000] access INFO 10.11.144.153 hdfs -
    "GET /filebrowser/ HTTP/1.0"
    [20/Aug/2013 07:16:11 +0000] middleware INFO Processing exception:
    SecurityException: Failed to obtain user group information:
    org.apache.hadoop.security.authorize.AuthorizationException: *User: hue
    is not allowed to impersonate hdfs* (error 401): Traceback (most recent
    call last):
    File
    "/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
    line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
    File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py", line
    90, in index
    if not request.fs.isdir(path):
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 214, in isdir
    sb = self._stats(path)
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 199, in _stats
    raise ex
    WebHdfsException: SecurityException: Failed to obtain user group
    information: org.apache.hadoop.security.authorize.AuthorizationException:
    User: hue is not allowed to impersonate hdfs (error 401)




    Is it no need to extend this config on all DNs ?
    Cause the same http 500 error occurs again :



    [20/Aug/2013 07:53:57 +0000] access INFO 10.11.144.153 hdfs -
    "GET /filebrowser/ HTTP/1.0"
    [20/Aug/2013 07:53:57 +0000] middleware INFO Processing exception:
    <*urlopen error [Errno 111] Connection refused*>: Traceback (most
    recent call last):
    File
    "/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
    line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
    File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py", line
    90, in index
    if not request.fs.isdir(path):
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 214, in isdir
    sb = self._stats(path)
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 199, in _stats
    raise ex
    WebHdfsException: <urlopen error [Errno 111] Connection refused>


    /etc/hue/hue.ini filesystem config :

    [[hdfs_clusters]]

    [[[default]]]
    # Enter the filesystem uri
    fs_defaultfs=hdfs://172.20.42.1:8020

    # Change this if your HDFS cluster is Kerberos-secured
    ## security_enabled=false

    # Use WebHdfs/HttpFs as the communication mechanism.
    # This should be the web service root URL, such as
    # http://namenode:50070/webhdfs/v1
    webhdfs_url=http://172.20.42.1:50070/webhdfs/v1/

    # Settings about this HDFS cluster. If you install HDFS in a
    # different location, you need to set the following.

    # Defaults to $HADOOP_HDFS_HOME or /usr/lib/hadoop-hdfs
    hadoop_hdfs_home=/usr/lib/hadoop

    # Defaults to $HADOOP_BIN or /usr/bin/hadoop
    hadoop_bin=/usr/bin/hadoop

    # Defaults to $HADOOP_CONF_DIR or /etc/hadoop/conf
    hadoop_conf_dir=/etc/hadoop/conf.cluster


    What happens ?




    Franck

    To unsubscribe from this group and stop receiving emails from it, send
    an email to hue-user+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to hue-user+unsubscribe@cloudera.org.
  • Abraham Elmahrek at Aug 21, 2013 at 5:48 pm
    Frank,

    Thank you for reporting back. Glad things are working out.

    -Abe

    On Wed, Aug 21, 2013 at 7:52 AM, Franck Gallos wrote:

    Solved

    I maked "hadoop.proxyuser.hue.groups" value to "*"

    Why Hue needs a permissive security configuration ?

    Thank you

    Franck



    2013/8/21 Abraham Elmahrek <abe@cloudera.com>
    Franck,

    Sorry, I missed this. You'll likely want to make
    "hadoop.proxyuser.hue.groups" value to "*". Also, please make sure webhdfs
    is enabled in the namenode. Add the following to "hdfs-site.xml":

    <property>
    <name>dfs.webhdfs.enabled</name>
    <value>true</value>
    </property>


    -Abe

    On Wed, Aug 21, 2013 at 12:36 AM, Franck Gallos wrote:

    Hi Abraham,

    I wrote in my first mail :

    "I partially solved this issue by *adding proxyuser hadoop config in
    namenode* *core-site.xml* as described in hue installation guide, "


    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>hdfs</value>
    </property>


    So I said that the same http 500 error occurs again and the log message
    change from *User: hue is not allowed to impersonate hdfs* (error 401)
    to *urlopen error [Errno 111] Connection refused

    *
    Thanks for your help

    Franck



    2013/8/20 Abraham Elmahrek <abe@cloudera.com>
    Hey Franck,

    It looks like you're missing some configuration in your core-site.xml
    file:

    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    -Abe

    On Tue, Aug 20, 2013 at 7:22 AM, Franck Gallos wrote:

    Hi,

    I partially solved this issue by adding proxyuser hadoop config in
    namenode core-site.xml as described in hue installation guide, see
    /var/log/hue/runcpserver.log below :

    [20/Aug/2013 07:16:11 +0000] access INFO 10.11.144.153 hdfs
    - "GET /filebrowser/ HTTP/1.0"
    [20/Aug/2013 07:16:11 +0000] middleware INFO Processing
    exception: SecurityException: Failed to obtain user group information:
    org.apache.hadoop.security.authorize.AuthorizationException: *User:
    hue is not allowed to impersonate hdfs* (error 401): Traceback (most
    recent call last):
    File
    "/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
    line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
    File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py",
    line 90, in index
    if not request.fs.isdir(path):
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 214, in isdir
    sb = self._stats(path)
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 199, in _stats
    raise ex
    WebHdfsException: SecurityException: Failed to obtain user group
    information: org.apache.hadoop.security.authorize.AuthorizationException:
    User: hue is not allowed to impersonate hdfs (error 401)




    Is it no need to extend this config on all DNs ?
    Cause the same http 500 error occurs again :



    [20/Aug/2013 07:53:57 +0000] access INFO 10.11.144.153 hdfs
    - "GET /filebrowser/ HTTP/1.0"
    [20/Aug/2013 07:53:57 +0000] middleware INFO Processing
    exception: <*urlopen error [Errno 111] Connection refused*>:
    Traceback (most recent call last):
    File
    "/usr/share/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py",
    line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
    File "/usr/share/hue/apps/filebrowser/src/filebrowser/views.py",
    line 90, in index
    if not request.fs.isdir(path):
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 214, in isdir
    sb = self._stats(path)
    File "/usr/share/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py",
    line 199, in _stats
    raise ex
    WebHdfsException: <urlopen error [Errno 111] Connection refused>


    /etc/hue/hue.ini filesystem config :

    [[hdfs_clusters]]

    [[[default]]]
    # Enter the filesystem uri
    fs_defaultfs=hdfs://172.20.42.1:8020

    # Change this if your HDFS cluster is Kerberos-secured
    ## security_enabled=false

    # Use WebHdfs/HttpFs as the communication mechanism.
    # This should be the web service root URL, such as
    # http://namenode:50070/webhdfs/v1
    webhdfs_url=http://172.20.42.1:50070/webhdfs/v1/

    # Settings about this HDFS cluster. If you install HDFS in a
    # different location, you need to set the following.

    # Defaults to $HADOOP_HDFS_HOME or /usr/lib/hadoop-hdfs
    hadoop_hdfs_home=/usr/lib/hadoop

    # Defaults to $HADOOP_BIN or /usr/bin/hadoop
    hadoop_bin=/usr/bin/hadoop

    # Defaults to $HADOOP_CONF_DIR or /etc/hadoop/conf
    hadoop_conf_dir=/etc/hadoop/conf.cluster


    What happens ?




    Franck

    To unsubscribe from this group and stop receiving emails from it, send
    an email to hue-user+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to hue-user+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouphue-user @
categorieshadoop
postedAug 21, '13 at 7:36a
activeAug 21, '13 at 5:48p
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Abraham Elmahrek: 2 posts Franck Gallos: 1 post

People

Translate

site design / logo © 2022 Grokbase