FAQ
Hello,

I've installed the Hue-Oozie server
per https://github.com/cloudera/hue/tree/hue-oozie/dist

I am able to start the server (as a "hue" user I created), and I am able to
bring up the initial landing page to select my user name. However, after I
type the username and select login, the web request hangs indefinitely.

The last lines in the log are:

[18/Jul/2013 12:29:52 +0000] backend INFO Materializing user ryan
in the database
[18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users with
class: <class 'desktop.auth.backend.DefaultUserAugmentor'>

And nothing else. Any idea what could be going on here?

This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

Thanks,
Ryan

Search Discussions

  • Romain Rigaux at Jul 18, 2013 at 7:57 pm
    About doing something similar to this for starting the server:

    build/env/bin/hue runcherrypyserver

    New port might be:

    http://localhost:8000

    Romain

    On Thu, Jul 18, 2013 at 12:34 PM, wrote:

    Hello,

    I've installed the Hue-Oozie server per
    https://github.com/cloudera/hue/tree/hue-oozie/dist

    I am able to start the server (as a "hue" user I created), and I am able
    to bring up the initial landing page to select my user name. However, after
    I type the username and select login, the web request hangs indefinitely.

    The last lines in the log are:

    [18/Jul/2013 12:29:52 +0000] backend INFO Materializing user ryan
    in the database
    [18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users with
    class: <class 'desktop.auth.backend.DefaultUserAugmentor'>

    And nothing else. Any idea what could be going on here?

    This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

    Thanks,
    Ryan
  • Rlanman at Jul 18, 2013 at 8:00 pm
    That worked great. Though I got a "Could not create Home directory" error
    when I log in.

    I'm sure I have some permissions issue, I'll figure it out.

    Thanks for your help!
    On Thursday, July 18, 2013 3:57:01 PM UTC-4, Romain Rigaux wrote:

    About doing something similar to this for starting the server:

    build/env/bin/hue runcherrypyserver

    New port might be:

    http://localhost:8000

    Romain


    On Thu, Jul 18, 2013 at 12:34 PM, <rla...@nearinfinity.com <javascript:>>wrote:
    Hello,

    I've installed the Hue-Oozie server per
    https://github.com/cloudera/hue/tree/hue-oozie/dist

    I am able to start the server (as a "hue" user I created), and I am able
    to bring up the initial landing page to select my user name. However, after
    I type the username and select login, the web request hangs indefinitely.

    The last lines in the log are:

    [18/Jul/2013 12:29:52 +0000] backend INFO Materializing user
    ryan in the database
    [18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users
    with class: <class 'desktop.auth.backend.DefaultUserAugmentor'>

    And nothing else. Any idea what could be going on here?

    This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

    Thanks,
    Ryan
  • Rlanman at Jul 18, 2013 at 8:09 pm
    Looks like I am missing the Rerun, Kill, and Suspend buttons for my
    workflows as well. Is this known for the Cherry Py server?
    On Thursday, July 18, 2013 4:00:54 PM UTC-4, rla...@nearinfinity.com wrote:

    That worked great. Though I got a "Could not create Home directory" error
    when I log in.

    I'm sure I have some permissions issue, I'll figure it out.

    Thanks for your help!
    On Thursday, July 18, 2013 3:57:01 PM UTC-4, Romain Rigaux wrote:

    About doing something similar to this for starting the server:

    build/env/bin/hue runcherrypyserver

    New port might be:

    http://localhost:8000

    Romain

    On Thu, Jul 18, 2013 at 12:34 PM, wrote:

    Hello,

    I've installed the Hue-Oozie server per
    https://github.com/cloudera/hue/tree/hue-oozie/dist

    I am able to start the server (as a "hue" user I created), and I am able
    to bring up the initial landing page to select my user name. However, after
    I type the username and select login, the web request hangs indefinitely.

    The last lines in the log are:

    [18/Jul/2013 12:29:52 +0000] backend INFO Materializing user
    ryan in the database
    [18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users
    with class: <class 'desktop.auth.backend.DefaultUserAugmentor'>

    And nothing else. Any idea what could be going on here?

    This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

    Thanks,
    Ryan
  • Romain Rigaux at Jul 18, 2013 at 8:31 pm
    The 'Could not create Home directory' is just a warning and because
    HDFS/Hue are not configured to talk to each other:
    https://github.com/cloudera/hue/blob/hue-oozie/dist/README#L28

    For the missing permissions, are you logged-in in Hue as the same user as
    the one who submitted the workflow?

    Romain


    On Thu, Jul 18, 2013 at 1:09 PM, wrote:

    Looks like I am missing the Rerun, Kill, and Suspend buttons for my
    workflows as well. Is this known for the Cherry Py server?


    On Thursday, July 18, 2013 4:00:54 PM UTC-4, rla...@nearinfinity.comwrote:
    That worked great. Though I got a "Could not create Home directory" error
    when I log in.

    I'm sure I have some permissions issue, I'll figure it out.

    Thanks for your help!
    On Thursday, July 18, 2013 3:57:01 PM UTC-4, Romain Rigaux wrote:

    About doing something similar to this for starting the server:

    build/env/bin/hue runcherrypyserver

    New port might be:

    http://localhost:8000

    Romain

    On Thu, Jul 18, 2013 at 12:34 PM, wrote:

    Hello,

    I've installed the Hue-Oozie server per https://github.com/**
    cloudera/hue/tree/hue-oozie/**dist<https://github.com/cloudera/hue/tree/hue-oozie/dist>

    I am able to start the server (as a "hue" user I created), and I am
    able to bring up the initial landing page to select my user name. However,
    after I type the username and select login, the web request hangs
    indefinitely.

    The last lines in the log are:

    [18/Jul/2013 12:29:52 +0000] backend INFO Materializing user
    ryan in the database
    [18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users
    with class: <class 'desktop.auth.backend.**DefaultUserAugmentor'>

    And nothing else. Any idea what could be going on here?

    This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

    Thanks,
    Ryan
  • Rlanman at Jul 18, 2013 at 8:35 pm
    Nope. That worked, and makes sense! Thanks.
    On Thursday, July 18, 2013 4:30:58 PM UTC-4, Romain Rigaux wrote:

    The 'Could not create Home directory' is just a warning and because
    HDFS/Hue are not configured to talk to each other:
    https://github.com/cloudera/hue/blob/hue-oozie/dist/README#L28

    For the missing permissions, are you logged-in in Hue as the same user as
    the one who submitted the workflow?

    Romain



    On Thu, Jul 18, 2013 at 1:09 PM, <rla...@nearinfinity.com <javascript:>>wrote:
    Looks like I am missing the Rerun, Kill, and Suspend buttons for my
    workflows as well. Is this known for the Cherry Py server?


    On Thursday, July 18, 2013 4:00:54 PM UTC-4, rla...@nearinfinity.comwrote:
    That worked great. Though I got a "Could not create Home directory"
    error when I log in.

    I'm sure I have some permissions issue, I'll figure it out.

    Thanks for your help!
    On Thursday, July 18, 2013 3:57:01 PM UTC-4, Romain Rigaux wrote:

    About doing something similar to this for starting the server:

    build/env/bin/hue runcherrypyserver

    New port might be:

    http://localhost:8000

    Romain

    On Thu, Jul 18, 2013 at 12:34 PM, wrote:

    Hello,

    I've installed the Hue-Oozie server per https://github.com/**
    cloudera/hue/tree/hue-oozie/**dist<https://github.com/cloudera/hue/tree/hue-oozie/dist>

    I am able to start the server (as a "hue" user I created), and I am
    able to bring up the initial landing page to select my user name. However,
    after I type the username and select login, the web request hangs
    indefinitely.

    The last lines in the log are:

    [18/Jul/2013 12:29:52 +0000] backend INFO Materializing user
    ryan in the database
    [18/Jul/2013 12:29:52 +0000] backend INFO Augmenting users
    with class: <class 'desktop.auth.backend.**DefaultUserAugmentor'>

    And nothing else. Any idea what could be going on here?

    This is running on Centos 6.4 with CDH3 Hadoop and CDH3 Oozie.

    Thanks,
    Ryan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouphue-user @
categorieshadoop
postedJul 18, '13 at 7:34p
activeJul 18, '13 at 8:35p
posts6
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Rlanman: 4 posts Romain Rigaux: 2 posts

People

Translate

site design / logo © 2022 Grokbase