FAQ
You need to specify one Impalad address here
https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485and
restart Hue. The path to your hue.ini is specified in
hue_host:8888/about/admin_wizard in CDH4.3.

Let us know how it goes!

Romain

On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

I am getting the error below when I click on the "Impala Query Ui" via
Hue. I dont have the Impala daemons running on the HUE server the Impala
service is installed on a different server in the cluster. Where do I need
to change the config so it points to the proper Impala instance and not the
localhost were Impala is not installed.

*Could not connect to localhost:21050*
*
*
Thanks.*.*

--

---
You received this message because you are subscribed to the Google Groups
"CDH Users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to cdh-user+unsubscribe@cloudera.org.
For more options, visit
https://groups.google.com/a/cloudera.org/groups/opt_out.

Search Discussions

  • Gerardo Delgado at Jul 16, 2013 at 12:56 am
    Thanks Romain..

    I followed the steps below and see in my configuration file were hue.ini is
    located for example my hue.ini is located at the following path "/run/
    cloudera-scm-agent/process/144-hue-HUE_SERVER/hue.ini" . The issue is once
    I restart HUE it begins a new process "/run/cloudera-scm-agent/process/145-hue-HUE_SERVER/hue.ini".
    So the change never applies is there a global config so the change affects
    any future processes.

    Thanks..
    On Monday, July 15, 2013 7:47:32 PM UTC-4, Romain Rigaux wrote:

    You need to specify one Impalad address here
    https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485and restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_wizard in CDH4.3.

    Let us know how it goes!

    Romain


    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado <gdel...@gmail.com<javascript:>
    wrote:
    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the Impala
    service is installed on a different server in the cluster. Where do I need
    to change the config so it points to the proper Impala instance and not the
    localhost were Impala is not installed.

    *Could not connect to localhost:21050*
    *
    *
    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google Groups
    "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to cdh-user+u...@cloudera.org <javascript:>.
    For more options, visit
    https://groups.google.com/a/cloudera.org/groups/opt_out.

  • Romain Rigaux at Jul 16, 2013 at 2:09 am
    Yes, if you use CM you can't edit hue.ini as it will be overridden by CM.
    Impala configuration should be managed by CM. If you click on Hue, then
    Configuration, then on the Impala service.

    The alternative hacky (not recommended) way to do it is to add the property
    below to the "Hue Server Configuration Safety Valve for
    hue_safety_valve_server.ini" property in the "Advanced" menu of the Hueservice
    .

    [impala]

        # Host of the Impala Server
        server_host=impala.com

    Romain

    On Mon, Jul 15, 2013 at 5:56 PM, Gerardo Delgado wrote:

    Thanks Romain..

    I followed the steps below and see in my configuration file were hue.ini
    is located for example my hue.ini is located at the following path "/run/
    cloudera-scm-agent/process/144-hue-HUE_SERVER/hue.ini" . The issue is
    once I restart HUE it begins a new process "/run/cloudera-scm-agent/process/145-hue-HUE_SERVER/hue.ini".
    So the change never applies is there a global config so the change affects
    any future processes.

    Thanks..

    On Monday, July 15, 2013 7:47:32 PM UTC-4, Romain Rigaux wrote:

    You need to specify one Impalad address here https://github.com/cloudera/
    **hue/blob/master/desktop/conf/**pseudo-distributed.ini.tmpl#**L485<https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485>and restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_**wizard in CDH4.3.

    Let us know how it goes!

    Romain

    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the
    Impala service is installed on a different server in the cluster. Where do
    I need to change the config so it points to the proper Impala instance and
    not the localhost were Impala is not installed.

    *Could not connect to localhost:21050*
    *
    *
    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google
    Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to cdh-user+u...@cloudera.**org.

    For more options, visit https://groups.google.com/a/**
    cloudera.org/groups/opt_out<https://groups.google.com/a/cloudera.org/groups/opt_out>
    .

  • Gerardo Delgado at Jul 16, 2013 at 2:42 am
    Thanks Romain that did the trick!... One question you said its not a
    recommended way to do it could you tell me how come? I am just getting
    familiar with the Cloudera product and I want to make sure that once were
    in a production environment were using the best practices.

    Thanks..
    On Monday, July 15, 2013 10:09:11 PM UTC-4, Romain Rigaux wrote:

    Yes, if you use CM you can't edit hue.ini as it will be overridden by CM.
    Impala configuration should be managed by CM. If you click on Hue, then
    Configuration, then on the Impala service.

    The alternative hacky (not recommended) way to do it is to add the
    property below to the "Hue Server Configuration Safety Valve for
    hue_safety_valve_server.ini" property in the "Advanced" menu of the Hueservice
    .

    [impala]

    # Host of the Impala Server
    server_host=impala.com

    Romain


    On Mon, Jul 15, 2013 at 5:56 PM, Gerardo Delgado <gdel...@gmail.com<javascript:>
    wrote:
    Thanks Romain..

    I followed the steps below and see in my configuration file were hue.ini
    is located for example my hue.ini is located at the following path "/run/
    cloudera-scm-agent/process/144-hue-HUE_SERVER/hue.ini" . The issue is
    once I restart HUE it begins a new process "/run/cloudera-scm-agent/process/145-hue-HUE_SERVER/hue.ini".
    So the change never applies is there a global config so the change affects
    any future processes.

    Thanks..

    On Monday, July 15, 2013 7:47:32 PM UTC-4, Romain Rigaux wrote:

    You need to specify one Impalad address here
    https://github.com/cloudera/**hue/blob/master/desktop/conf/**
    pseudo-distributed.ini.tmpl#**L485<https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485>and restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_**wizard in CDH4.3.

    Let us know how it goes!

    Romain

    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the
    Impala service is installed on a different server in the cluster. Where do
    I need to change the config so it points to the proper Impala instance and
    not the localhost were Impala is not installed.

    *Could not connect to localhost:21050*
    *
    *
    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google
    Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to cdh-user+u...@cloudera.**org.

    For more options, visit https://groups.google.com/a/**
    cloudera.org/groups/opt_out<https://groups.google.com/a/cloudera.org/groups/opt_out>
    .

  • Romain Rigaux at Jul 16, 2013 at 4:14 am
    The best is to use the UI in CM because you just need to click to select
    Impala and that's it, Hue will work! (no need to enter the ini yourself and
    hardcode the impalad hostname)

    Romain

    On Mon, Jul 15, 2013 at 7:42 PM, Gerardo Delgado wrote:

    Thanks Romain that did the trick!... One question you said its not a
    recommended way to do it could you tell me how come? I am just getting
    familiar with the Cloudera product and I want to make sure that once were
    in a production environment were using the best practices.

    Thanks..

    On Monday, July 15, 2013 10:09:11 PM UTC-4, Romain Rigaux wrote:

    Yes, if you use CM you can't edit hue.ini as it will be overridden by
    CM. Impala configuration should be managed by CM. If you click on Hue, then
    Configuration, then on the Impala service.

    The alternative hacky (not recommended) way to do it is to add the
    property below to the "Hue Server Configuration Safety Valve for
    hue_safety_valve_server.ini" property in the "Advanced" menu of the Hueservice
    .

    [impala]

    # Host of the Impala Server
    server_host=impala.com

    Romain

    On Mon, Jul 15, 2013 at 5:56 PM, Gerardo Delgado wrote:

    Thanks Romain..

    I followed the steps below and see in my configuration file were hue.ini
    is located for example my hue.ini is located at the following path "/run/
    cloudera-scm-agent/**process/144-hue-HUE_SERVER/**hue.ini" . The issue
    is once I restart HUE it begins a new process "/run/cloudera-scm-**
    agent/process/145-hue-HUE_**SERVER/hue.ini". So the change never
    applies is there a global config so the change affects any future processes.

    Thanks..

    On Monday, July 15, 2013 7:47:32 PM UTC-4, Romain Rigaux wrote:

    You need to specify one Impalad address here
    https://github.com/cloudera/**hu**e/blob/master/desktop/conf/**pse**
    udo-distributed.ini.tmpl#**L485<https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485>and restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_**wiza**rd in CDH4.3.

    Let us know how it goes!

    Romain

    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the
    Impala service is installed on a different server in the cluster. Where do
    I need to change the config so it points to the proper Impala instance and
    not the localhost were Impala is not installed.

    *Could not connect to localhost:21050*
    *
    *
    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google
    Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to cdh-user+u...@cloudera.**org.

    For more options, visit https://groups.google.com/a/**cl**
    oudera.org/groups/opt_out<https://groups.google.com/a/cloudera.org/groups/opt_out>
    .

  • Gerardo Delgado at Jul 16, 2013 at 8:59 pm
    Thank You Romain..
    On Tuesday, July 16, 2013 12:13:52 AM UTC-4, Romain Rigaux wrote:

    The best is to use the UI in CM because you just need to click to select
    Impala and that's it, Hue will work! (no need to enter the ini yourself
    and hardcode the impalad hostname)

    Romain


    On Mon, Jul 15, 2013 at 7:42 PM, Gerardo Delgado <gdel...@gmail.com<javascript:>
    wrote:
    Thanks Romain that did the trick!... One question you said its not a
    recommended way to do it could you tell me how come? I am just getting
    familiar with the Cloudera product and I want to make sure that once were
    in a production environment were using the best practices.

    Thanks..

    On Monday, July 15, 2013 10:09:11 PM UTC-4, Romain Rigaux wrote:

    Yes, if you use CM you can't edit hue.ini as it will be overridden by
    CM. Impala configuration should be managed by CM. If you click on Hue,
    then Configuration, then on the Impala service.

    The alternative hacky (not recommended) way to do it is to add the
    property below to the "Hue Server Configuration Safety Valve for
    hue_safety_valve_server.ini" property in the "Advanced" menu of the Hueservice
    .

    [impala]

    # Host of the Impala Server
    server_host=impala.com

    Romain

    On Mon, Jul 15, 2013 at 5:56 PM, Gerardo Delgado wrote:

    Thanks Romain..

    I followed the steps below and see in my configuration file were
    hue.ini is located for example my hue.ini is located at the following path
    "/run/cloudera-scm-agent/**process/144-hue-HUE_SERVER/**hue.ini" . The
    issue is once I restart HUE it begins a new process "/run/cloudera-scm-
    **agent/process/145-hue-HUE_**SERVER/hue.ini". So the change never
    applies is there a global config so the change affects any future processes.

    Thanks..

    On Monday, July 15, 2013 7:47:32 PM UTC-4, Romain Rigaux wrote:

    You need to specify one Impalad address here
    https://github.com/cloudera/**hu**e/blob/master/desktop/conf/**pse**
    udo-distributed.ini.tmpl#**L485<https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485>and restart Hue. The path to your hue.ini is specified in hue_host
    :8888/about/admin_**wiza**rd in CDH4.3.

    Let us know how it goes!

    Romain

    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

    I am getting the error below when I click on the "Impala Query Ui"
    via Hue. I dont have the Impala daemons running on the HUE server
    the Impala service is installed on a different server in the cluster. Where
    do I need to change the config so it points to the proper Impala instance
    and not the localhost were Impala is not installed.

    *Could not connect to localhost:21050*
    *
    *
    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google
    Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to cdh-user+u...@cloudera.**org.

    For more options, visit https://groups.google.com/a/**cl**
    oudera.org/groups/opt_out<https://groups.google.com/a/cloudera.org/groups/opt_out>
    .

  • Venkatarun N at Apr 21, 2014 at 9:47 am
    Romain,

    I have tried the above settings and deployed and restarted the hue service
    via Cloudera Manager 5 version. Still i unable to connect the impala in
    hue's impala editor.

    impala service is installed.

    please let me know,


    On Tuesday, 16 July 2013 05:17:32 UTC+5:30, Romain Rigaux wrote:

    You need to specify one Impalad address here
    https://github.com/cloudera/hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485and restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_wizard in CDH4.3.

    Let us know how it goes!

    Romain


    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado <gdel...@gmail.com<javascript:>
    wrote:
    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the Impala
    service is installed on a different server in the cluster. Where do I need
    to change the config so it points to the proper Impala instance and not the
    localhost were Impala is not installed.

    *Could not connect to localhost:21050*

    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google Groups
    "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to cdh-user+u...@cloudera.org <javascript:>.
    For more options, visit
    https://groups.google.com/a/cloudera.org/groups/opt_out.

    To unsubscribe from this group and stop receiving emails from it, send an email to hue-user+unsubscribe@cloudera.org.
  • Romain Rigaux at Apr 21, 2014 at 2:51 pm
    Do you see any misconfiguration on the /about/ page?
    Then what do you see in the [impala] bottom section of the page
    /desktop/dump_config ?

    Romain


    On Mon, Apr 21, 2014 at 2:47 AM, wrote:

    Romain,

    I have tried the above settings and deployed and restarted the hue service
    via Cloudera Manager 5 version. Still i unable to connect the impala in
    hue's impala editor.

    impala service is installed.

    please let me know,


    On Tuesday, 16 July 2013 05:17:32 UTC+5:30, Romain Rigaux wrote:

    You need to specify one Impalad address here https://github.com/cloudera/
    hue/blob/master/desktop/conf/pseudo-distributed.ini.tmpl#L485 and
    restart Hue. The path to your hue.ini is specified in
    hue_host:8888/about/admin_wizard in CDH4.3.

    Let us know how it goes!

    Romain

    On Mon, Jul 15, 2013 at 3:08 PM, Gerardo Delgado wrote:

    I am getting the error below when I click on the "Impala Query Ui" via
    Hue. I dont have the Impala daemons running on the HUE server the
    Impala service is installed on a different server in the cluster. Where do
    I need to change the config so it points to the proper Impala instance and
    not the localhost were Impala is not installed.

    *Could not connect to localhost:21050*

    Thanks.*.*

    --

    ---
    You received this message because you are subscribed to the Google
    Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to cdh-user+u...@cloudera.org.

    For more options, visit https://groups.google.com/a/
    cloudera.org/groups/opt_out.

    To unsubscribe from this group and stop receiving emails from it, send
    an email to hue-user+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to hue-user+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouphue-user @
categorieshadoop
postedJul 15, '13 at 11:47p
activeApr 21, '14 at 2:51p
posts8
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase