FAQ
Looping in hue-user@ and scm-users.

Hue specifically:

Hue should come pre-built in CDH4 tarball. I'm assuming you're using the
newest release (4.2)?

Building Hue on Mac OS X:
There are aspects of Hue that will run without error on Mac OS X and
other aspects which will be very difficult. Hue is dependent on several
Hadoop components, which do not officially support Mac OS X. I would
recommend not trying to install Hue on Mac OS X. You could use VMWare
Fusion or Parallels to run a linux distro that is supported though.

Building Hue on AWS instance:
I've never tried building Hue on an AWS instance.. I recall the default
image being a RedHat variant (or something similar). You may be able to
get Hue running on this. In the output provided below, it seems like you
are missing krb5-*.
On 2/26/13 11:44 AM, Keith Wiley wrote:
My goal here is to install Hue. ClouderaManager is not the primary
goal...at the moment.

Hue, unlike Hadoop or Hive, seems to come unbuilt in the CDH4
tarball. Attempting to build it reveals a number of missing
dependencies, both on my Mac and on a basic AWS instance. First I
tried to chase the dependencies down one by one (on my Mac using
macports, and on an AWS instance using yum). This was problematic in
that the dependencies wouldn't even install successfully. On the mac
I was attempting to macport "mysql5-devel" which wouldn't finish
successfully, and on the AWS instance I got stuff like this:

...[clip]...
creating build
creating build/temp.linux-x86_64-2.7
creating build/temp.linux-x86_64-2.7/src
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC
-fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
-mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC
-I/usr/include/python2.7 -c src/kerberos.c -o
build/temp.linux-x86_64-2.7/src/kerberos.o sh: krb5-config: command
not found
gcc: error: sh:: No such file or directory
gcc: error: krb5-config:: No such file or directory
gcc: error: command: No such file or directory
gcc: error: not: No such file or directory
gcc: error: found: No such file or directory
error: command 'gcc' failed with exit status 1
make[2]: ***
[/home/ec2-user/hue-2.2.0-cdh4.2.0/desktop/core/build/kerberos-1.1.1/egg.stamp]
Error 1
make[2]: Leaving directory
`/home/ec2-user/hue-2.2.0-cdh4.2.0/desktop/core'
make[1]: *** [.recursive-env-install/core] Error 2
make[1]: Leaving directory `/home/ec2-user/hue-2.2.0-cdh4.2.0/desktop'
make: *** [desktop] Error 2

Sigh...Has anyone successfully installed Hue from the tarball on a Mac
or an AWS instance?

Moving on, I decided to try to do the whole thing through
ClouderaManager. My impression was that it might actually install Hue
for me. However, the ClouderManager installer complains that my basic
AWS instance is not running a supported system. Is it true that
ClouderaManager will not deploy on a default AWS instance? Do I need
to specify one of the nondefault OS options? If so, I'm looking for
advice on which one to use. Options include Red Hat Linux Enterprise
6.3, SUSE Linux Enterprise Server 11, Ubuntu Server 12.04.1 LTS,
Ubuntu Server 12.10.......the list goes on for quite a ways. I'm not
sure what to do here.

Help!

Thanks.
--

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouphue-user @
categorieshadoop
postedFeb 26, '13 at 8:12p
activeFeb 26, '13 at 10:21p
posts8
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase