FAQ
Using package installed from RPM 1.2.0+cdh5.0.0+0 with version
0.cdh5b1.p0.81.el6

Impala doesn't seem to start. All I get in the log files is that it can't
connect to the statestore on localhost:24000.

BUT! I supply the IMPALA_STATE_STORE_HOST=hostname in /etc/default/impala
as it states in the docs.

Doing a tcpdump from the box doesn't show any packets leaving the box to
the statestore (and the same on the statestore). I also confirmed, using a
telnet to the statestore that this isn't an iptables issue.

I tried to manually launch impalad with the same results. I exported the
variables below.

IMPALA_SERVER_ARGS=-log_dir=/var/log/impala -state_store_port=24000
-use_statestore -state_store_host=ip-172-19-0-110.aws.internal
-be_port=22000

HADOOP_CONF_DIR="/etc/hadoop/conf"

HIVE_CONF_DIR="/etc/hive/conf"


HDFS and the hive shell both work fine off this datanode.


Any help appreciated (especially debugging as of this point, asides from
looking at /tmp/impala.ERROR/WARNING/INFO I don't know where to go.

Here's the exact error message, although i didn't find it too insightful..
That localhost "should" be pointing to my statestore IP/host

impalad-main.cc:85] Impalad services did not start correctly, exiting.
Error: Couldn't open transport for localhost:24000(connect() failed:
Connection refused)

Pat

--

---
You received this message because you are subscribed to the Google Groups "CDH Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.

Search Discussions

  • Srinath Mantripragada at Jan 27, 2014 at 5:28 pm
    I was having the same issue and could find a workaround.

    I'm not sure if the problem is with the init script or with the file
    /etc/defaults/impala, but the init script looks for a file named 'impalad'.

    Renaming /etc/defaults/impala to /etc/defaults/impalad made impala server
    start correctly.


    On Sunday, January 12, 2014 11:37:30 AM UTC-5, Patrick Ethier wrote:

    Using package installed from RPM 1.2.0+cdh5.0.0+0 with version
    0.cdh5b1.p0.81.el6

    Impala doesn't seem to start. All I get in the log files is that it can't
    connect to the statestore on localhost:24000.

    BUT! I supply the IMPALA_STATE_STORE_HOST=hostname in /etc/default/impala
    as it states in the docs.

    Doing a tcpdump from the box doesn't show any packets leaving the box to
    the statestore (and the same on the statestore). I also confirmed, using a
    telnet to the statestore that this isn't an iptables issue.

    I tried to manually launch impalad with the same results. I exported the
    variables below.

    IMPALA_SERVER_ARGS=-log_dir=/var/log/impala -state_store_port=24000
    -use_statestore -state_store_host=ip-172-19-0-110.aws.internal
    -be_port=22000

    HADOOP_CONF_DIR="/etc/hadoop/conf"

    HIVE_CONF_DIR="/etc/hive/conf"


    HDFS and the hive shell both work fine off this datanode.


    Any help appreciated (especially debugging as of this point, asides from
    looking at /tmp/impala.ERROR/WARNING/INFO I don't know where to go.

    Here's the exact error message, although i didn't find it too insightful..
    That localhost "should" be pointing to my statestore IP/host

    impalad-main.cc:85] Impalad services did not start correctly, exiting.
    Error: Couldn't open transport for localhost:24000(connect() failed:
    Connection refused)

    Pat
    --

    ---
    You received this message because you are subscribed to the Google Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
    For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.
  • Patrick Ethier at Jan 27, 2014 at 6:40 pm
    Jira Reference: Impala-768 https://issues.cloudera.org/browse/IMPALA-768

    Thanks Srinath, looks like they have noticed and fixed this.

    Pat


    On Mon, Jan 27, 2014 at 12:28 PM, Srinath Mantripragada wrote:

    I was having the same issue and could find a workaround.

    I'm not sure if the problem is with the init script or with the file
    /etc/defaults/impala, but the init script looks for a file named 'impalad'.

    Renaming /etc/defaults/impala to /etc/defaults/impalad made impala server
    start correctly.


    On Sunday, January 12, 2014 11:37:30 AM UTC-5, Patrick Ethier wrote:

    Using package installed from RPM 1.2.0+cdh5.0.0+0 with version
    0.cdh5b1.p0.81.el6

    Impala doesn't seem to start. All I get in the log files is that it can't
    connect to the statestore on localhost:24000.

    BUT! I supply the IMPALA_STATE_STORE_HOST=hostname in
    /etc/default/impala as it states in the docs.

    Doing a tcpdump from the box doesn't show any packets leaving the box to
    the statestore (and the same on the statestore). I also confirmed, using a
    telnet to the statestore that this isn't an iptables issue.

    I tried to manually launch impalad with the same results. I exported the
    variables below.

    IMPALA_SERVER_ARGS=-log_dir=/var/log/impala -state_store_port=24000
    -use_statestore -state_store_host=ip-172-19-0-110.aws.internal
    -be_port=22000

    HADOOP_CONF_DIR="/etc/hadoop/conf"

    HIVE_CONF_DIR="/etc/hive/conf"


    HDFS and the hive shell both work fine off this datanode.


    Any help appreciated (especially debugging as of this point, asides from
    looking at /tmp/impala.ERROR/WARNING/INFO I don't know where to go.

    Here's the exact error message, although i didn't find it too
    insightful.. That localhost "should" be pointing to my statestore IP/host

    impalad-main.cc:85] Impalad services did not start correctly, exiting.
    Error: Couldn't open transport for localhost:24000(connect() failed:
    Connection refused)

    Pat
    --

    ---
    You received this message because you are subscribed to the Google Groups
    "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to cdh-user+unsubscribe@cloudera.org.
    For more options, visit
    https://groups.google.com/a/cloudera.org/groups/opt_out.
    --

    ---
    You received this message because you are subscribed to the Google Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
    For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcdh-user @
categorieshadoop
postedJan 12, '14 at 4:37p
activeJan 27, '14 at 6:40p
posts3
users2
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase