FAQ
can any one help me , i am tring to load the data from hdfs to impala using
load data inpath command
i tried the same couple of times, tried changing permission , can any one
help me.
i am new to cloudera impala , with hive the same command works.


[ec2-user@ip-10-158-71-121 ~]$ sudo su hdfs;
bash-4.1$ hadoop fs -chown impala /user/ec2-user
bash-4.1$ hadoop fs -chown impala /user
bash-4.1$ exit;
exit
[ec2-user@ip-10-158-71-121 ~]$ sudo su impala
bash-4.1$ exit;
exit
[ec2-user@ip-10-158-71-121 ~]$ impala-shell
Starting Impala Shell without Kerberos authentication
Connected to ip-10-158-71-121.ec2.internal:21000
Server version: impalad version 1.2.1 RELEASE (build
5f67f4e6ab9c91157e14815da8bc05ed2e6969fa)
Welcome to the Impala shell. Press TAB twice to see a list of available
commands.

Copyright (c) 2012 Cloudera, Inc. All rights reserved.

(Shell build version: Impala Shell v1.2.1 (5f67f4e) built on Thu Nov 21
22:50:04 PST 2013)
[ip-10-158-71-121.ec2.internal:21000] > LOAD DATA INPATH
"/user/ec2-user/shakespeare_freq2/part-00000" INTO TABLE shakespeare1;

Query: load DATA INPATH "/user/ec2-user/shakespeare_freq2/part-00000" INTO
TABLE shakespeare1
ERROR: AnalysisException: Error accessing file system: Permission denied:
user=impala, access=EXECUTE,
inode="/user/ec2-user/shakespeare_freq2":ec2-user:supergroup:drwx------
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.check(FSPermissionChecker.java:224)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkTraverse(FSPermissionChecker.java:177)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkPermission(FSPermissionChecker.java:142)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4846)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4828)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkTraverse(FSNamesystem.java:4807)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getFileInfo(FSNamesystem.java:3029)
         at
org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.getFileInfo(NameNodeRpcServer.java:694)
         at
org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.getFileInfo(ClientNamenodeProtocolServerSideTranslatorPB.java:646)
         at
org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java:45002)
         at
org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:453)
         at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:1002)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1752)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1748)
         at java.security.AccessController.doPrivileged(Native Method)
         at javax.security.auth.Subject.doAs(Subject.java:396)
         at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
         at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1746)

CAUSED BY: AccessControlException: Permission denied: user=impala,
access=EXECUTE,
inode="/user/ec2-user/shakespeare_freq2":ec2-user:supergroup:drwx------
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.check(FSPermissionChecker.java:224)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkTraverse(FSPermissionChecker.java:177)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkPermission(FSPermissionChecker.java:142)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4846)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4828)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkTraverse(FSNamesystem.java:4807)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getFileInfo(FSNamesystem.java:3029)
         at
org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.getFileInfo(NameNodeRpcServer.java:694)
         at
org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.getFileInfo(ClientNamenodeProtocolServerSideTranslatorPB.java:646)
         at
org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java:45002)
         at
org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:453)
         at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:1002)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1752)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1748)
         at java.security.AccessController.doPrivileged(Native Method)
         at javax.security.auth.Subject.doAs(Subject.java:396)
         at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
         at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1746)

CAUSED BY: RemoteException: Permission denied: user=impala, access=EXECUTE,
inode="/user/ec2-user/shakespeare_freq2":ec2-user:supergroup:drwx------
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.check(FSPermissionChecker.java:224)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkTraverse(FSPermissionChecker.java:177)
         at
org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkPermission(FSPermissionChecker.java:142)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4846)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkPermission(FSNamesystem.java:4828)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkTraverse(FSNamesystem.java:4807)
         at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getFileInfo(FSNamesystem.java:3029)
         at
org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.getFileInfo(NameNodeRpcServer.java:694)
         at
org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.getFileInfo(ClientNamenodeProtocolServerSideTranslatorPB.java:646)
         at
org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java:45002)
         at
org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:453)
         at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:1002)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1752)
         at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1748)
         at java.security.AccessController.doPrivileged(Native Method)
         at javax.security.auth.Subject.doAs(Subject.java:396)
         at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
         at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1746)

[ip-10-158-71-121.ec2.internal:21000] > exit;
Goodbye

[ec2-user@ip-10-158-71-121 ~]$ sudo hadoop fs -chmod 777 shakespeare_freq2
chmod: `shakespeare_freq2': No such file or directory

[ec2-user@ip-10-158-71-121 ~]$ sudo hadoop fs -chmod 777
/user/ec2-user/shakespeare_freq2
chmod: Permission denied: user=root, access=EXECUTE,
inode="/user/ec2-user":impala:supergroup:drwx------

[ec2-user@ip-10-158-71-121 ~]$ sudo su impala

--

---
You received this message because you are subscribed to the Google Groups "CDH Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcdh-user @
categorieshadoop
postedDec 13, '13 at 5:05a
activeDec 13, '13 at 5:05a
posts1
users1
websitecloudera.com
irc#hadoop

1 user in discussion

HK2004: 1 post

People

Translate

site design / logo © 2022 Grokbase