FAQ
HI Qwert,

The issue is SQL_VARCHAR in SQL Server Linked Servers rejects columns
greater than 8000. We'll release an updated driver soon that will allow you
to optionally truncate your string columns instead of current behavior
which always exposes Impala STRING as 32k SQL_VARCHARs.

Thanks,
Justin

On Tue, Sep 24, 2013 at 2:26 AM, qwert wrote:

Hi Andrew,

I also encountered this issue now.
Did you have any workaround for it?

And I also open a bug for it:
https://issues.cloudera.org/browse/IMPALA-600


On Saturday, August 31, 2013 5:58:21 PM UTC+8, Andrew Stevenson wrote:

This is only affecting SQL Server linked servers, I believe it's because
it expects VARCHAR(4000) but IMPALA string size is INT_MAX (32,767 f).

While I can bypass this with SSAS tabular cubes by using the ODBC
directly being able to use linked server would be very useful..
To unsubscribe from this group and stop receiving emails from it, send an
email to impala-user+unsubscribe@cloudera.org.
--

---
You received this message because you are subscribed to the Google Groups "CDH Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.

Search Discussions

  • Justin Erickson at Sep 27, 2013 at 1:22 am
    Hi qwuert and Andrew,

    Just wanted to let you know that we have an updated Impala ODBC 2.5.5
    driver patch that should unblock the issue you encountered:
    http://go.cloudera.com/odbc-driver-hive-impala.html

    The ODBC Driver for Impala v2.5.5 patch adds a DSN setting
    (‘StringColumnLength’) that the user can use to control the length STRING
    columns are exposed as. If the user is using Linked Server, they’ll need to
    use a value lower than 8000 or Linked Server will reject the column. This
    option is visible when you click the Advanced button in the configuration
    dialog:****

    ** **



    On Tue, Sep 24, 2013 at 10:05 AM, Justin Erickson wrote:

    HI Qwert,

    The issue is SQL_VARCHAR in SQL Server Linked Servers rejects columns
    greater than 8000. We'll release an updated driver soon that will allow you
    to optionally truncate your string columns instead of current behavior
    which always exposes Impala STRING as 32k SQL_VARCHARs.

    Thanks,
    Justin

    On Tue, Sep 24, 2013 at 2:26 AM, qwert wrote:

    Hi Andrew,

    I also encountered this issue now.
    Did you have any workaround for it?

    And I also open a bug for it:
    https://issues.cloudera.org/browse/IMPALA-600


    On Saturday, August 31, 2013 5:58:21 PM UTC+8, Andrew Stevenson wrote:

    This is only affecting SQL Server linked servers, I believe it's because
    it expects VARCHAR(4000) but IMPALA string size is INT_MAX (32,767 f).

    While I can bypass this with SSAS tabular cubes by using the ODBC
    directly being able to use linked server would be very useful..
    To unsubscribe from this group and stop receiving emails from it, send
    an email to impala-user+unsubscribe@cloudera.org.
    --

    ---
    You received this message because you are subscribed to the Google Groups "CDH Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to cdh-user+unsubscribe@cloudera.org.
    For more options, visit https://groups.google.com/a/cloudera.org/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcdh-user @
categorieshadoop
postedSep 24, '13 at 5:05p
activeSep 27, '13 at 1:22a
posts2
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Justin Erickson: 2 posts

People

Translate

site design / logo © 2022 Grokbase