FAQ
Hi all,

My oozie sqoop action is failing with Main class
[org.apache.oozie.action.hadoop.SqoopMain], exit code [1] with Error code,
Log files doesn't give me much info even if I add --verbose option..BElow
is my command and it works with commandline
<command>export --connect ${database} --username root --password mysql
--export-dir ${finaldata} --table airline --num-mappers 1
--input-fields-terminated-by \011 --update-key delaytype,year,month
--update-mode allowinsert</command>

If I remove the "-update-key delaytype,year,month --update-mode
allowinsert" part its working

<command>export --connect ${database} --username root --password ****
--export-dir ${finaldata} --table airline --num-mappers 1
--input-fields-terminated-by \011</command>
is working.
My table is
Field | Type | Null | Key | Default | Extra |
+-----------+-------------+------+-----+---------+-------+
delaytype | varchar(20) | NO | PRI | | |
delay | float | YES | | NULL | |
year | int(11) | NO | PRI | 0 | |
month | int(11) | NO | PRI | 0 | |
+-----------+-------------+------+-----+---------+-------+

<arg>export</arg>
<arg>--connect</arg>
<arg>${database}</arg>
<arg>--username</arg>
<arg>root</arg>
<arg>--password</arg>
<arg>***</arg>
<arg>--export-dir</arg>
<arg>${finaldata}</arg>
<arg>--table</arg>
<arg>airline</arg>
<arg>--input-fields-terminated-by</arg>
<arg>\011</arg>
<arg>--update-key</arg>
<arg>delaytype,year,month</arg>
<arg>--update-mode</arg>
<arg>allowinsert</arg>

is also not working.

Many Thanks,
Mathew

--

Search Discussions

  • Joel Mathew at Apr 24, 2013 at 3:22 am
    I am using Oozie 3.3.2, sqoop sqoop-1.5.0-incubatingand and hadoop 1.0.4

    Mathew
    On Tuesday, April 23, 2013 8:16:00 PM UTC-7, Joel Mathew wrote:

    Hi all,

    My oozie sqoop action is failing with Main class
    [org.apache.oozie.action.hadoop.SqoopMain], exit code [1] with Error code,
    Log files doesn't give me much info even if I add --verbose option..BElow
    is my command and it works with commandline
    <command>export --connect ${database} --username root --password mysql
    --export-dir ${finaldata} --table airline --num-mappers 1
    --input-fields-terminated-by \011 --update-key delaytype,year,month
    --update-mode allowinsert</command>

    If I remove the "-update-key delaytype,year,month --update-mode
    allowinsert" part its working

    <command>export --connect ${database} --username root --password ****
    --export-dir ${finaldata} --table airline --num-mappers 1
    --input-fields-terminated-by \011</command>
    is working.
    My table is
    Field | Type | Null | Key | Default | Extra |
    +-----------+-------------+------+-----+---------+-------+
    delaytype | varchar(20) | NO | PRI | | |
    delay | float | YES | | NULL | |
    year | int(11) | NO | PRI | 0 | |
    month | int(11) | NO | PRI | 0 | |
    +-----------+-------------+------+-----+---------+-------+

    <arg>export</arg>
    <arg>--connect</arg>
    <arg>${database}</arg>
    <arg>--username</arg>
    <arg>root</arg>
    <arg>--password</arg>
    <arg>***</arg>
    <arg>--export-dir</arg>
    <arg>${finaldata}</arg>
    <arg>--table</arg>
    <arg>airline</arg>
    <arg>--input-fields-terminated-by</arg>
    <arg>\011</arg>
    <arg>--update-key</arg>
    <arg>delaytype,year,month</arg>
    <arg>--update-mode</arg>
    <arg>allowinsert</arg>

    is also not working.

    Many Thanks,
    Mathew
    --
  • Jarek Jarcec Cecho at Apr 24, 2013 at 3:46 am
    Hi Joel,
    it seems that you're not using CDH and thus you might want to send your question to more appropriate mailing list (user@oozie.apache.org or user@sqoop.apache.org).

    My first step in this case would be to check ooze's sharelibs. You can find more information about sharelibs on excellent blogpost written my colleague Robert [1].

    Jarcec

    Links:
    1: http://blog.cloudera.com/blog/2012/12/how-to-use-the-sharelib-in-apache-oozie/
    On Apr 23, 2013, at 8:22 PM, Joel Mathew wrote:

    I am using Oozie 3.3.2, sqoop sqoop-1.5.0-incubatingand and hadoop 1.0.4

    Mathew

    On Tuesday, April 23, 2013 8:16:00 PM UTC-7, Joel Mathew wrote:
    Hi all,

    My oozie sqoop action is failing with Main class [org.apache.oozie.action.hadoop.SqoopMain], exit code [1] with Error code,
    Log files doesn't give me much info even if I add --verbose option..BElow is my command and it works with commandline
    <command>export --connect ${database} --username root --password mysql --export-dir ${finaldata} --table airline --num-mappers 1 --input-fields-terminated-by \011 --update-key delaytype,year,month --update-mode allowinsert</command>

    If I remove the "-update-key delaytype,year,month --update-mode allowinsert" part its working

    <command>export --connect ${database} --username root --password **** --export-dir ${finaldata} --table airline --num-mappers 1 --input-fields-terminated-by \011</command>
    is working.
    My table is
    Field | Type | Null | Key | Default | Extra |
    +-----------+-------------+------+-----+---------+-------+
    delaytype | varchar(20) | NO | PRI | | |
    delay | float | YES | | NULL | |
    year | int(11) | NO | PRI | 0 | |
    month | int(11) | NO | PRI | 0 | |
    +-----------+-------------+------+-----+---------+-------+

    <arg>export</arg>
    <arg>--connect</arg>
    <arg>${database}</arg>
    <arg>--username</arg>
    <arg>root</arg>
    <arg>--password</arg>
    <arg>***</arg>
    <arg>--export-dir</arg>
    <arg>${finaldata}</arg>
    <arg>--table</arg>
    <arg>airline</arg>
    <arg>--input-fields-terminated-by</arg>
    <arg>\011</arg>
    <arg>--update-key</arg>
    <arg>delaytype,year,month</arg>
    <arg>--update-mode</arg>
    <arg>allowinsert</arg>

    is also not working.

    Many Thanks,
    Mathew

    --

    --

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcdh-user @
categorieshadoop
postedApr 24, '13 at 3:16a
activeApr 24, '13 at 3:46a
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Joel Mathew: 2 posts Jarek Jarcec Cecho: 1 post

People

Translate

site design / logo © 2022 Grokbase