FAQ
I'm attempting to enable HBase replication of several tables to another
HBase cluster. I have added to the HBase Service Configuration Safety Valve
:

<property>
<name>hbase.replication</name>
<value>true</value>
</property>



When I attempt to add a peer in the Hue HBase shell:


hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
enable it in order to use replication



Any ideas?


Thanks,
Neil Yalowitz

Search Discussions

  • Amandeep Khurana at Jul 6, 2012 at 9:09 pm
    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another HBase cluster. I have added to the HBase Service Configuration Safety Valve:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please enable it in order to use replication



    Any ideas?


    Thanks,
    Neil Yalowitz
  • Neil Y at Jul 6, 2012 at 10:21 pm
    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase shell.
    The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz
    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y <> wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz
  • Neil Y at Jul 6, 2012 at 10:22 pm
    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase shell.
    The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz
    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz
  • Amandeep Khurana at Jul 6, 2012 at 10:27 pm
    Yes, your suspicion is right. You have to deploy the client configurations generated by Cloudera Manager to the /etc/<service>/conf for the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk


    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are attempting to read from the default configuration locations (such as /etc/hbase and /etc/zookeeper etc.) instead of the CM generated configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz
    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:
    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y (mailto:neilyalowitz@gmail.com)> wrote:

    I'm attempting to enable HBase replication of several tables to another HBase cluster. I have added to the HBase Service Configuration Safety Valve:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please enable it in order to use replication



    Any ideas?


    Thanks,
    Neil Yalowitz
  • Vinithra Varadharajan at Jul 7, 2012 at 12:43 am
    Neil,

    If you are using CM 4.0, the client configs will get automatically deployed
    when you add the service. See the docs here for deploying them after
    configuration changes:
    https://ccp.cloudera.com/display/ENT4DOC/Deploying+Client+Configuration+Files

    -Vinithra
    On Fri, Jul 6, 2012 at 3:27 PM, Amandeep Khurana wrote:

    Yes, your suspicion is right. You have to deploy the client
    configurations generated by Cloudera Manager to the /etc/<service>/conf for
    the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk

    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase
    shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz

    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz
  • Neil Y at Jul 11, 2012 at 3:53 pm
    Vinithra,

    Very good to know, thanks. Seems like a very useful feature. More
    motivation to upgrade to CDH4!


    Neil
    On Friday, July 6, 2012 8:42:48 PM UTC-4, Vinithra wrote:

    Neil,

    If you are using CM 4.0, the client configs will get automatically
    deployed when you add the service. See the docs here for deploying them
    after configuration changes:

    https://ccp.cloudera.com/display/ENT4DOC/Deploying+Client+Configuration+Files

    -Vinithra
    On Fri, Jul 6, 2012 at 3:27 PM, Amandeep Khurana wrote:

    Yes, your suspicion is right. You have to deploy the client
    configurations generated by Cloudera Manager to the /etc/<service>/conf for
    the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk

    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase
    shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals
    are attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz

    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz
  • Joey Echeverria at Jul 11, 2012 at 4:56 pm
    This is actually a feature of Cloudera Manager 4, not CDH4, and CM4 works with both CDH3 and CDH4.

    -Joey

    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.

    On Wednesday, July 11, 2012 at 11:53, Neil Y wrote:

    Vinithra,

    Very good to know, thanks. Seems like a very useful feature. More motivation to upgrade to CDH4!


    Neil
    On Friday, July 6, 2012 8:42:48 PM UTC-4, Vinithra wrote:
    Neil,

    If you are using CM 4.0, the client configs will get automatically deployed when you add the service. See the docs here for deploying them after configuration changes:
    https://ccp.cloudera.com/display/ENT4DOC/Deploying+Client+Configuration+Files

    -Vinithra
    On Fri, Jul 6, 2012 at 3:27 PM, Amandeep Khurana (mailto:ak@cloudera.com)> wrote:
    Yes, your suspicion is right. You have to deploy the client configurations generated by Cloudera Manager to the /etc/<service>/conf for the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk


    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are attempting to read from the default configuration locations (such as /etc/hbase and /etc/zookeeper etc.) instead of the CM generated configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz
    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:
    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y (mailto:neilyalowitz@gmail.com)> wrote:

    I'm attempting to enable HBase replication of several tables to another HBase cluster. I have added to the HBase Service Configuration Safety Valve:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please enable it in order to use replication



    Any ideas?


    Thanks,
    Neil Yalowitz
  • Neil Y at Jul 11, 2012 at 7:24 pm
    Joey,

    Good info, thanks.

    Does CM4 still have the quirk I described above where safety valve values
    are not in the client confs?


    Neil
    On Wednesday, July 11, 2012 12:56:31 PM UTC-4, Joey Echeverria wrote:

    This is actually a feature of Cloudera Manager 4, not CDH4, and CM4 works
    with both CDH3 and CDH4.

    -Joey

    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.

    On Wednesday, July 11, 2012 at 11:53, Neil Y wrote:

    Vinithra,

    Very good to know, thanks. Seems like a very useful feature. More
    motivation to upgrade to CDH4!


    Neil

    On Friday, July 6, 2012 8:42:48 PM UTC-4, Vinithra wrote:

    Neil,

    If you are using CM 4.0, the client configs will get automatically
    deployed when you add the service. See the docs here for deploying them
    after configuration changes:

    https://ccp.cloudera.com/display/ENT4DOC/Deploying+Client+Configuration+Files

    -Vinithra

    On Fri, Jul 6, 2012 at 3:27 PM, Amandeep Khurana wrote:

    Yes, your suspicion is right. You have to deploy the client
    configurations generated by Cloudera Manager to the /etc/<service>/conf for
    the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk

    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase
    shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz

    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz


  • Joey Echeverria at Jul 11, 2012 at 7:28 pm
    CM4 has an explicit client safety valve for just this purpose.

    -Joey
    On Wed, Jul 11, 2012 at 3:23 PM, Neil Y wrote:
    Joey,

    Good info, thanks.

    Does CM4 still have the quirk I described above where safety valve values
    are not in the client confs?


    Neil

    On Wednesday, July 11, 2012 12:56:31 PM UTC-4, Joey Echeverria wrote:

    This is actually a feature of Cloudera Manager 4, not CDH4, and CM4 works
    with both CDH3 and CDH4.

    -Joey

    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.

    On Wednesday, July 11, 2012 at 11:53, Neil Y wrote:

    Vinithra,

    Very good to know, thanks. Seems like a very useful feature. More
    motivation to upgrade to CDH4!


    Neil

    On Friday, July 6, 2012 8:42:48 PM UTC-4, Vinithra wrote:

    Neil,

    If you are using CM 4.0, the client configs will get automatically
    deployed when you add the service. See the docs here for deploying them
    after configuration changes:

    https://ccp.cloudera.com/display/ENT4DOC/Deploying+Client+Configuration+Files

    -Vinithra

    On Fri, Jul 6, 2012 at 3:27 PM, Amandeep Khurana wrote:

    Yes, your suspicion is right. You have to deploy the client configurations
    generated by Cloudera Manager to the /etc/<service>/conf for the clients
    (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk

    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase
    shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz

    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:

    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication



    Any ideas?


    Thanks,
    Neil Yalowitz



    --
    Joey Echeverria
    Principal Solutions Architect
    Cloudera, Inc.
  • Neil Y at Jul 11, 2012 at 3:51 pm
    Amandeep,

    Thanks for confirming. This was the issue. Replication appears to be
    working now.

    I encountered a couple of caveats that I wanted to document here for others:

    1) The client configurations need to be pushed to all nodes (as described
    in item #2 on this page<https://ccp.cloudera.com/display/CDH4DOC/HBase+Replication#HBaseReplication-DeployingHBaseReplication>which, although CDH4 specific, was still a useful howto). To push the
    confs, I created a custom helper shell script that performed to scp to all
    nodes, moved the old confs out of the way (/etc/hadoop/conf and
    /etc/hbase/conf), unzipped the new global client archive, and moved them to
    the final destination (/etc/<service>/conf). It sounds like deploying
    client confs with CDH4 is more streamlined, however.

    2) The hbase-conf/hbase-site.xml that was created via the "Generate Client
    Configuration" button did not contain the replication=true property that I
    entered into the HBase configuration under Service-Wide Settings -> HBase
    Service Configuration Safety Valve. I needed to manually unzip
    global-clientconfig.zip, edit hbase-site.xml to include "hbase.replication"
    property, and re-zip. Perhaps this is a bug with CDH3u3?

    Thanks for the input, hope this helps someone down the line.



    Neil
    On Friday, July 6, 2012 6:27:04 PM UTC-4, Amandeep Khurana wrote:

    Yes, your suspicion is right. You have to deploy the client
    configurations generated by Cloudera Manager to the /etc/<service>/conf for
    the clients (like HBase shell) to pick them up.

    --
    Amandeep Khurana
    Solutions Architect, Cloudera Inc
    Twitter: @amansk

    On Friday, July 6, 2012 at 3:22 PM, Neil Y wrote:

    Yes, I did restart the HBase service.

    Yes, it's a CM managed cluster. The "add_peer" was in the Hue HBase
    shell. The same issue occurs when I use hbase shell via SSH command line.

    I suspect both the Hue and command-line launched hbase shell terminals are
    attempting to read from the default configuration locations (such as
    /etc/hbase and /etc/zookeeper etc.) instead of the CM generated
    configuration dirs under /var/run/cloudera-scm-agent/process.


    Neil Yalowitz

    On Friday, July 6, 2012 5:09:35 PM UTC-4, Amandeep Khurana wrote:

    Neil,

    Did you restart HBase after adding that config? This is a Cloudera
    Manager managed cluster?

    Amandeep
    On Jul 6, 2012, at 2:07 PM, Neil Y wrote:

    I'm attempting to enable HBase replication of several tables to another
    HBase cluster. I have added to the HBase Service Configuration Safety
    Valve:
    <property>
    <name>hbase.replication</name>
    <value>true</value>
    </property>



    When I attempt to add a peer in the Hue HBase shell:


    hbase(main):006:0* add_peer '1',"my-zk:2181:/hbase"

    ERROR: java.lang.RuntimeException: hbase.replication isn't true, please
    enable it in order to use replication


    Any ideas?


    Thanks,
    Neil Yalowitz

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcdh-user @
categorieshadoop
postedJul 6, '12 at 9:07p
activeJul 11, '12 at 7:28p
posts11
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase