FAQ
How to get postfix working on CentOS 6 and Comcast. Recently, they've
changed their policies regards email relay and require authentication
even to send email. (they no longer use IP address ranges, presumably in
an attempt to curb outgoing SPAM)


I didn't see an updated howto anywhere on the Interwebs, thought I'd
point out what I had to do. The part that had me stumped for longer than
I care to admit was having to install cyrus-sasl-plain rpm - EL5
apparently had that installed as part of the cyrus-sasl package.


1) yum install postfix cyrus-sasl-plain;
# note that cyrus-sasl-plain is NOT installed by default but is needed
by this config.


2) Create file /etc/postfix/passwords. Replace "USERNAME" with your user
name, and
"password" with your password. Note: your username is typically your
email address without the domain name.
#----------------------------
smtp.comcast.net:587 USERNAME:password
smtp.comcast.net USERNAME at comcast.net:password
#----------------------------


3) makemap passwords;


4) Edit /etc/postfix/main.cf
#----------------------------
relayhost = [smtp.comcast.net]:587
smtpd_sasl_auth_enable = yes
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/passwords
# note that with no security options on, we're using sasl-plain
installed above.
smtp_sasl_security_options =
# You might need this, you may not.
#sender_canonical_maps = regexp:/etc/postfix/sender_rewrite
#----------------------------


5) Create file /etc/postfix/sender_rewrite. Note that not all Comcast
customers need this, I didn't when I authenticated as above. Obviously,
replace "USERNAME" with your user name.
#----------------------------
/^([^@]*)@.*$/ USERNAME at comcast.net
#----------------------------


6) service postfix stop; sleep 5; service postfix start

Search Discussions

  • SilverTip257 at Nov 22, 2013 at 5:23 pm

    On Thu, Nov 21, 2013 at 9:08 PM, Lists wrote:


    How to get postfix working on CentOS 6 and Comcast. Recently, they've
    changed their policies regards email relay and require authentication
    even to send email. (they no longer use IP address ranges, presumably in
    an attempt to curb outgoing SPAM)

    Requiring auth is how it should be.


    <tangent>
    Now if Comcast would provide IMAP access instead of just POP3 to
    customers...
    </tangent>



    I didn't see an updated howto anywhere on the Interwebs, thought I'd
    point out what I had to do. The part that had me stumped for longer than
    I care to admit was having to install cyrus-sasl-plain rpm - EL5
    apparently had that installed as part of the cyrus-sasl package.

    I've seen write-ups for relaying mail through Gmail using Postfix.


    Thanks for sharing.



    1) yum install postfix cyrus-sasl-plain;
    # note that cyrus-sasl-plain is NOT installed by default but is needed
    by this config.

    2) Create file /etc/postfix/passwords. Replace "USERNAME" with your user
    name, and
    "password" with your password. Note: your username is typically your
    email address without the domain name.
    #----------------------------
    smtp.comcast.net:587 USERNAME:password
    smtp.comcast.net USERNAME at comcast.net:password
    #----------------------------

    3) makemap passwords;

    4) Edit /etc/postfix/main.cf
    #----------------------------
    relayhost = [smtp.comcast.net]:587
    smtpd_sasl_auth_enable = yes
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/passwords
    # note that with no security options on, we're using sasl-plain
    installed above.
    smtp_sasl_security_options =
    # You might need this, you may not.
    #sender_canonical_maps = regexp:/etc/postfix/sender_rewrite
    #----------------------------

    5) Create file /etc/postfix/sender_rewrite. Note that not all Comcast
    customers need this, I didn't when I authenticated as above. Obviously,
    replace "USERNAME" with your user name.
    #----------------------------
    /^([^@]*)@.*$/ USERNAME at comcast.net
    #----------------------------

    6) service postfix stop; sleep 5; service postfix start


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos





    --
    ---~~.~~---
    Mike
    // SilverTip257 //
  • Arun Khan at Nov 24, 2013 at 8:00 am

    On Fri, Nov 22, 2013 at 7:38 AM, Lists wrote:
    How to get postfix working on CentOS 6 and Comcast. Recently, they've
    changed their policies regards email relay and require authentication
    even to send email. (they no longer use IP address ranges, presumably in
    an attempt to curb outgoing SPAM)

    I didn't see an updated howto anywhere on the Interwebs, thought I'd
    point out what I had to do. The part that had me stumped for longer than
    I care to admit was having to install cyrus-sasl-plain rpm - EL5
    apparently had that installed as part of the cyrus-sasl package.

    search keywords gave ample links with pretty much the same documents


    Here is one specifically for CentOS with GMail as smtp smart host.
    Replace Gmail smtp host with Comcast smtp host and change port 587 if
    Comcast is using something different.


    <http://blog.earth-works.com/2013/05/14/postfix-relay-using-gmail-on-centos/>


    HTH,
    --
    Arun Khan
    Sent from my non-iphone/non-android device

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedNov 22, '13 at 2:08a
activeNov 24, '13 at 8:00a
posts3
users3
websitecentos.org
irc#centos

3 users in discussion

Lists: 1 post Arun Khan: 1 post SilverTip257: 1 post

People

Translate

site design / logo © 2021 Grokbase