FAQ
I have a recently installed Mellanox VPI interface in my server. This is
an InfiniBand interface, which, through the use of adapters, can also do
10GbE over fiber. I have one of the adapter's two ports configured for
10GbE in this way, with a point to point link to a Mac workstation with
a Myricom 10GbE card.


I've configured this interface on the Linux box (eth2) using
/etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
subnet, etc.


Everything seems to work fine, with a single exception. If I reboot the
Mac on the other end, causing the link state of the fiber interface to
bounce, the network interface on the Linux box doesn't come back up when
the link comes back up. That is, ifconfig shows it as having the link
up, but it doesn't do the equivalent of "ifup eth2" when the link comes
back, so it doesn't get an IP, the routing table doesn't get updated, etc.


So, my question is, how can I make CentOS automatically configure this
interface when the link comes back up? It's a bit annoying having to log
in and do ifup eth2 every time...


--
Joakim Ziegler - Supervisor de postproducci?n - Terminal
joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

Search Discussions

  • Earl Ramirez at Mar 24, 2013 at 3:13 am

    On Sat, 2013-03-23 at 20:27 -0600, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This is
    an InfiniBand interface, which, through the use of adapters, can also do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link comes
    back, so it doesn't get an IP, the routing table doesn't get updated, etc.

    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to log
    in and do ifup eth2 every time...

    Joakim,


    Do you have ONBOOT=yes in the /etc/sysconfig/network-scripts/ifcfg-eth2?
    --




    Kind Regards
    Earl Ramirez
    GPG Key: http://trinipino.com/PublicKey.asc
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 316 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20130324/f3886255/attachment.bin
  • Joakim Ziegler at Mar 24, 2013 at 5:16 am
    I do have ONBOOT=yes, yes. It comes up on boot (if there's a link), it
    just doesn't come up after the link goes down and comes back up.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 23/03/13 21:13, Earl Ramirez wrote:
    On Sat, 2013-03-23 at 20:27 -0600, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This is
    an InfiniBand interface, which, through the use of adapters, can also do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link comes
    back, so it doesn't get an IP, the routing table doesn't get updated, etc.

    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to log
    in and do ifup eth2 every time...
    Joakim,

    Do you have ONBOOT=yes in the /etc/sysconfig/network-scripts/ifcfg-eth2?



    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Eero Volotinen at Mar 24, 2013 at 6:46 am
    Try to disable network manager on that interface
    On Mar 24, 2013 7:17 AM, "Joakim Ziegler" wrote:

    I do have ONBOOT=yes, yes. It comes up on boot (if there's a link), it
    just doesn't come up after the link goes down and comes back up.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 23/03/13 21:13, Earl Ramirez wrote:
    On Sat, 2013-03-23 at 20:27 -0600, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This is
    an InfiniBand interface, which, through the use of adapters, can also do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link comes
    back, so it doesn't get an IP, the routing table doesn't get updated,
    etc.
    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to log
    in and do ifup eth2 every time...
    Joakim,

    Do you have ONBOOT=yes in the /etc/sysconfig/network-scripts/ifcfg-eth2?



    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Joakim Ziegler at Mar 24, 2013 at 7:03 am
    How do I do that? I've not used network manager to set it up, I just
    made the ifcfg-eth2 file from scratch.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 24/03/13 0:46, Eero Volotinen wrote:
    Try to disable network manager on that interface
    On Mar 24, 2013 7:17 AM, "Joakim Ziegler" wrote:

    I do have ONBOOT=yes, yes. It comes up on boot (if there's a link), it
    just doesn't come up after the link goes down and comes back up.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 23/03/13 21:13, Earl Ramirez wrote:
    On Sat, 2013-03-23 at 20:27 -0600, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This is
    an InfiniBand interface, which, through the use of adapters, can also do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link comes
    back, so it doesn't get an IP, the routing table doesn't get updated,
    etc.
    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to log
    in and do ifup eth2 every time...
    Joakim,

    Do you have ONBOOT=yes in the /etc/sysconfig/network-scripts/ifcfg-eth2?



    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Eero Volotinen at Mar 24, 2013 at 7:20 am
    NM_MANAGED=no on ifcfg-ethX script.. and onboot=YES
    On Mar 24, 2013 9:04 AM, "Joakim Ziegler" wrote:

    How do I do that? I've not used network manager to set it up, I just
    made the ifcfg-eth2 file from scratch.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 24/03/13 0:46, Eero Volotinen wrote:
    Try to disable network manager on that interface
    On Mar 24, 2013 7:17 AM, "Joakim Ziegler" wrote:

    I do have ONBOOT=yes, yes. It comes up on boot (if there's a link), it
    just doesn't come up after the link goes down and comes back up.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 23/03/13 21:13, Earl Ramirez wrote:
    On Sat, 2013-03-23 at 20:27 -0600, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This
    is
    an InfiniBand interface, which, through the use of adapters, can also
    do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation
    with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address,
    MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot
    the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up
    when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link
    comes
    back, so it doesn't get an IP, the routing table doesn't get updated,
    etc.
    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to
    log
    in and do ifup eth2 every time...
    Joakim,

    Do you have ONBOOT=yes in the
    /etc/sysconfig/network-scripts/ifcfg-eth2?


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Patrick Lists at Mar 24, 2013 at 1:38 pm

    On 24-03-13 08:03, Joakim Ziegler wrote:
    How do I do that? I've not used network manager to set it up, I just
    made the ifcfg-eth2 file from scratch.

    Besides the other two suggestions you may also want to set a proper
    SELinux label on the ifcfg-eth2 file with something like:
    /sbin/restorecon -v -F /etc/sysconfig/network-scripts/ifcfg-eth2


    The SELinux label I have on my ifcfg-eth0 is:
    -rw-r--r--. root root system_u:object_r:net_conf_t:s0 ifcfg-eth0


    Regards,
    Patrick
  • Joakim Ziegler at Mar 26, 2013 at 4:29 am
    Well, /etc/sysconfig/network-scripts/ifcfg-eth2 looks like this:


    DEVICE=eth2
    BOOTPROTO=none
    ONBOOT=yes
    NETWORK.10.0.0
    NETMASK%5.255.0.0
    IPADDR.10.0.1
    USERCTL=no
    MTU�00
    HOTPLUG=yes
    NM_MANAGED=no


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 24/03/13 7:38, Patrick Lists wrote:
    On 24-03-13 08:03, Joakim Ziegler wrote:
    How do I do that? I've not used network manager to set it up, I just
    made the ifcfg-eth2 file from scratch.
    Besides the other two suggestions you may also want to set a proper
    SELinux label on the ifcfg-eth2 file with something like:
    /sbin/restorecon -v -F /etc/sysconfig/network-scripts/ifcfg-eth2

    The SELinux label I have on my ifcfg-eth0 is:
    -rw-r--r--. root root system_u:object_r:net_conf_t:s0 ifcfg-eth0

    Regards,
    Patrick
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Eero Volotinen at Mar 26, 2013 at 4:42 am

    2013/3/26 Joakim Ziegler <joakim@terminalmx.com>:
    Well, /etc/sysconfig/network-scripts/ifcfg-eth2 looks like this:

    DEVICE=eth2
    BOOTPROTO=none
    ONBOOT=yes
    NETWORK.10.0.0
    NETMASK%5.255.0.0
    IPADDR.10.0.1
    USERCTL=no
    MTU�00
    HOTPLUG=yes
    NM_MANAGED=no

    try changing BOOTPROTO=static, instead of none.


    --
    Eero
  • Eero Volotinen at Mar 26, 2013 at 4:44 am

    2013/3/26 Eero Volotinen <eero.volotinen@iki.fi>:
    2013/3/26 Joakim Ziegler <joakim@terminalmx.com>:
    Well, /etc/sysconfig/network-scripts/ifcfg-eth2 looks like this:

    DEVICE=eth2
    BOOTPROTO=none
    ONBOOT=yes
    NETWORK.10.0.0
    NETMASK%5.255.0.0
    IPADDR.10.0.1
    USERCTL=no
    MTU�00
    HOTPLUG=yes
    NM_MANAGED=no
    try changing BOOTPROTO=static, instead of none.

    some documentation also like NM_CONTROLLED=no :
    http://wiki.centos.org/FAQ/CentOS6


    --
    Eero
  • Banyan He at Mar 24, 2013 at 3:41 am
    what do you find in dmesg and /var/log/messages? The system should bring
    it up automatically. If not, you should get an error for the prompts.


    ------------
    Banyan He
    Blog: http://www.rootong.com
    Email: banyan at rootong.com

    On 3/24/2013 10:27 AM, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This is
    an InfiniBand interface, which, through the use of adapters, can also do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address, MTU,
    subnet, etc.

    Everything seems to work fine, with a single exception. If I reboot the
    Mac on the other end, causing the link state of the fiber interface to
    bounce, the network interface on the Linux box doesn't come back up when
    the link comes back up. That is, ifconfig shows it as having the link
    up, but it doesn't do the equivalent of "ifup eth2" when the link comes
    back, so it doesn't get an IP, the routing table doesn't get updated, etc.

    So, my question is, how can I make CentOS automatically configure this
    interface when the link comes back up? It's a bit annoying having to log
    in and do ifup eth2 every time...
  • Nux! at Mar 24, 2013 at 10:01 am

    On 24.03.2013 02:27, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This
    is
    an InfiniBand interface, which, through the use of adapters, can also
    do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation
    with
    a Myricom 10GbE card.

    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address,
    MTU,
    subnet, etc.

    Try adding HOTPLUG=yes in the cfg file.




    --
    Sent from the Delta quadrant using Borg technology!


    Nux!
    www.nux.ro
  • Joakim Ziegler at Mar 26, 2013 at 12:09 am

    On 24/03/13 4:01, Nux! wrote:
    On 24.03.2013 02:27, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This
    is
    an InfiniBand interface, which, through the use of adapters, can also
    do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation
    with
    a Myricom 10GbE card.
    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address,
    MTU,
    subnet, etc.
    Try adding HOTPLUG=yes in the cfg file.

    Neither HOTPLUG=yes or MANAGED=no seems to make this interface come back
    up when the cable is unplugged and then plugged, unfortunately. For
    instance, before unplugging anything, ifconfig says:


    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:47 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:14924 (14.5 KiB) TX bytes:3940 (3.8 KiB)


    Then I unplug the cable, which, in dmesg, gives me:


    mlx4_en: eth2: Link Down


    And in /var/log/messages:


    Mar 25 11:36:24 resolve02 ntpd[4819]: Deleting interface #14 eth2,
    10.10.0.1#123, interface stats: received=0, sent=0, dropped=0,
    active_time3 secs


    (Which I guess is just ntpd reacting)


    And then I plug the cable back in, and in dmesg, I have:


    mlx4_en: eth2: Link Up


    Mar 25 11:38:09 resolve02 kernel: mlx4_en: eth2: Link Up
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): carrier
    now ON (device state 2)
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): device
    state change: 2 -> 3 (reason 40)


    But ifconfig gives me:


    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:3940 (3.8 KiB)


    So no IP address, and no joy. ifup eth2 brings me back to:


    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:6493 (6.3 KiB)


    Ideas?


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
  • Earl Ramirez at Mar 26, 2013 at 1:34 am

    On Mon, 2013-03-25 at 18:09 -0600, Joakim Ziegler wrote:
    On 24/03/13 4:01, Nux! wrote:
    On 24.03.2013 02:27, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This
    is
    an InfiniBand interface, which, through the use of adapters, can also
    do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation
    with
    a Myricom 10GbE card.
    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address,
    MTU,
    subnet, etc.
    Try adding HOTPLUG=yes in the cfg file.
    Neither HOTPLUG=yes or MANAGED=no seems to make this interface come back
    up when the cable is unplugged and then plugged, unfortunately. For
    instance, before unplugging anything, ifconfig says:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:47 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:14924 (14.5 KiB) TX bytes:3940 (3.8 KiB)

    Then I unplug the cable, which, in dmesg, gives me:

    mlx4_en: eth2: Link Down

    And in /var/log/messages:

    Mar 25 11:36:24 resolve02 ntpd[4819]: Deleting interface #14 eth2,
    10.10.0.1#123, interface stats: received=0, sent=0, dropped=0,
    active_time3 secs

    (Which I guess is just ntpd reacting)

    And then I plug the cable back in, and in dmesg, I have:

    mlx4_en: eth2: Link Up

    Mar 25 11:38:09 resolve02 kernel: mlx4_en: eth2: Link Up
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): carrier
    now ON (device state 2)
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): device
    state change: 2 -> 3 (reason 40)

    But ifconfig gives me:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:3940 (3.8 KiB)

    So no IP address, and no joy. ifup eth2 brings me back to:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:6493 (6.3 KiB)

    Ideas?

    I am just shooting in the dark what happen if you have NM_CONTROLLED=yes
    in the eth2 network script?
    --




    Kind Regards
    Earl Ramirez
    GPG Key: http://trinipino.com/PublicKey.asc
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 316 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20130326/1e74686a/attachment.bin
  • Eero Volotinen at Mar 26, 2013 at 4:10 am

    Mar 25 11:38:09 resolve02 kernel: mlx4_en: eth2: Link Up
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): carrier
    now ON (device state 2)
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): device
    state change: 2 -> 3 (reason 40)

    Is the network manager REALLY disabled on that interface?


    --
    Eero
  • Joakim Ziegler at Apr 22, 2013 at 5:11 pm

    On 25/03/13 18:09, Joakim Ziegler wrote:
    On 24/03/13 4:01, Nux! wrote:
    On 24.03.2013 02:27, Joakim Ziegler wrote:
    I have a recently installed Mellanox VPI interface in my server. This
    is
    an InfiniBand interface, which, through the use of adapters, can also
    do
    10GbE over fiber. I have one of the adapter's two ports configured for
    10GbE in this way, with a point to point link to a Mac workstation
    with
    a Myricom 10GbE card.
    I've configured this interface on the Linux box (eth2) using
    /etc/sysconfig/network-scripts/ifcfg-eth2 , setting its IP address,
    MTU,
    subnet, etc.
    Try adding HOTPLUG=yes in the cfg file.
    Neither HOTPLUG=yes or MANAGED=no seems to make this interface come back
    up when the cable is unplugged and then plugged, unfortunately. For
    instance, before unplugging anything, ifconfig says:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:47 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:14924 (14.5 KiB) TX bytes:3940 (3.8 KiB)

    Then I unplug the cable, which, in dmesg, gives me:

    mlx4_en: eth2: Link Down

    And in /var/log/messages:

    Mar 25 11:36:24 resolve02 ntpd[4819]: Deleting interface #14 eth2,
    10.10.0.1#123, interface stats: received=0, sent=0, dropped=0,
    active_time3 secs

    (Which I guess is just ntpd reacting)

    And then I plug the cable back in, and in dmesg, I have:

    mlx4_en: eth2: Link Up

    Mar 25 11:38:09 resolve02 kernel: mlx4_en: eth2: Link Up
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): carrier
    now ON (device state 2)
    Mar 25 11:38:09 resolve02 NetworkManager[4429]: <info> (eth2): device
    state change: 2 -> 3 (reason 40)

    But ifconfig gives me:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:3940 (3.8 KiB)

    So no IP address, and no joy. ifup eth2 brings me back to:

    eth2 Link encap:Ethernet HWaddr 00:02:C9:29:64:8F
    inet addr:10.10.0.1 Bcast:10.10.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2:c900:129:648f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
    RX packets:104 errors:0 dropped:0 overruns:0 frame:0
    TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25567 (24.9 KiB) TX bytes:6493 (6.3 KiB)

    Ideas?

    Hello, I'm just trying to get back to this, since no one has answered my
    questions... Is this really a very difficult thing to accomplish?


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
  • Nux! at Apr 22, 2013 at 5:22 pm

    On 22.04.2013 18:11, Joakim Ziegler wrote:
    Hello, I'm just trying to get back to this, since no one has answered
    my
    questions... Is this really a very difficult thing to accomplish?

    Hi,


    Can you make a short list of what you tried and did not work? I've
    already lost count.


    Lucian


    --
    Sent from the Delta quadrant using Borg technology!


    Nux!
    www.nux.ro
  • Joakim Ziegler at Apr 22, 2013 at 5:30 pm
    I've tried various combinations of HOTPLUG=yes and no, and MANAGED=yes
    and no, then someone asked me if this was really not managed, so I
    posted the dmesg output above.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 22/04/13 12:22, Nux! wrote:
    On 22.04.2013 18:11, Joakim Ziegler wrote:
    Hello, I'm just trying to get back to this, since no one has answered
    my
    questions... Is this really a very difficult thing to accomplish?
    Hi,

    Can you make a short list of what you tried and did not work? I've
    already lost count.

    Lucian
  • Eero Volotinen at Apr 22, 2013 at 5:38 pm
    http://www.putorius.net/2012/10/how-to-configure-static-ip-address-in.html




    2013/4/22 Joakim Ziegler <joakim@terminalmx.com>

    I've tried various combinations of HOTPLUG=yes and no, and MANAGED=yes
    and no, then someone asked me if this was really not managed, so I
    posted the dmesg output above.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 22/04/13 12:22, Nux! wrote:
    On 22.04.2013 18:11, Joakim Ziegler wrote:
    Hello, I'm just trying to get back to this, since no one has answered
    my
    questions... Is this really a very difficult thing to accomplish?
    Hi,

    Can you make a short list of what you tried and did not work? I've
    already lost count.

    Lucian
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Joakim Ziegler at Apr 22, 2013 at 9:16 pm
    Do I need to disable NetworkManager for everything to make this work?


    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 22/04/13 12:38, Eero Volotinen wrote:
    http://www.putorius.net/2012/10/how-to-configure-static-ip-address-in.html


    2013/4/22 Joakim Ziegler <joakim@terminalmx.com>
    I've tried various combinations of HOTPLUG=yes and no, and MANAGED=yes
    and no, then someone asked me if this was really not managed, so I
    posted the dmesg output above.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 22/04/13 12:22, Nux! wrote:
    On 22.04.2013 18:11, Joakim Ziegler wrote:
    Hello, I'm just trying to get back to this, since no one has answered
    my
    questions... Is this really a very difficult thing to accomplish?
    Hi,

    Can you make a short list of what you tried and did not work? I've
    already lost count.

    Lucian
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Mark Roth at Apr 22, 2013 at 9:26 pm

    Joakim Ziegler wrote:
    Do I need to disable NetworkManager for everything to make this work?

    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.
    <snip>
    Disabling NetworkManager, if you've got a wired connection, is *always* a
    Good Idea, IMO. There's *no* reason for it on anything but a mobile
    system.


    Now - did you say that this was an infiniband connection? We've got one
    system like that, and it's ip0. The ifcfg-ib0 we've got is
    DEVICE=ib0
    TYPE=Infiniband
    BOOTPROTO=static
    BROADCAST2.168.20.255
    IPADDR2.168.20.1
    NETMASK%5.255.255.0
    NETWORK2.168.20.0
    ONBOOT=yes


    mark
  • Joakim Ziegler at Apr 22, 2013 at 11:34 pm
    It's not an InfiniBand connection per se. It's a Mellanox VPI card,
    which has IB ports that can be configured to be 10GbE, through an
    adapter and fiber transciever. I've currently got one of its two ports
    set up to be 10GbE, and it shows up as eth2. The other port on the card,
    which is configured as IB, is indeed ib0, but that's not the one causing
    me problems.


    I will try to completely disable NetworkManager per the instructions,
    and see if that works. Thanks.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 22/04/13 16:26, m.roth at 5-cent.us wrote:
    Joakim Ziegler wrote:
    Do I need to disable NetworkManager for everything to make this work?

    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.
    <snip>
    Disabling NetworkManager, if you've got a wired connection, is *always* a
    Good Idea, IMO. There's *no* reason for it on anything but a mobile
    system.

    Now - did you say that this was an infiniband connection? We've got one
    system like that, and it's ip0. The ifcfg-ib0 we've got is
    DEVICE=ib0
    TYPE=Infiniband
    BOOTPROTO=static
    BROADCAST2.168.20.255
    IPADDR2.168.20.1
    NETMASK%5.255.255.0
    NETWORK2.168.20.0
    ONBOOT=yes

    mark


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • John Doe at Apr 23, 2013 at 9:25 am
    From: Joakim Ziegler <joakim@terminalmx.com>

    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.

    Not the solution you want but, as a last resort, you could always have a
    cron script that checks every minute if the link is down...


    JD
  • Carl T. Miller at Apr 23, 2013 at 10:09 am

    On 04/23/2013 05:25 AM, John Doe wrote:
    From: Joakim Ziegler <joakim@terminalmx.com>
    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.
    Not the solution you want but, as a last resort, you could always have a
    cron script that checks every minute if the link is down...

    Or consider putting "* * * * * /sbin/ifup eth2" in root's crontab. If
    eth2 is up, it simply rereads the configs (which haven't changed). If
    it was down, it brings it up.


    c
  • Joakim Ziegler at Apr 24, 2013 at 6:02 am
    This seems really dirty. :)


    Also, I actually have to take it down and back up to make it work
    currently. But I will try the recipe I got soon and see if that fixes it.


    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864

    On 23/04/13 5:09, Carl T. Miller wrote:
    On 04/23/2013 05:25 AM, John Doe wrote:
    From: Joakim Ziegler <joakim@terminalmx.com>
    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.
    Not the solution you want but, as a last resort, you could always have a
    cron script that checks every minute if the link is down...
    Or consider putting "* * * * * /sbin/ifup eth2" in root's crontab. If
    eth2 is up, it simply rereads the configs (which haven't changed). If
    it was down, it brings it up.

    c



    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Svavar Örn Eysteinsson at Apr 24, 2013 at 11:17 am
    You can create these two files which will be executed every time interface comes up & goes down.


    /sbin/ifup-local
    /sbin/ifdown-local


    mark them as executable.


    The Device name will be passed as argument.


    example, /sbin/ifup-local eth0.


    use case or if statements for interface parsing in the script.


















    On 24.4.2013, at 06:02, Joakim Ziegler wrote:

    This seems really dirty. :)

    Also, I actually have to take it down and back up to make it work
    currently. But I will try the recipe I got soon and see if that fixes it.

    --
    Joakim Ziegler - Supervisor de postproducci?n - Terminal
    joakim at terminalmx.com - 044 55 2971 8514 - 5264 0864
    On 23/04/13 5:09, Carl T. Miller wrote:
    On 04/23/2013 05:25 AM, John Doe wrote:
    From: Joakim Ziegler <joakim@terminalmx.com>
    As I'd mentioned before, the problem isn't that the interface doesn't
    come up on boot, it does, but since it's a point to point interface,
    when I reboot the computer on the other end, it goes down and doesn't
    come back up automatically. That is, link going down and up makes the
    network configuration stay down, I have to manually take the interface
    down and back up to make it work again.
    Not the solution you want but, as a last resort, you could always have a
    cron script that checks every minute if the link is down...
    Or consider putting "* * * * * /sbin/ifup eth2" in root's crontab. If
    eth2 is up, it simply rereads the configs (which haven't changed). If
    it was down, it brings it up.

    c



    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Gordon Messmer at Apr 24, 2013 at 5:07 pm

    On 04/22/2013 10:30 AM, Joakim Ziegler wrote:
    I've tried various combinations of HOTPLUG=yes and no, and MANAGED=yes
    and no, then someone asked me if this was really not managed, so I
    posted the dmesg output above.

    I'm pretty sure HOTPLUG is only used when the interface ITSELF is
    attached to the system at runtime, not the cable, and MANAGED isn't used
    at all.


    If you set NM_CONTROLLED=no then the configuration will be loaded only
    if the system starts the "network" service and the configuration will
    not change on link up/link down.


    Otherwise, you need to check the messages log file for information from
    NetworkManager. dmesg will not tell you what you need to know.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedMar 24, '13 at 2:27a
activeApr 24, '13 at 5:07p
posts27
users11
websitecentos.org
irc#centos

People

Translate

site design / logo © 2021 Grokbase