FAQ
Hi all


I get a Cisco 1841 router, connecting the office through a CHAP PPPoE link:
[...]
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname username at isp
ppp chap password 0 s0meStr0ngP4sswd
[...]




As a fallback solution, I would like to setup a CentOS Dual NIC 1U unit.
I dont want to use NetworkManager, I'd rather use the bare interface
configuration tools.
I'm running CentOS 6.3




I looked for the right way to configure the internface:
- http://goo.gl/UaNBe: officiel doc, found no indication.
- http://goo.gl/DQ5Gk: using rp-pppoe, is it the right way?
- http://goo.gl/PTaes: seem to be right, but which package is it from?








--
RMA.

Search Discussions

  • Robert Moskowitz at Mar 11, 2013 at 5:20 am

    On 03/11/2013 01:05 AM, Mihamina Rakotomandimby wrote:
    Hi all

    I get a Cisco 1841 router, connecting the office through a CHAP PPPoE link:
    [...]
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname username at isp
    ppp chap password 0 s0meStr0ngP4sswd
    [...]


    As a fallback solution, I would like to setup a CentOS Dual NIC 1U unit.
    I dont want to use NetworkManager, I'd rather use the bare interface
    configuration tools.
    I'm running CentOS 6.3


    I looked for the right way to configure the internface:
    - http://goo.gl/UaNBe: officiel doc, found no indication.
    - http://goo.gl/DQ5Gk: using rp-pppoe, is it the right way?
    - http://goo.gl/PTaes: seem to be right, but which package is it from?

    I am sure someone has something more current, I think my old box was
    running C5.3 or even earlier. I saved the control files off it and my
    ifcfg-ppp0 was:


    USERCTL=no
    BOOTPROTO=dialup
    NAME=DSLppp0
    DEVICE=ppp0
    TYPE=xDSL
    ONBOOT=yes
    PIDFILE=/var/run/pppoe-adsl.pid
    FIREWALL=NONE
    PING=.
    PPPOE_TIMEOUT�
    LCP_FAILURE=3
    LCP_INTERVAL
    CLAMPMSS12
    CONNECT_POLL=6
    CONNECT_TIMEOUT`
    DEFROUTE=yes
    SYNCHRONOUS=no
    ETH=eth0
    PROVIDER=DSLppp0
    USER='me at isp.net'
    PEERDNS=no
    DEMAND=no
    PERSIST=no
    IPV6INIT=yes
    PPPD_EXTRA="ipv6 ,"


    There was also a ppp directory that had files: options, pap-secrets, and
    chap-secrets


    But like I said, old box.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedMar 11, '13 at 5:05a
activeMar 11, '13 at 5:20a
posts2
users2
websitecentos.org
irc#centos

People

Translate

site design / logo © 2021 Grokbase