FAQ
Hi All,

One of my servers upon a restart today comes up with an error

checking filesystems:

fsck.ext3: no such file or directory while trying to open /dev/VolGroup-1/Logvol00.

/dev/VolGroup-1/LogVol00. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>

I dropped into the shell and tried mounting:

mount -t ext3 /dev/VolGroup-1/LogVol00

I tried booting to media and do 'linux rescue' but it could not mount file filesystems either and nothing at all ends up in /mnt/sysimage.

I think this was caused by installing quotas and changing /etc/fstab to add ,usrquota,grpquota.

There are 2 x 1tb drives, software raid, mirrored.

Can anyone provide advice on how to solve? I would think if I could get /etc/fstab edited back to normal I would be all set.

-Jason

Search Discussions

  • Dennis Jacobfeuerborn at Jan 30, 2012 at 12:59 pm
    The "no such file or directory" sound more like the LV cannot be found.
    What does "lvdisplay" say?

    Regards,
    Dennis
    On 01/30/2012 06:56 PM, Jason T. Slack-Moehrle wrote:
    Hi All,

    One of my servers upon a restart today comes up with an error

    checking filesystems:

    fsck.ext3: no such file or directory while trying to open /dev/VolGroup-1/Logvol00.

    /dev/VolGroup-1/LogVol00. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193<device>

    I dropped into the shell and tried mounting:

    mount -t ext3 /dev/VolGroup-1/LogVol00

    I tried booting to media and do 'linux rescue' but it could not mount file filesystems either and nothing at all ends up in /mnt/sysimage.

    I think this was caused by installing quotas and changing /etc/fstab to add ,usrquota,grpquota.

    There are 2 x 1tb drives, software raid, mirrored.

    Can anyone provide advice on how to solve? I would think if I could get /etc/fstab edited back to normal I would be all set.

    -Jason
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 1:01 pm
    It says "File based locking initialization failed"


    --
    Jason T. Slack-Moehrle

    On Monday, January 30, 2012 at 9:59 AM, Dennis Jacobfeuerborn wrote:

    The "no such file or directory" sound more like the LV cannot be found.
    What does "lvdisplay" say?

    Regards,
    Dennis
    On 01/30/2012 06:56 PM, Jason T. Slack-Moehrle wrote:
    Hi All,

    One of my servers upon a restart today comes up with an error

    checking filesystems:

    fsck.ext3: no such file or directory while trying to open /dev/VolGroup-1/Logvol00.

    /dev/VolGroup-1/LogVol00. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193<device>

    I dropped into the shell and tried mounting:

    mount -t ext3 /dev/VolGroup-1/LogVol00

    I tried booting to media and do 'linux rescue' but it could not mount file filesystems either and nothing at all ends up in /mnt/sysimage.

    I think this was caused by installing quotas and changing /etc/fstab to add ,usrquota,grpquota.

    There are 2 x 1tb drives, software raid, mirrored.

    Can anyone provide advice on how to solve? I would think if I could get /etc/fstab edited back to normal I would be all set.

    -Jason
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org (mailto:CentOS at centos.org)
    http://lists.centos.org/mailman/listinfo/centos


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org (mailto:CentOS at centos.org)
    http://lists.centos.org/mailman/listinfo/centos
  • Dennis Jacobfeuerborn at Jan 30, 2012 at 1:06 pm

    On 01/30/2012 07:01 PM, Jason T. Slack-Moehrle wrote:
    It says "File based locking initialization failed"
    Try the --ignorelockingfailure argument.

    Regards,
    Dennis
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 1:14 pm

    It says "File based locking initialization failed"

    Try the --ignorelockingfailure argument.
    I am not familiar with that and 'man lvdisplay' does not show it as an option. Google for that turns up more results. Is it used with e2fsck, I dont see it there either.
  • Dennis Jacobfeuerborn at Jan 30, 2012 at 1:24 pm

    On 01/30/2012 07:14 PM, Jason T. Slack-Moehrle wrote:
    It says "File based locking initialization failed"

    Try the --ignorelockingfailure argument.
    I am not familiar with that and 'man lvdisplay' does not show it as an option. Google for that turns up more results. Is it used with e2fsck, I dont see it there either.


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    It's an option for most LVM commands. Do a "man lvdisplay" and look in the
    SYNOPSIS section. Apparently most options lvdisplay understands aren't
    actually listed in the OPTIONS section.

    Regards,
    Dennis
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 1:28 pm

    It says "File based locking initialization failed"


    Try the --ignorelockingfailure argument.
    I am not familiar with that and 'man lvdisplay' does not show it as an option. Google for that turns up more results. Is it used with e2fsck, I dont see it there either.
    It's an option for most LVM commands. Do a "man lvdisplay" and look in the
    SYNOPSIS section. Apparently most options lvdisplay understands aren't
    actually listed in the OPTIONS section.
    Thanks.

    It does list out the volume information, what else should it do?
  • Ljubomir Ljubojevic at Jan 30, 2012 at 2:28 pm

    On 01/30/2012 07:28 PM, Jason T. Slack-Moehrle wrote:
    It says "File based locking initialization failed"


    Try the --ignorelockingfailure argument.
    I am not familiar with that and 'man lvdisplay' does not show it as an option. Google for that turns up more results. Is it used with e2fsck, I dont see it there either.
    It's an option for most LVM commands. Do a "man lvdisplay" and look in the
    SYNOPSIS section. Apparently most options lvdisplay understands aren't
    actually listed in the OPTIONS section.
    Thanks.

    It does list out the volume information, what else should it do?
    what does lvm lvscan says, are they active? if not, run "vgchange -a y
    VolGroup-1" to activate them (temporary only, while using that
    DVD/LiveDVD). it should activate that Volume Group and all Logical
    Volumes in it. Now you can scan it wit fsck

    Then you may need to mount it in some created folder (mkdir -p
    /sysimage/LogVol00; mount /dev/VolGroup-1/LogVol00 /sysimage/LogVol00).

    Check if your system had any updates (kernel in particular) between
    reboots. Maybe something gone bad.



    --

    Ljubomir Ljubojevic
    (Love is in the Air)
    PL Computers
    Serbia, Europe

    Google is the Mother, Google is the Father, and traceroute is your
    trusty Spiderman...
    StarOS, Mikrotik and CentOS/RHEL/Linux consultant
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 6:43 pm
    Hi,
    Try the --ignorelockingfailure argument.

    I am not familiar with that and 'man lvdisplay' does not show it as an option. Google for that turns up more results. Is it used with e2fsck, I dont see it there either.
    It's an option for most LVM commands. Do a "man lvdisplay" and look in the
    SYNOPSIS section. Apparently most options lvdisplay understands aren't
    actually listed in the OPTIONS section.


    Thanks.

    It does list out the volume information, what else should it do?
    what does lvm lvscan says, are they active? if not, run "vgchange -a y
    VolGroup-1" to activate them (temporary only, while using that
    DVD/LiveDVD). it should activate that Volume Group and all Logical
    Volumes in it. Now you can scan it wit fsck

    Then you may need to mount it in some created folder (mkdir -p
    /sysimage/LogVol00; mount /dev/VolGroup-1/LogVol00 /sysimage/LogVol00).

    Check if your system had any updates (kernel in particular) between
    reboots. Maybe something gone bad.
    I did vgchange -a y VolGroup00

    and it activated 3 volumes

    So I am trying to fsck and it comes up with the same super block error I had but I dont see how to fix it.

    It says:

    /dev/VolGroup00/. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>

    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?

    -Jason
  • Kahlil Hodgson at Jan 30, 2012 at 6:49 pm

    On Mon, 2012-01-30 at 15:43 -0800, Jason T. Slack-Moehrle wrote:

    It says:

    /dev/VolGroup00/. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>

    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?
    You need to fsck each logical volume, not the whole volume group, e.g.

    e2fsck -b 8193 /dev/VolGroup00/LogVol01

    or whatever.
    Look under /dev/VolGroup00 to see what's there.

    K
    --
    Kahlil (Kal) Hodgson GPG: C9A02289
    Head of Technology (m) +61 (0) 4 2573 0382
    DealMax Pty Ltd (w) +61 (0) 3 9008 5281

    Suite 1005
    401 Docklands Drive
    Docklands VIC 3008 Australia

    "All parts should go together without forcing. You must remember that
    the parts you are reassembling were disassembled by you. Therefore,
    if you can't get them together again, there must be a reason. By all
    means, do not use a hammer." -- IBM maintenance manual, 1925
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 7:36 pm

    It says:

    /dev/VolGroup00/. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>

    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?
    You need to fsck each logical volume, not the whole volume group, e.g.

    e2fsck -b 8193 /dev/VolGroup00/LogVol01
    sure, I thought of that too.

    under /dev/VolGroup00 is LogVol00, LogVol01, LogVol02.

    I do e2fsck -b 8193 /dev/VolGroup00/LogVol00 and I get the same super block error above.

    Same with LogVol01 and 02.

    -Jason
  • Jason T. Slack-Moehrle at Jan 30, 2012 at 7:38 pm

    It says:

    /dev/VolGroup00/. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>

    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?
    You need to fsck each logical volume, not the whole volume group, e.g.

    e2fsck -b 8193 /dev/VolGroup00/LogVol01
    sure, I thought of that too.

    under /dev/VolGroup00 is LogVol00, LogVol01, LogVol02.

    I do e2fsck -b 8193 /dev/VolGroup00/LogVol00 and I get the same super block error above.

    Same with LogVol01 and 02.
    Forgot:

    e2fsck: Bad magic number in super-block while trying to open LogVol00

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
  • Paul (GPR Support) at Jan 31, 2012 at 2:24 am
    You might try

    # dumpe2fs /dev/<your device> | grep superblock


    Then from this output - if you can get any - use one of the backup
    superblocks with

    #e2fsck -b <number from above output> /dev/VolGroup00/<logical volume>
    -----Original Message-----
    From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
    Behalf Of Jason T. Slack-Moehrle
    Sent: 31 January 2012 02:38
    To: CentOS mailing list
    Subject: Re: [CentOS] One of my servers wont boot today
    It says:

    /dev/VolGroup00/. The superblock could not be read or does not
    describe a correct ext2 filesystem. If the device is valid and it
    really contains an ext2 filesystem (and not swap or ufs or something
    else), then the superblock is corrupt, and you might try running e2fsck
    with an alternate superblock: e2fsck -b 8193 <device>
    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?
    You need to fsck each logical volume, not the whole volume group,
    e.g.
    e2fsck -b 8193 /dev/VolGroup00/LogVol01
    sure, I thought of that too.

    under /dev/VolGroup00 is LogVol00, LogVol01, LogVol02.

    I do e2fsck -b 8193 /dev/VolGroup00/LogVol00 and I get the same super
    block error above.
    Same with LogVol01 and 02.
    Forgot:

    e2fsck: Bad magic number in super-block while trying to open LogVol00

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate
    superblock:
    e2fsck -b 8193 <device>


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Paul (GPR Support) at Jan 31, 2012 at 2:40 am
    Another possible way of getting backup superblock info is with

    # mke2fs -n /dev/<your device>

    And then use this with

    #e2fsck -b <backup block> /dev/<your device>

    mke2fs with the -n switch, runs as though it would create a new filesystem
    without actually writing anything to disk. So it tells you where it would
    put the backup superblocks if it were to run in full filesystem creation
    mode. This means that if you use different parameters from the ones used in
    actually creating the file system to begin with, you may get the wrong
    backup superblock info. Nothing should break by doing this anyway.
    -----Original Message-----
    From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
    Behalf Of Jason T. Slack-Moehrle
    Sent: 31 January 2012 02:38
    To: CentOS mailing list
    Subject: Re: [CentOS] One of my servers wont boot today
    It says:

    /dev/VolGroup00/. The superblock could not be read or does not
    describe a correct ext2 filesystem. If the device is valid and it
    really contains an ext2 filesystem (and not swap or ufs or something
    else), then the superblock is corrupt, and you might try running e2fsck
    with an alternate superblock: e2fsck -b 8193 <device>
    So I tried e2fsck -b 8193 /dev/VolGroup00

    and it seems I get the same error coming up over and over

    I tried:

    fsck -y b�93 /dev/VolGroup00 as well

    Any thoughts?
    You need to fsck each logical volume, not the whole volume group,
    e.g.
    e2fsck -b 8193 /dev/VolGroup00/LogVol01
    sure, I thought of that too.

    under /dev/VolGroup00 is LogVol00, LogVol01, LogVol02.

    I do e2fsck -b 8193 /dev/VolGroup00/LogVol00 and I get the same super
    block error above.
    Same with LogVol01 and 02.
    Forgot:

    e2fsck: Bad magic number in super-block while trying to open LogVol00

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate
    superblock:
    e2fsck -b 8193 <device>


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Ryan Ivey at Jan 30, 2012 at 1:55 pm


    Can anyone provide advice on how to solve? I would think if I could get
    /etc/fstab edited back to normal I would be all set.
    <http://lists.centos.org/mailman/listinfo/centos>

    Yea, try a LiveCD and try mounting it there and make your adjustments to
    /etc/fstab, although I don't think your addition of usrquota,grpquota is
    the sole reason for this issue.


    --
    M. Ryan Ivey
    www.initialss.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedJan 30, '12 at 12:56p
activeJan 31, '12 at 2:40a
posts15
users6
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase