FAQ
I just tried to update to CentOS 6.2, but I am faced with "Errors: Protected multilib versions" error, the offending packages are:

jasper-libs.i686
krb5-libs.i686
nss.i686

After some investigation, it turns out that there are newer packages in "x86_64 updates" repository, but only for x86_64 version, while in "x86_64 main" repository there are older i686 version packages, causing version conflict. To solve these problem, I have to manually install the newer i686 packages in "i686 updates" repository. Is there anything wrong in the build system that lacked those i686 packages in"x86_64 updates" repository?

Search Discussions

  • Lee_yiu_chung at Dec 21, 2011 at 2:38 am

    I just tried to update to CentOS 6.2, but I am faced with "Errors: Protected multilib versions" error, the offending packages are:

    jasper-libs.i686
    krb5-libs.i686
    nss.i686

    After some investigation, it turns out that there are newer packages in "x86_64 updates" repository, but only for x86_64 version, while in "x86_64 main" repository there are older i686 version packages, causing version conflict. To solve these problem, I have to manually install the newer i686 packages in "i686 updates" repository. Is there anything wrong in the build system that lacked those i686 packages in"x86_64 updates" repository?

    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    Sorry that I got Chinese name mangled in the email...and I think it would be better to clarify
    something.

    In CentOS/6.2/os/x86_64/Packages (x86_64 main), there are those packages available:

    jasper-libs-1.900.1-15.el6.i686.rpm
    jasper-libs-1.900.1-15.el6.x86_64.rpm
    krb5-libs-1.9-22.el6.i686.rpm
    krb5-libs-1.9-22.el6.x86_64.rpm
    nss-3.12.10-16.el6.i686.rpm
    nss-3.12.10-16.el6.x86_64.rpm

    But in CentOS/6.2/updates/x86_64/Packages (x86_64 updates), only these packages are available:
    jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm
    krb5-libs-1.9-22.el6_2.1.x86_64.rpm
    nss-3.12.10-17.el6_2.x86_64.rpm

    So when I tried to run "yum update" to upgrade to 6.2, these packages would be picked up and caused
    multilib error:

    jasper-libs-1.900.1-15.el6.i686.rpm (x86_64 main)
    jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm (x86_64 updates)
    krb5-libs-1.9-22.el6.i686.rpm (x86_64 main)
    krb5-libs-1.9-22.el6_2.1.x86_64.rpm (x86_64 updates)
    nss-3.12.10-16.el6.i686.rpm (x86_64 main)
    nss-3.12.10-17.el6_2.x86_64.rpm (x86_64 updates)

    To solve this problem, I have to manually pick up these packages from
    CentOS/6.2/updates/i386/Packages (i386 update) and install them:
    jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    krb5-libs-1.9-22.el6_2.1.i686.rpm
    nss-3.12.10-17.el6_2.i686.rpm

    Hope this would clarify the situation.
  • Mogens Kjaer at Dec 21, 2011 at 2:57 am
    On 12/21/2011 08:38 AM, lee_yiu_chung at yahoo.com wrote:
    ...
    To solve this problem, I have to manually pick up these packages from
    CentOS/6.2/updates/i386/Packages (i386 update) and install them:
    jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    krb5-libs-1.9-22.el6_2.1.i686.rpm
    nss-3.12.10-17.el6_2.i686.rpm
    These are required by the i486 version of Adobe Reader.

    I did a (on one line):

    rpm -Uvh
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/krb5-libs-1.9-22.el6_2.1.i686.rpm
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/nss-3.12.10-17.el6_2.i686.rpm

    to fix this (replace ftp.crc.dk with your local mirror).

    Mogens
    --
    Mogens Kjaer, mk at lemo.dk
    http://www.lemo.dk
  • Wwp at Dec 21, 2011 at 3:48 am
    Hello Mogens,

    On Wed, 21 Dec 2011 08:57:59 +0100 Mogens Kjaer wrote:

    On 12/21/2011 08:38 AM, lee_yiu_chung at yahoo.com wrote:
    ...
    To solve this problem, I have to manually pick up these packages from
    CentOS/6.2/updates/i386/Packages (i386 update) and install them:
    jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    krb5-libs-1.9-22.el6_2.1.i686.rpm
    nss-3.12.10-17.el6_2.i686.rpm
    These are required by the i486 version of Adobe Reader.

    I did a (on one line):

    rpm -Uvh
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/krb5-libs-1.9-22.el6_2.1.i686.rpm
    http://ftp.crc.dk/centos/6.2/updates/i386/Packages/nss-3.12.10-17.el6_2.i686.rpm

    to fix this (replace ftp.crc.dk with your local mirror).
    Thanks! I was facing the same issue, solved now.


    Regards,

    --
    wwp
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 198 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20111221/0f39d9bb/attachment.bin
  • Akemi Yagi at Dec 21, 2011 at 4:34 am

    On Tue, Dec 20, 2011 at 11:38 PM, lee_yiu_chung at yahoo.com wrote:

    In CentOS/6.2/os/x86_64/Packages (x86_64 main), there are those packages available:

    jasper-libs-1.900.1-15.el6.i686.rpm
    jasper-libs-1.900.1-15.el6.x86_64.rpm
    krb5-libs-1.9-22.el6.i686.rpm
    krb5-libs-1.9-22.el6.x86_64.rpm
    nss-3.12.10-16.el6.i686.rpm
    nss-3.12.10-16.el6.x86_64.rpm

    But in CentOS/6.2/updates/x86_64/Packages (x86_64 updates), only these packages are available:
    jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm
    krb5-libs-1.9-22.el6_2.1.x86_64.rpm
    nss-3.12.10-17.el6_2.x86_64.rpm
    CentOS bug filed here:

    http://bugs.centos.org/view.php?idS30

    Thanks,

    Akemi
  • Johnny Hughes at Dec 21, 2011 at 5:44 am

    On 12/21/2011 01:38 AM, lee_yiu_chung at yahoo.com wrote:
    I just tried to update to CentOS 6.2, but I am faced with "Errors: Protected multilib versions" error, the offending packages are:

    jasper-libs.i686
    krb5-libs.i686
    nss.i686

    After some investigation, it turns out that there are newer packages in "x86_64 updates" repository, but only for x86_64 version, while in "x86_64 main" repository there are older i686 version packages, causing version conflict. To solve these problem, I have to manually install the newer i686 packages in "i686 updates" repository. Is there anything wrong in the build system that lacked those i686 packages in"x86_64 updates" repository?

    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    Sorry that I got Chinese name mangled in the email...and I think it would be better to clarify
    something.

    In CentOS/6.2/os/x86_64/Packages (x86_64 main), there are those packages available:

    jasper-libs-1.900.1-15.el6.i686.rpm
    jasper-libs-1.900.1-15.el6.x86_64.rpm
    krb5-libs-1.9-22.el6.i686.rpm
    krb5-libs-1.9-22.el6.x86_64.rpm
    nss-3.12.10-16.el6.i686.rpm
    nss-3.12.10-16.el6.x86_64.rpm

    But in CentOS/6.2/updates/x86_64/Packages (x86_64 updates), only these packages are available:
    jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm
    krb5-libs-1.9-22.el6_2.1.x86_64.rpm
    nss-3.12.10-17.el6_2.x86_64.rpm

    So when I tried to run "yum update" to upgrade to 6.2, these packages would be picked up and caused
    multilib error:

    jasper-libs-1.900.1-15.el6.i686.rpm (x86_64 main)
    jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm (x86_64 updates)
    krb5-libs-1.9-22.el6.i686.rpm (x86_64 main)
    krb5-libs-1.9-22.el6_2.1.x86_64.rpm (x86_64 updates)
    nss-3.12.10-16.el6.i686.rpm (x86_64 main)
    nss-3.12.10-17.el6_2.x86_64.rpm (x86_64 updates)

    To solve this problem, I have to manually pick up these packages from
    CentOS/6.2/updates/i386/Packages (i386 update) and install them:
    jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    krb5-libs-1.9-22.el6_2.1.i686.rpm
    nss-3.12.10-17.el6_2.i686.rpm

    Hope this would clarify the situation.
    Thanks for the report, this is now fixed on the master mirror and will
    be syncing to all the other mirrors shortly. The following multilib
    packages were added to the updates/x86_64/Packages directory:

    bind-devel-9.7.3-8.P3.el6_2.1.i686.rpm
    bind-libs-9.7.3-8.P3.el6_2.1.i686.rpm
    dhcp-devel-4.1.1-25.P1.el6_2.1.i686.rpm
    finch-2.7.9-3.el6.2.i686.rpm
    finch-devel-2.7.9-3.el6.2.i686.rpm
    jasper-devel-1.900.1-15.el6_1.1.i686.rpm
    jasper-libs-1.900.1-15.el6_1.1.i686.rpm
    krb5-devel-1.9-22.el6_2.1.i686.rpm
    krb5-libs-1.9-22.el6_2.1.i686.rpm
    krb5-server-ldap-1.9-22.el6_2.1.i686.rpm
    libicu-4.2.1-9.1.el6_2.i686.rpm
    libicu-devel-4.2.1-9.1.el6_2.i686.rpm
    libipa_hbac-1.5.1-66.el6_2.1.i686.rpm
    libipa_hbac-devel-1.5.1-66.el6_2.1.i686.rpm
    libpurple-2.7.9-3.el6.2.i686.rpm
    libpurple-devel-2.7.9-3.el6.2.i686.rpm
    libvirt-client-0.9.4-23.el6_2.1.i686.rpm
    libvirt-devel-0.9.4-23.el6_2.1.i686.rpm
    net-snmp-devel-5.5-37.el6_2.1.i686.rpm
    net-snmp-libs-5.5-37.el6_2.1.i686.rpm
    nss-3.12.10-17.el6_2.i686.rpm
    nss-devel-3.12.10-17.el6_2.i686.rpm
    nss-pkcs11-devel-3.12.10-17.el6_2.i686.rpm
    pidgin-devel-2.7.9-3.el6.2.i686.rpm
    sssd-client-1.5.1-66.el6_2.1.i686.rpm
    xorg-x11-server-devel-1.10.4-6.el6_2.1.i686.rpm

    Better still, the faulty compare to copy multilib items into x86_64
    (which was not seeing any packages) was fixed as well, so this should
    not recur.

    Thanks,
    Johnny Hughes

    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 262 bytes
    Desc: OpenPGP digital signature
    Url : http://lists.centos.org/pipermail/centos/attachments/20111221/90786b80/attachment.bin
  • Pavel Lisy at Dec 21, 2011 at 5:03 am

    ??? p??e v ?t 20. 12. 2011 v 22:54 -0800:
    I just tried to update to CentOS 6.2, but I am faced with "Errors: Protected multilib versions" error, the offending packages are:

    jasper-libs.i686
    krb5-libs.i686
    nss.i686
    After some investigation, it turns out that there are newer packages in "x86_64 updates" repository, but only for x86_64 version, while in "x86_64 main" repository there are older i686 version packages, causing version conflict. To solve these problem, I have to manually install the newer i686 packages in "i686 updates" repository. Is there anything wrong in the build system that lacked those i686 packages in"x86_64 updates" repository?
    You can try new yum option, it helped me
    --setopt=protected_multilib=false

    Pavel

    --
    Pavel Lisy <pavel.lisy at gmail.com>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedDec 21, '11 at 1:54a
activeDec 21, '11 at 5:44a
posts7
users6
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase