FAQ
I have a 1.5TB Western Digital hard disk (WD15EADS-00R6B0)
on my CentOS-5.7 server, which has become incredibly slow
for some operations, eg rsync, BackupPC archive, e2fsck,
although it seems to work fine for ordinary file operations,
and "smartctl -a /dev/sdb" does not report any errors.

For example, running "e2fsck -p /dev/sdb5" on a 250GB partition
on this disk took over 24 hours to complete,
as it did on another partition.

I wonder if anyone can offer an explanation,
or suggest a remedy?


--
Timothy Murphy
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin

Search Discussions

  • Ilyas -- at Dec 4, 2011 at 8:06 am
    Just check smart table:

    smartctl -a -d ata /dev/sdX

    Sometimes disk work very slowly without any visible reason. In this
    case just replace your disk.


    On Sun, Dec 4, 2011 at 4:46 PM, Timothy Murphy wrote:
    I have a 1.5TB Western Digital hard disk (WD15EADS-00R6B0)
    on my CentOS-5.7 server, which has become incredibly slow
    for some operations, eg rsync, BackupPC archive, e2fsck,
    although it seems to work fine for ordinary file operations,
    and "smartctl -a /dev/sdb" does not report any errors.

    For example, running "e2fsck -p /dev/sdb5" on a 250GB partition
    on this disk took over 24 hours to complete,
    as it did on another partition.

    I wonder if anyone can offer an explanation,
    or suggest a remedy?


    --
    Timothy Murphy
    e-mail: gayleard /at/ eircom.net
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College Dublin


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos


    --
    GPG Key ID: 6EC5EB27
  • Ho Chaw Ming at Dec 4, 2011 at 9:24 am
    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .

    -----Original Message-----
    From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
    Of Timothy Murphy
    Sent: Sunday, 4 December, 2011 8:46 PM
    To: centos at centos.org
    Subject: [CentOS] Strangely slow disk

    I have a 1.5TB Western Digital hard disk (WD15EADS-00R6B0) on my CentOS-5.7
    server, which has become incredibly slow for some operations, eg rsync,
    BackupPC archive, e2fsck, although it seems to work fine for ordinary file
    operations, and "smartctl -a /dev/sdb" does not report any errors.

    For example, running "e2fsck -p /dev/sdb5" on a 250GB partition on this disk
    took over 24 hours to complete, as it did on another partition.

    I wonder if anyone can offer an explanation, or suggest a remedy?


    --
    Timothy Murphy
    e-mail: gayleard /at/ eircom.net
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College Dublin


    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Fred smith at Dec 4, 2011 at 2:08 pm

    On Sun, Dec 04, 2011 at 10:24:00PM +0800, Ho Chaw Ming wrote:
    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .
    Also, is this one of the "Green" series of WD disks? Those have
    a 4KB sector size, not the old/traditional 512B sector size. This has
    performance ramifications in that you must have partitions begin on
    a sector boundary or performance goes to the dogs. There are a number
    of articles about it on various geek sites, sorry I can't point you
    to one offhand.


    --
    -------------------------------------------------------------------------------
    .---- Fred Smith /
    ( /__ ,__. __ __ / __ : /
    / / / /__) / / /__) .+' Home: fredex at fcshome.stoneham.ma.us
    / / (__ (___ (__(_ (___ / :__ 781-438-5471
    -------------------------------- Jude 1:24,25 ---------------------------------
  • John R Pierce at Dec 4, 2011 at 2:19 pm

    On 12/04/11 11:08 AM, fred smith wrote:
    On Sun, Dec 04, 2011 at 10:24:00PM +0800, Ho Chaw Ming wrote:
    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .
    Also, is this one of the "Green" series of WD disks? Those have
    a 4KB sector size, not the old/traditional 512B sector size. This has
    performance ramifications in that you must have partitions begin on
    a sector boundary or performance goes to the dogs. There are a number
    of articles about it on various geek sites, sorry I can't point you
    to one offhand.
    many newer disks use this same 4k internal sectoring. the drives still
    *look* like they have 512 byte sectors to the outside world, but its
    very important for performance to get your partitions properly aligned
    on a 4k boundary, and ideally your file system uses 4K (or multiple of
    4k) as its block size.

    sadly, the default fake CHS (cylinder head sector) mapping left over
    from legacy PC architectures ends up with a 255 512b sector 'track', and
    MBR partitioning defaults to using track or cylinder boundaries, so the
    first partition starts at an odd location if you use legacy tools like
    fdisk.


    --
    john r pierce N 37, W 122
    santa cruz ca mid-left coast
  • Robert Nichols at Dec 4, 2011 at 3:32 pm

    On 12/04/2011 01:08 PM, fred smith wrote:
    On Sun, Dec 04, 2011 at 10:24:00PM +0800, Ho Chaw Ming wrote:
    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .
    Also, is this one of the "Green" series of WD disks? Those have
    a 4KB sector size, not the old/traditional 512B sector size. This has
    performance ramifications in that you must have partitions begin on
    a sector boundary or performance goes to the dogs. There are a number
    of articles about it on various geek sites, sorry I can't point you
    to one offhand.
    The WDxxEADS drives have 512B sectors, _not_ 4KB sectors.

    --
    Bob Nichols "NOSPAM" is really part of my email address.
    Do NOT delete it.
  • Timothy Murphy at Dec 4, 2011 at 4:25 pm

    Ho Chaw Ming wrote:

    I have a 1.5TB Western Digital hard disk (WD15EADS-00R6B0) on my
    CentOS-5.7 server, which has become incredibly slow for some operations,
    eg rsync, BackupPC archive, e2fsck, although it seems to work fine for
    ordinary file operations, and "smartctl -a /dev/sdb" does not report any
    errors.
    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .
    Thanks for your response, and for the others received.

    But I should have pointed out that the slow operation
    has only started recently, in the last week or so,
    after working normally since I acquired the disk a year or so ago.



    --
    Timothy Murphy
    e-mail: gayleard /at/ eircom.net
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College Dublin
  • Timothy Murphy at Dec 4, 2011 at 7:38 pm

    Timothy Murphy wrote:

    Check your bios, and make sure that you did not have IDE mode enabled and
    AHCI is selected .
    Thanks for your response, and for the others received.

    But I should have pointed out that the slow operation
    has only started recently, in the last week or so,
    after working normally since I acquired the disk a year or so ago.
    To add to the mystery, I just checked with hdparm,
    and the speed of the disk (as measured this way) seems normal,
    compared with various other disks:
    -----------------------------------
    The "slow disk"
    [tim at helen ~]$ sudo hdparm -t /dev/sdb
    /dev/sdb:
    Timing buffered disk reads: 168 MB in 3.00 seconds = 55.98 MB/sec
    -----------------------------------
    Another disk on the same machine
    [tim at blanche ~]$ sudo hdparm -t /dev/sda
    /dev/sda:
    Timing buffered disk reads: 146 MB in 3.01 seconds = 48.57 MB/sec
    -----------------------------------
    An external hard disk attached to the same machine
    [tim at helen ~]$ sudo hdparm -t /dev/sdc

    /dev/sdc:
    Timing buffered disk reads: 54 MB in 3.03 seconds = 17.80 MB/sec
    -----------------------------------

    I have Windows XP on another partition.
    I don't think I've ever used it
    (I always install Windows if it is not already on the machine,
    as I've had a couple of occasions when it has saved my life).
    I'll see how fast (or slow) Windows backup goes.

    --
    Timothy Murphy
    e-mail: gayleard /at/ eircom.net
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College Dublin
  • Alan McKay at Dec 4, 2011 at 8:07 pm
    Those are slowish times even for a 7200rpm disk. My desktop here at
    home (Ubuntu) has a slow 7200 drive and hdparam reports a lot faster
    than that. Well, it is a Caviar "Green" drive which means that 7200
    is the fastest speed but it does spin slower too.

    amckay at amckay-desktop:~$ sudo !!
    sudo hdparm -t /dev/sda
    [sudo] password for amckay:

    /dev/sda:
    Timing buffered disk reads: 244 MB in 3.01 seconds = 81.10 MB/sec
    amckay at amckay-desktop:~$




    --
    ?Don't eat anything you've ever seen advertised on TV?
    ? ? ? ?? - Michael Pollan, author of "In Defense of Food"
  • Alan McKay at Dec 4, 2011 at 9:19 pm
    You have not said anything yet in this thread about defragging that drive.

    I just checked your original message and your drive is the exact same
    as mine except yours is the 1.5 TB version and mine is 1.0.

    --
    ?Don't eat anything you've ever seen advertised on TV?
    ? ? ? ?? - Michael Pollan, author of "In Defense of Food"
  • Alan McKay at Dec 4, 2011 at 9:22 pm
    Also - boot a live Linux CD and then from there do hdparam again and
    compare results, If they differ vastly at least you know it is
    something in your running system which is the culprit. If they are
    roughly the same then it is likely the drive gone bad. Though check
    the man page for hdparam to see if disk fragmentation will affect the
    results it gives.


    --
    ?Don't eat anything you've ever seen advertised on TV?
    ? ? ? ?? - Michael Pollan, author of "In Defense of Food"
  • Yves Bellefeuille at Dec 4, 2011 at 10:43 pm

    On Sunday 04 December 2011 19:38, Timothy Murphy wrote:

    The "slow disk"
    [tim at helen ~]$ sudo hdparm -t /dev/sdb
    /dev/sdb:
    Timing buffered disk reads: 168 MB in 3.00 seconds = 55.98 MB/sec
    -----------------------------------
    Another disk on the same machine
    [tim at blanche ~]$ sudo hdparm -t /dev/sda
    /dev/sda:
    Timing buffered disk reads: 146 MB in 3.01 seconds = 48.57 MB/sec
    Here are my?results with a PATA drive and a SATA drive:

    [root at poontang ~]# hdparm -t /dev/hda

    /dev/hda:
    Timing buffered disk reads: 172 MB in 3.02 seconds = 56.97 MB/sec
    [root at poontang ~]# hdparm -t /dev/sda

    /dev/sda:
    Timing buffered disk reads: 300 MB in 3.01 seconds = 99.66 MB/sec

    Your results are similar to what I get with my PATA drive, so I agree
    with Ho Chaw Ming that you should check that AHCI is selected.

    --
    Yves Bellefeuille <yan at storm.ca>
    "La Esperanta Civito ne rifuzas anticipe la kunlaboron de erarintoj, se
    ili konscias pri sia eraro." -- Heroldo Komunikas, n-ro 473.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedDec 4, '11 at 7:46a
activeDec 4, '11 at 10:43p
posts12
users8
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase