FAQ
It seems as if /etc/inittab has undergone some changes. That doesn't seem
to be related to my issues however. I am able to setup the grub.conf (
menu.lst if you like ) to use the serial console ttyS0 at 9600 baud and
the usual bits.

However I can not actually see the GRUB menu at boot time. I see nothing
until the server begins to boot and then I can see everything. However the
grub menu is absent entirely.

My config looks like so :

# grep -v "^#" /boot/grub/grub.conf
default=0
timeout0
serial --unit=0 --speed�00 --word=8 --parity=no --stop=1
terminal -timeout0 serial console
title CentOS (2.6.32-71.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32-71.el6.x86_64 ro
root=UUID#96ae8a-7eaa-4690-8701-10fb1b604e21 rd_NO_LUKS
rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8
SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
crashkernel=auto rhgb console=tty0 console=ttyS0,9600n8
initrd /initramfs-2.6.32-71.el6.x86_64.img


Everything runs fine, however the GRUB menu is no where to be seen at boot
time. Any ideas ?

Dennis



--
--
http://pgp.mit.edu:11371/pks/lookup?op=vindex&search=0x1D936C72FA35B44B
+-------------------------+-----------------------------------+
Dennis Clarke | Solaris and Linux and Open Source |
dclarke at blastwave.org | Respect for open standards. |
+-------------------------+-----------------------------------+

Search Discussions

  • Tru Huynh at Nov 20, 2011 at 6:20 pm
    On Sun, Nov 20, 2011 at 02:13:13PM -0500, Dennis Clarke wrote:
    >
    ....
    However I can not actually see the GRUB menu at boot time. I see nothing
    until the server begins to boot and then I can see everything. However the
    grub menu is absent entirely.

    My config looks like so : ..
    serial --unit=0 --speed�00 --word=8 --parity=no --stop=1
    terminal -timeout0 serial console
    put these two lines at the beginning and fix the --timeout typo :)

    This config works for me:
    <cut>
    serial --unit=0 --speed8400
    terminal --timeout serial console
    default=0
    timeout=5

    title CentOS Linux (2.6.32-71.29.1.el6.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.32-71.29.1.el6.x86_64 ro root=/dev/mapper/vg_c6-lv_root rd_LVM_LV=vg_c6/lv_root rd_LVM_LV=vg_c6/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us nomodeset crashkernel=auto rhgb quiet console=tty0 console=ttyS0,38400n
    initrd /initramfs-2.6.32-71.29.1.el6.x86_64.img
    </cut>

    Cheers,

    Tru

    --
    Tru Huynh (mirrors, CentOS i386/x86_64 Package Maintenance)
    http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xBEFA581B
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20111121/34816168/attachment.bin
  • Paul Heinlein at Nov 21, 2011 at 12:34 pm

    On Sun, 20 Nov 2011, Dennis Clarke wrote:

    My config looks like so :

    # grep -v "^#" /boot/grub/grub.conf
    default=0
    timeout0
    serial --unit=0 --speed�00 --word=8 --parity=no --stop=1
    terminal -timeout0 serial console
    The "timeout" option needs a double-dash: "--timeout".
    title CentOS (2.6.32-71.el6.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.32-71.el6.x86_64 ro
    root=UUID#96ae8a-7eaa-4690-8701-10fb1b604e21 rd_NO_LUKS
    rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8
    SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
    crashkernel=auto rhgb console=tty0 console=ttyS0,9600n8
    I've always edited out the "rhgb" option when I depend on a serial
    console, but I honestly haven't checked whether it makes any
    difference in CentOS 6.0.

    --
    Paul Heinlein <> heinlein at madboa.com <> http://www.madboa.com/

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedNov 20, '11 at 2:13p
activeNov 21, '11 at 12:34p
posts3
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase