FAQ
On my CentOS 6:
chkconfig --list wpa_supplicant
shows off at all levels, which is confirmed by examination of:
/etc/init.d/wpa_supplicant
but ps -ef shows the process running.
Furthermore, repeated
cd /etc/init.d/
./wpa_supplicant stop
appears to succeed, but the process continues to run.
These observations were made at levels 3 and 5.

Thanks in advance for your explanation.

Mike.

Search Discussions

  • Scott Robbins at Aug 29, 2011 at 7:36 pm

    On Mon, Aug 29, 2011 at 10:35:18PM +0000, Michael D. Berger wrote:
    On my CentOS 6:
    chkconfig --list wpa_supplicant
    shows off at all levels, which is confirmed by examination of:
    /etc/init.d/wpa_supplicant
    but ps -ef shows the process running.
    Furthermore, repeated
    cd /etc/init.d/
    ./wpa_supplicant stop
    appears to succeed, but the process continues to run.
    These observations were made at levels 3 and 5.
    Are you using NetworkManager? It probably starts wpa_supplicant. Have
    you ever noticed, on a Gnome desktop, how you have to specifically
    uncheck enable wireless?



    --
    Scott Robbins
    PGP keyID EB3467D6
    ( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
    gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

    Angel: I'm weak. I've never been anything else. I wanted to lose
    myself in you. I know it will cost me my soul, and part of me
    didn't care. It's not the demon in me that needs killing, Buffy,
    it's the man.
  • Michael D. Berger at Aug 29, 2011 at 8:55 pm

    On Mon, 29 Aug 2011 19:36:13 -0400, Scott Robbins wrote:
    On Mon, Aug 29, 2011 at 10:35:18PM +0000, Michael D. Berger wrote:
    On my CentOS 6:
    chkconfig --list wpa_supplicant
    shows off at all levels, which is confirmed by examination of:
    /etc/init.d/wpa_supplicant
    but ps -ef shows the process running. Furthermore, repeated
    cd /etc/init.d/
    ./wpa_supplicant stop
    appears to succeed, but the process continues to run. These
    observations were made at levels 3 and 5.
    Are you using NetworkManager? It probably starts wpa_supplicant. Have
    you ever noticed, on a Gnome desktop, how you have to specifically
    uncheck enable wireless?
    Yes, I am using NetworkManager, and, as I forgot to mention, KDE.
    But I see that NetworkManager starts at level 2.

    (BTW, I also see that the scripts in /etc/init.d have a new format
    for specifying start and stop levels.)

    Mike.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedAug 29, '11 at 6:35p
activeAug 29, '11 at 8:55p
posts3
users2
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase