FAQ
I have just upgraded my server from CentOS 5 to CentOS 6 and am having
connectivity problems. My laptop runs Fedora 14, and I have been in the habit
of mounting data partitions on my server by fstab entries. Since the update
I've not been able to do that. On watching the messages during a reboot I saw
a statement that the connection was denied by the server (where are those
messages stored so that I can quote accurately?).

I have temporarily disabled both the firewall and selinux, and the problem
persists, so clearly they are not the cause. Logwatch has the following
section which may or may not be connected:

--------------------- Connections (secure-log) Begin ------------------------


Userhelper executed applications:
anne -> system-config-users as root: 1 Time(s)

**Unmatched Entries**
polkitd(authority=local): Operator of unix-
session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as
unix-user:root to gain TEMPORARY authorization for action
org.fedoraproject.config.firewall.auth for system-bus-name::1.88
[/usr/bin/python /usr/bin/system-config-firewall] (owned by unix-user:anne): 1
Time(s)
polkitd(authority=local): Registered Authentication Agent for session
/org/freedesktop/ConsoleKit/Session1 (system bus name :1.24
[/usr/libexec/polkit-gnome-authentication-agent-1], object path
/org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8): 1 Time(s)
polkitd(authority=local): Registered Authentication Agent for session
/org/freedesktop/ConsoleKit/Session2 (system bus name :1.45
[/usr/libexec/polkit-gnome-authentication-agent-1], object path
/org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8): 1 Time(s)
polkitd(authority=local): Unregistered Authentication Agent for session
/org/freedesktop/ConsoleKit/Session1 (system bus name :1.24, object path
/org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected
from bus): 1 Time(s)
polkitd(authority=local): Unregistered Authentication Agent for session
/org/freedesktop/ConsoleKit/Session6 (system bus name :1.214, object path
/org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8) (disconnected
from bus): 1 Time(s)

---------------------- Connections (secure-log) End -------------------------

An example fstab line is

/Data1 /nfs4exports/Data1 none bind 0 0

Under CentOS 5 this was mounted by the exports line:

/nfs4exports/Data1 192.168.0.0/24(rw,insecure,no_subtree_check,nohide)

Following advice, I have changed this to:

/Data1/ 192.168.0.0/255.255.255.0 *(rw,sync,insecure,no_all_squash)

That hasn't helped at all.

I'm completely at a loss, and really need to get this connection working
again. I've done lots of googling and reading, but just feel to be digging an
ever-deeper hole. All help appreciated.

Anne

Search Discussions

  • Tony Schreiner at Aug 19, 2011 at 10:43 am

    On Aug 19, 2011, at 10:39 AM, Anne Wilson wrote:

    I have just upgraded my server from CentOS 5 to CentOS 6 and am having
    connectivity problems. My laptop runs Fedora 14, and I have been in
    the habit
    of mounting data partitions on my server by fstab entries. Since
    the update
    I've not been able to do that. On watching the messages during a
    reboot I saw
    a statement that the connection was denied by the server (where are
    those
    messages stored so that I can quote accurately?).

    I have temporarily disabled both the firewall and selinux, and the
    problem
    persists, so clearly they are not the cause. Logwatch has the
    following
    section which may or may not be connected:

    --------------------- Connections (secure-log) Begin
    ------------------------


    Userhelper executed applications:
    anne -> system-config-users as root: 1 Time(s)

    **Unmatched Entries**
    polkitd(authority=local): Operator of unix-
    session:/org/freedesktop/ConsoleKit/Session2 successfully
    authenticated as
    unix-user:root to gain TEMPORARY authorization for action
    org.fedoraproject.config.firewall.auth for system-bus-name::1.88
    [/usr/bin/python /usr/bin/system-config-firewall] (owned by unix-
    user:anne): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session2 (system bus name :1.45
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8): 1
    Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    (disconnected
    from bus): 1 Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session6 (system bus name :1.214, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8)
    (disconnected
    from bus): 1 Time(s)

    ---------------------- Connections (secure-log) End
    -------------------------

    An example fstab line is

    /Data1 /nfs4exports/Data1 none bind 0 0

    Under CentOS 5 this was mounted by the exports line:

    /nfs4exports/Data1
    192.168.0.0/24(rw,insecure,no_subtree_check,nohide)

    Following advice, I have changed this to:

    /Data1/ 192.168.0.0/255.255.255.0 *(rw,sync,insecure,no_all_squash)

    That hasn't helped at all.

    I'm completely at a loss, and really need to get this connection
    working
    again. I've done lots of googling and reading, but just feel to be
    digging an
    ever-deeper hole. All help appreciated.

    Anne
    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).

    Tony
  • Anne Wilson at Aug 19, 2011 at 12:23 pm

    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:
    On Aug 19, 2011, at 10:39 AM, Anne Wilson wrote:
    I have just upgraded my server from CentOS 5 to CentOS 6 and am having
    connectivity problems. My laptop runs Fedora 14, and I have been in
    the habit
    of mounting data partitions on my server by fstab entries. Since
    the update
    I've not been able to do that. On watching the messages during a
    reboot I saw
    a statement that the connection was denied by the server (where are
    those
    messages stored so that I can quote accurately?).

    I have temporarily disabled both the firewall and selinux, and the
    problem
    persists, so clearly they are not the cause. Logwatch has the
    following
    section which may or may not be connected:

    --------------------- Connections (secure-log) Begin
    ------------------------


    Userhelper executed applications:
    anne -> system-config-users as root: 1 Time(s)

    **Unmatched Entries**
    polkitd(authority=local): Operator of unix-
    session:/org/freedesktop/ConsoleKit/Session2 successfully
    authenticated as
    unix-user:root to gain TEMPORARY authorization for action
    org.fedoraproject.config.firewall.auth for system-bus-name::1.88
    [/usr/bin/python /usr/bin/system-config-firewall] (owned by unix-
    user:anne): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session2 (system bus name :1.45
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8): 1
    Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    (disconnected
    from bus): 1 Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session6 (system bus name :1.214, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8)
    (disconnected
    from bus): 1 Time(s)

    ---------------------- Connections (secure-log) End
    -------------------------

    An example fstab line is

    /Data1 /nfs4exports/Data1 none bind 0 0

    Under CentOS 5 this was mounted by the exports line:

    /nfs4exports/Data1
    192.168.0.0/24(rw,insecure,no_subtree_check,nohide)

    Following advice, I have changed this to:

    /Data1/ 192.168.0.0/255.255.255.0 *(rw,sync,insecure,no_all_squash)

    That hasn't helped at all.

    I'm completely at a loss, and really need to get this connection
    working
    again. I've done lots of googling and reading, but just feel to be
    digging an
    ever-deeper hole. All help appreciated.

    Anne
    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at square 1.
    Two things -

    I should have said that I can access the system from the laptop using ssh +
    keys.

    During bootup I saw many messages about nfs4 exports failing, so that's whre
    the problem is, it seems. Can you please give me a sample line of a known
    good nfs4 export?

    Anne
  • Anne Wilson at Aug 19, 2011 at 12:46 pm

    On Friday 19 Aug 2011 17:23:34 Anne Wilson wrote:
    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:

    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at square
    1. Two things -

    I should have said that I can access the system from the laptop using ssh +
    keys.

    During bootup I saw many messages about nfs4 exports failing, so that's
    whre the problem is, it seems. Can you please give me a sample line of a
    known good nfs4 export?
    It's hard to be sure when messages flash by so quickly, but I got the
    impression that there was something about fstab. Maybe the format required
    for those lines has changed, too? These are the lines that I guess it is
    looking at:

    /Data1 /nfs4exports/Data1 none bind 0 0
    /Data2 /nfs4exports/Data2 none` bind 0 0
    /Data3 /nfs4exports/Data3 none bind 0 0
    /home /nfs4exports/home none bind 0 0

    I think there was something about wrong or missing type. Each of those
    partitions is defined earlier in fstab and does have the correct type stated.

    Anne
  • Craig White at Aug 19, 2011 at 10:41 pm

    On Fri, 2011-08-19 at 17:46 +0100, Anne Wilson wrote:
    On Friday 19 Aug 2011 17:23:34 Anne Wilson wrote:
    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:

    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at square
    1. Two things -

    I should have said that I can access the system from the laptop using ssh +
    keys.

    During bootup I saw many messages about nfs4 exports failing, so that's
    whre the problem is, it seems. Can you please give me a sample line of a
    known good nfs4 export?
    It's hard to be sure when messages flash by so quickly, but I got the
    impression that there was something about fstab. Maybe the format required
    for those lines has changed, too? These are the lines that I guess it is
    looking at:

    /Data1 /nfs4exports/Data1 none bind 0 0
    /Data2 /nfs4exports/Data2 none` bind 0 0
    /Data3 /nfs4exports/Data3 none bind 0 0
    /home /nfs4exports/home none bind 0 0

    I think there was something about wrong or missing type. Each of those
    partitions is defined earlier in fstab and does have the correct type stated.
    ----
    this is obviously intended to be your NFS server (who knows whether this
    is CentOS or Fedora 14). You can only bind mount something that already
    exists and maybe it's empty.

    does ls -l /Data1 /Data2 /Data3 /home show much of anything?

    On the other system (the NFS client), what does it have in fstab?

    Craig


    --
    This message has been scanned for viruses and
    dangerous content by MailScanner, and is
    believed to be clean.
  • Anne Wilson at Aug 20, 2011 at 4:38 am

    On Saturday 20 Aug 2011 03:41:12 Craig White wrote:
    On Fri, 2011-08-19 at 17:46 +0100, Anne Wilson wrote:
    On Friday 19 Aug 2011 17:23:34 Anne Wilson wrote:
    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:
    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at
    square 1. Two things -

    I should have said that I can access the system from the laptop using
    ssh + keys.

    During bootup I saw many messages about nfs4 exports failing, so that's
    whre the problem is, it seems. Can you please give me a sample line
    of a known good nfs4 export?
    It's hard to be sure when messages flash by so quickly, but I got the
    impression that there was something about fstab. Maybe the format
    required for those lines has changed, too? These are the lines that I
    guess it is looking at:

    /Data1 /nfs4exports/Data1 none bind 0 0
    /Data2 /nfs4exports/Data2 none` bind 0 0
    /Data3 /nfs4exports/Data3 none bind 0 0
    /home /nfs4exports/home none bind 0 0

    I think there was something about wrong or missing type. Each of those
    partitions is defined earlier in fstab and does have the correct type
    stated.
    ----
    this is obviously intended to be your NFS server (who knows whether this
    is CentOS or Fedora 14).
    The server is CentOS 6.
    You can only bind mount something that already
    exists and maybe it's empty.

    does ls -l /Data1 /Data2 /Data3 /home show much of anything?
    Yes, it lists the contents of each of them.
    On the other system (the NFS client), what does it have in fstab?
    192.168.0.40:/Data1 /mnt/borg_Data1 nfs4 rsize�92,wsize�92,timeo,intr 0

    and equivalents for each of the others.

    As I said originally, these lines worked with nfs4 on CentOS 5.

    Anne
  • Craig White at Aug 20, 2011 at 7:05 am

    On Sat, 2011-08-20 at 09:38 +0100, Anne Wilson wrote:
    On Saturday 20 Aug 2011 03:41:12 Craig White wrote:
    On Fri, 2011-08-19 at 17:46 +0100, Anne Wilson wrote:
    On Friday 19 Aug 2011 17:23:34 Anne Wilson wrote:
    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:
    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at
    square 1. Two things -

    I should have said that I can access the system from the laptop using
    ssh + keys.

    During bootup I saw many messages about nfs4 exports failing, so that's
    whre the problem is, it seems. Can you please give me a sample line
    of a known good nfs4 export?
    It's hard to be sure when messages flash by so quickly, but I got the
    impression that there was something about fstab. Maybe the format
    required for those lines has changed, too? These are the lines that I
    guess it is looking at:

    /Data1 /nfs4exports/Data1 none bind 0 0
    /Data2 /nfs4exports/Data2 none` bind 0 0
    /Data3 /nfs4exports/Data3 none bind 0 0
    /home /nfs4exports/home none bind 0 0

    I think there was something about wrong or missing type. Each of those
    partitions is defined earlier in fstab and does have the correct type
    stated.
    ----
    this is obviously intended to be your NFS server (who knows whether this
    is CentOS or Fedora 14).
    The server is CentOS 6.
    You can only bind mount something that already
    exists and maybe it's empty.

    does ls -l /Data1 /Data2 /Data3 /home show much of anything?
    Yes, it lists the contents of each of them.
    On the other system (the NFS client), what does it have in fstab?
    192.168.0.40:/Data1 /mnt/borg_Data1 nfs4 rsize�92,wsize�92,timeo,intr 0

    and equivalents for each of the others.

    As I said originally, these lines worked with nfs4 on CentOS 5.
    ----
    then issuing the command (on the Fedora client)

    mount /mnt/borg_Data1
    should either work or fail and give you a message (at worst, log
    to /var/log/messages).

    This of course assumes that it isn't already mounted which could be
    noted by simply issuing a 'mount' command by itself to see what is
    mounted.

    You may have to check /var/log/messages on the CentOS server for clues
    too.

    Craig


    --
    This message has been scanned for viruses and
    dangerous content by MailScanner, and is
    believed to be clean.
  • Anne Wilson at Aug 20, 2011 at 7:40 am

    On Saturday 20 Aug 2011 12:05:51 Craig White wrote:
    On Sat, 2011-08-20 at 09:38 +0100, Anne Wilson wrote:
    On Saturday 20 Aug 2011 03:41:12 Craig White wrote:
    On Fri, 2011-08-19 at 17:46 +0100, Anne Wilson wrote:
    On Friday 19 Aug 2011 17:23:34 Anne Wilson wrote:
    On Friday 19 Aug 2011 15:43:23 Tony Schreiner wrote:
    NFS v4 problems maybe. Try setting a value for Domain in

    /etc/idmapd.conf

    on both systems (the same for both).
    That gave me an unbootable system. I've removed it, and am back at
    square 1. Two things -

    I should have said that I can access the system from the laptop
    using ssh + keys.

    During bootup I saw many messages about nfs4 exports failing, so
    that's

    whre the problem is, it seems. Can you please give me a sample
    line

    of a known good nfs4 export?
    It's hard to be sure when messages flash by so quickly, but I got the
    impression that there was something about fstab. Maybe the format
    required for those lines has changed, too? These are the lines that
    I guess it is looking at:

    /Data1 /nfs4exports/Data1 none bind 0 0
    /Data2 /nfs4exports/Data2 none` bind 0 0
    /Data3 /nfs4exports/Data3 none bind 0 0
    /home /nfs4exports/home none bind 0 0

    I think there was something about wrong or missing type. Each of
    those partitions is defined earlier in fstab and does have the
    correct type stated.
    ----
    this is obviously intended to be your NFS server (who knows whether
    this is CentOS or Fedora 14).
    The server is CentOS 6.
    You can only bind mount something that already
    exists and maybe it's empty.

    does ls -l /Data1 /Data2 /Data3 /home show much of anything?
    Yes, it lists the contents of each of them.
    On the other system (the NFS client), what does it have in fstab?
    192.168.0.40:/Data1 /mnt/borg_Data1 nfs4
    rsize�92,wsize�92,timeo,intr 0



    and equivalents for each of the others.

    As I said originally, these lines worked with nfs4 on CentOS 5.
    ----
    then issuing the command (on the Fedora client)

    mount /mnt/borg_Data1
    should either work or fail and give you a message (at worst, log
    to /var/log/messages).

    This of course assumes that it isn't already mounted which could be
    noted by simply issuing a 'mount' command by itself to see what is
    mounted.

    You may have to check /var/log/messages on the CentOS server for clues
    too.
    Every attempt to mount was simply hanging - so no help at all. However, as
    you will have seen by now, the problem is solved. I was right that I had
    missed some steps, and you were right that the mount points at the server end
    were not correctly set up. The guide on
    http://www.crazysquirrel.com/computing/debian/servers/setting-up-nfs4.jspx has
    got everything working again.

    Thanks for trying to help.

    Anne
    --
    New to KDE Software? - get help from http://userbase.kde.org
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 198 bytes
    Desc: This is a digitally signed message part.
    Url : http://lists.centos.org/pipermail/centos/attachments/20110820/c6607bad/attachment.bin
  • John Hodrien at Aug 20, 2011 at 7:45 am

    On Sat, 20 Aug 2011, Anne Wilson wrote:

    Every attempt to mount was simply hanging - so no help at all. However, as
    you will have seen by now, the problem is solved. I was right that I had
    missed some steps, and you were right that the mount points at the server end
    were not correctly set up. The guide on
    http://www.crazysquirrel.com/computing/debian/servers/setting-up-nfs4.jspx has
    got everything working again.

    Thanks for trying to help.
    I'd also suggest that you'd be better to not have these mounted directly from
    fstab. Make a simple automounter map for these and your life is all round
    less troublesome. You'll not suffer anywhere near as badly when an nfs mount
    is unavailable, and it'll recover gracefully once it's available again.

    jh
  • Anne Wilson at Aug 20, 2011 at 10:30 am

    On Saturday 20 Aug 2011 12:45:17 John Hodrien wrote:
    On Sat, 20 Aug 2011, Anne Wilson wrote:
    Every attempt to mount was simply hanging - so no help at all. However,
    as you will have seen by now, the problem is solved. I was right that I
    had missed some steps, and you were right that the mount points at the
    server end were not correctly set up. The guide on
    http://www.crazysquirrel.com/computing/debian/servers/setting-up-nfs4.jsp
    x has got everything working again.

    Thanks for trying to help.
    I'd also suggest that you'd be better to not have these mounted directly
    from fstab. Make a simple automounter map for these and your life is all
    round less troublesome. You'll not suffer anywhere near as badly when an
    nfs mount is unavailable, and it'll recover gracefully once it's available
    again.
    Hi, John. That sounds really useful, particularly on the netbook where I have
    to remember to disable the mounts before travelling. The only problem is, I
    don't know how to do that. Can you either describe it to me or point me to
    suitable reading? Thanks

    Anne
    --
    New to KDE Software? - get help from http://userbase.kde.org
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 198 bytes
    Desc: This is a digitally signed message part.
    Url : http://lists.centos.org/pipermail/centos/attachments/20110820/44327231/attachment.bin
  • John Hodrien at Aug 20, 2011 at 12:58 pm

    On Sat, 20 Aug 2011, Anne Wilson wrote:

    Hi, John. That sounds really useful, particularly on the netbook where I have
    to remember to disable the mounts before travelling. The only problem is, I
    don't know how to do that. Can you either describe it to me or point me to
    suitable reading? Thanks
    Basically the automounter will just step in and mount things when you try to
    access files within the directory.

    http://www.linux-consulting.com/Amd_AutoFS/autofs.html

    That probably tells you everything you need, but I'll just note the basics.

    Basically you can have:

    /etc/auto.master:

    /remote /etc/auto.remote

    /etc/auto.remote:

    somemount -rw,intr,rsize2768,wsize2768,udp nfsserver:/blah/blah
    someothermount -rw,intr,rsize2768,wsize2768,udp nfsserver:/foo/foo

    chkconfig autofs on
    service autofs start

    Then you should be able to do:

    cd /remote/somemount

    When you do that, autofs will mount the share.

    There's a lot more you can do, you really do need to read the documentation.
    Executable automount maps and ldap based maps really give you a lot of
    flexibility on how you can use it, but you probably need something very
    simple.

    jh
  • Anne Wilson at Aug 20, 2011 at 2:41 pm

    On Saturday 20 Aug 2011 17:58:13 John Hodrien wrote:
    On Sat, 20 Aug 2011, Anne Wilson wrote:
    Hi, John. That sounds really useful, particularly on the netbook where I
    have to remember to disable the mounts before travelling. The only
    problem is, I don't know how to do that. Can you either describe it to
    me or point me to suitable reading? Thanks
    Basically the automounter will just step in and mount things when you try
    to access files within the directory.

    http://www.linux-consulting.com/Amd_AutoFS/autofs.html

    That probably tells you everything you need, but I'll just note the basics.

    Basically you can have:

    /etc/auto.master:

    /remote /etc/auto.remote

    /etc/auto.remote:

    somemount -rw,intr,rsize2768,wsize2768,udp nfsserver:/blah/blah
    someothermount -rw,intr,rsize2768,wsize2768,udp nfsserver:/foo/foo

    chkconfig autofs on
    service autofs start

    Then you should be able to do:

    cd /remote/somemount

    When you do that, autofs will mount the share.

    There's a lot more you can do, you really do need to read the
    documentation. Executable automount maps and ldap based maps really give
    you a lot of flexibility on how you can use it, but you probably need
    something very simple.
    Thanks. Plenty to read, then :-)

    Anne
    --
    New to KDE Software? - get help from http://userbase.kde.org
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 198 bytes
    Desc: This is a digitally signed message part.
    Url : http://lists.centos.org/pipermail/centos/attachments/20110820/2c4973db/attachment.bin
  • Tony Schreiner at Aug 19, 2011 at 2:26 pm

    On Aug 19, 2011, at 10:39 AM, Anne Wilson wrote:

    I have just upgraded my server from CentOS 5 to CentOS 6 and am having
    connectivity problems. My laptop runs Fedora 14, and I have been in
    the habit
    of mounting data partitions on my server by fstab entries. Since
    the update
    I've not been able to do that. On watching the messages during a
    reboot I saw
    a statement that the connection was denied by the server (where are
    those
    messages stored so that I can quote accurately?).

    I have temporarily disabled both the firewall and selinux, and the
    problem
    persists, so clearly they are not the cause. Logwatch has the
    following
    section which may or may not be connected:

    --------------------- Connections (secure-log) Begin
    ------------------------


    Userhelper executed applications:
    anne -> system-config-users as root: 1 Time(s)

    **Unmatched Entries**
    polkitd(authority=local): Operator of unix-
    session:/org/freedesktop/ConsoleKit/Session2 successfully
    authenticated as
    unix-user:root to gain TEMPORARY authorization for action
    org.fedoraproject.config.firewall.auth for system-bus-name::1.88
    [/usr/bin/python /usr/bin/system-config-firewall] (owned by unix-
    user:anne): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8): 1
    Time(s)
    polkitd(authority=local): Registered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session2 (system bus name :1.45
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8): 1
    Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    (disconnected
    from bus): 1 Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for
    session
    /org/freedesktop/ConsoleKit/Session6 (system bus name :1.214, object
    path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8)
    (disconnected
    from bus): 1 Time(s)

    ---------------------- Connections (secure-log) End
    -------------------------

    An example fstab line is

    /Data1 /nfs4exports/Data1 none bind 0 0

    Under CentOS 5 this was mounted by the exports line:

    /nfs4exports/Data1
    192.168.0.0/24(rw,insecure,no_subtree_check,nohide)

    Following advice, I have changed this to:

    /Data1/ 192.168.0.0/255.255.255.0 *(rw,sync,insecure,no_all_squash)

    That hasn't helped at all.

    I'm completely at a loss, and really need to get this connection
    working
    again. I've done lots of googling and reading, but just feel to be
    digging an
    ever-deeper hole. All help appreciated.

    Anne

    I didn't read your original post carefully enough the first time.

    You show the exports file, but nowhere do I see a reference of how the
    client is mounting the export from the server. THe bind mounts above
    are remounting a local file system in a different location, they do
    not mount an NFS share from an external server. Usually it looks
    something like this:

    server:/share /local/mount nfs defaults 0 0

    (obviously defaults can instead be specific options)
  • Anne Wilson at Aug 20, 2011 at 6:35 am

    On Friday 19 Aug 2011 15:39:12 Anne Wilson wrote:
    I have just upgraded my server from CentOS 5 to CentOS 6 and am having
    connectivity problems. My laptop runs Fedora 14, and I have been in the
    habit of mounting data partitions on my server by fstab entries. Since
    the update I've not been able to do that. On watching the messages during
    a reboot I saw a statement that the connection was denied by the server
    (where are those messages stored so that I can quote accurately?).

    I have temporarily disabled both the firewall and selinux, and the problem
    persists, so clearly they are not the cause. Logwatch has the following
    section which may or may not be connected:

    --------------------- Connections (secure-log) Begin
    ------------------------


    Userhelper executed applications:
    anne -> system-config-users as root: 1 Time(s)

    **Unmatched Entries**
    polkitd(authority=local): Operator of unix-
    session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as
    unix-user:root to gain TEMPORARY authorization for action
    org.fedoraproject.config.firewall.auth for system-bus-name::1.88
    [/usr/bin/python /usr/bin/system-config-firewall] (owned by
    unix-user:anne): 1 Time(s)
    polkitd(authority=local): Registered Authentication Agent for session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8): 1 Time(s)
    polkitd(authority=local): Registered Authentication Agent for session
    /org/freedesktop/ConsoleKit/Session2 (system bus name :1.45
    [/usr/libexec/polkit-gnome-authentication-agent-1], object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8): 1 Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for session
    /org/freedesktop/ConsoleKit/Session1 (system bus name :1.24, object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    (disconnected from bus): 1 Time(s)
    polkitd(authority=local): Unregistered Authentication Agent for session
    /org/freedesktop/ConsoleKit/Session6 (system bus name :1.214, object path
    /org/gnome/PolicyKit1/AuthenticationAgent, locale en_GB.utf8) (disconnected
    from bus): 1 Time(s)

    ---------------------- Connections (secure-log) End
    -------------------------

    An example fstab line is

    /Data1 /nfs4exports/Data1 none bind 0 0

    Under CentOS 5 this was mounted by the exports line:

    /nfs4exports/Data1 192.168.0.0/24(rw,insecure,no_subtree_check,nohide)

    Following advice, I have changed this to:

    /Data1/ 192.168.0.0/255.255.255.0 *(rw,sync,insecure,no_all_squash)

    That hasn't helped at all.

    I'm completely at a loss, and really need to get this connection working
    again. I've done lots of googling and reading, but just feel to be digging
    an ever-deeper hole. All help appreciated.
    I was certain I had missed some steps in setting up the exports, but simply
    could not remember them. Nor could I find the guide that got me started
    before. This morning I found it. I cannot recommend this guide too highly -
    so you might like to bookmark it for a reference sheet - for next time someone
    asks you for help :-)

    http://www.crazysquirrel.com/computing/debian/servers/setting-up-nfs4.jspx

    Thanks, everyone, for trying to help.

    Anne
  • James Hogarth at Aug 20, 2011 at 1:31 pm

    I was certain I had missed some steps in setting up the exports, but simply
    could not remember them. ?Nor could I find the guide that got me started
    before. ?This morning I found it. ?I cannot recommend this guide too highly -
    so you might like to bookmark it for a reference sheet - for next time someone
    asks you for help :-)

    http://www.crazysquirrel.com/computing/debian/servers/setting-up-nfs4.jspx

    Thanks, everyone, for trying to help.
    Just one thing to note... RHEL6/CentOS6 no longer requires the bind
    mounts or fsid=0 on the NFS host... the system now defaults to NFS4
    being tried first and does some stuff in the background so that the
    bindings and fsid=0 is not required... in principle (barring nfs4
    specific options) the same exportfs line can be used for nfs3 or
    nfs4.... this is a change from 5.X... I thought it was in the release
    notes, technical notes or migration guide but I can't locate the
    relevant entry now...

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedAug 19, '11 at 10:39a
activeAug 20, '11 at 2:41p
posts15
users5
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase