FAQ
I have an old version of rkhunter installed on my CentOS 5 machine,
one I got from rpmforge.

In my most recent attempts to update this, I get the following errors in yum:

Resolving Dependencies
--> Running transaction check
---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
--> Processing Dependency: perl(JSON::XS) >= 2.2 for package: perl-AnyEvent
--> Processing Dependency: perl(JSON) >= 2.09 for package: perl-AnyEvent
--> Processing Dependency: perl(EV) >= 3.05 for package: perl-AnyEvent
--> Processing Dependency: perl(Guard) >= 1.02 for package: perl-AnyEvent
--> Processing Dependency: perl(Net::SSLeay) >= 1.33 for package: perl-AnyEvent
---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.024-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Zlib.x86_64 0:2.024-1.el5.rf set to be updated
---> Package perl-Error.noarch 0:0.17016-1.el5.rf set to be updated
---> Package perl-Event.x86_64 0:1.13-1.el5.rf set to be updated
---> Package perl-Event-ExecFlow.x86_64 0:0.64-1.el5.rf set to be updated
---> Package perl-IO-AIO.x86_64 0:3.310-1.el5.rf set to be updated
---> Package perl-IO-Compress.noarch 0:2.024-1.el5.rf set to be updated
---> Package perl-common-sense.x86_64 0:3.0-1.el5.rf set to be updated
---> Package rkhunter.noarch 0:1.3.6-1.el5.rf set to be updated
--> Processing Dependency: perl(Digest::SHA256) for package: rkhunter
--> Processing Dependency: perl(Digest::SHA::PurePerl) for package: rkhunter
--> Running transaction check
---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
--> Processing Dependency: perl(Net::SSLeay) >= 1.33 for package: perl-AnyEvent
---> Package perl-Digest-SHA-PurePerl.noarch 0:5.48-1.el5.rf set to be updated
---> Package perl-EV.x86_64 0:3.9-1.el5.rf set to be updated
---> Package perl-Guard.x86_64 0:1.021-1.el5.rf set to be updated
---> Package perl-JSON.noarch 0:2.17-1.el5.rf set to be updated
---> Package perl-JSON-XS.x86_64 0:2.27-1.el5.rf set to be updated
---> Package perl-SHA256.x86_64 0:0.01b-1.2.el5.rf set to be updated
--> Finished Dependency Resolution
perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
--> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

This seems to be because my current perl installation has the following:

perl-Net-SSLeay.x86_64 1.30-4.fc6 installed

IIRC, this is part of the base perl package, which repo has higher
priority than the rpmforge repo (of course), which in turn makes the
rpmforge perl packages invisible.

Questions:

1) Are the newer perl packages from rpmforge compatible with the
installed base perl packages?

2) What other implications should I be looking for if I try this
(other than the obvious caveat about other rpmforge rpms breaking
other base rpms)?

There's a fair amount of perl support in the installed base, I just
want to be sure I'm not likely to break it.

Thanks.

Mark

Search Discussions

  • Steve Huff at Sep 1, 2010 at 10:45 pm

    On Sep 1, 2010, at 9:51 PM, Mark wrote:

    I have an old version of rkhunter installed on my CentOS 5 machine,
    one I got from rpmforge.

    In my most recent attempts to update this, I get the following errors in yum:
    hi Mark! you have a couple of different issues going on here.

    first off, a more appropriate forum for this question is probably the RPMforge users list, <users at lists.rpmforge.net>. let's take the conversation over there, so that we don't spam everyone.

    rkhunter has, as best i can tell, no connection with perl-AnyEvent, which is the package that is triggering your conflict; it looks like you may be trying to updated several packages at once. please try running just

    $ sudo yum update rkhunter

    and let me know (over on the users list) how that works for you.
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
    ...
    --> Finished Dependency Resolution
    perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
    --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
    package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
    Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
    package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
    ...

    This seems to be because my current perl installation has the following:

    perl-Net-SSLeay.x86_64 1.30-4.fc6 installed

    IIRC, this is part of the base perl package, which repo has higher
    priority than the rpmforge repo (of course), which in turn makes the
    rpmforge perl packages invisible.
    not quite; there is indeed a perl-Net-SSLeay package that comes from upstream, but it's a separate package (as your yum output shows), not part of the base perl package (perl-5.8.8-32.el5_5.1 at the time of writing).
    Questions:

    1) Are the newer perl packages from rpmforge compatible with the
    installed base perl packages?
    many packages from RPMforge install cleanly without replacing any upstream packages; some, on the other hand, do require later versions of packages than are available from upstream. i'm not sure quite what you're asking; when you try to install a package that needs to clobber an upstream package, you'll see yum output similar to what you're seeing now, and then you need to decide how badly you want the newer version.
    2) What other implications should I be looking for if I try this
    (other than the obvious caveat about other rpmforge rpms breaking
    other base rpms)?
    there's more discussion of a similar issue over here:

    http://www.mail-archive.com/users at lists.rpmforge.net/msg01291.html

    in brief:

    if you don't want to clobber the upstream perl-Net-SSLeay package, then you don't get to safely install perl-AnyEvent-5.240, and you need to stay on an older version of perl-AnyEvent. on the other hand, if you want the latest perl-AnyEvent, then you need to replace the perl-Net-SSLeay package that you got from upstream.
    There's a fair amount of perl support in the installed base, I just
    want to be sure I'm not likely to break it.

    sounds like it's a good idea to roll out this change on a test system before you deploy it on your production systems, then :)

    -steve

    --
    If this were played upon a stage now, I could condemn it as an improbable fiction. - Fabian, Twelfth Night, III,v
    http://five.sentenc.es/





    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: PGP.sig
    Type: application/pgp-signature
    Size: 195 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20100901/4714d3f9/attachment.bin
  • Tsuyoshi Nagata at Sep 1, 2010 at 11:18 pm
    Hi, Mark
    (2010/09/02 10:51), Mark wrote:
    Error: Missing Dependency: perl(Net::SSLeay)>= 1.33 is needed by
    package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
    Some people solve this problem. He just decided to skip original repository.
    Try this command!
    # yum -y --disablerepo=addons --disablerepo=base --disablerepo=extras --disablerepo=updates install perl-Net-SSLeay

    http://d.hatena.ne.jp/o0cocoron0o/20100815/1281867920

    Tsuyoshi.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedSep 1, '10 at 9:51p
activeSep 1, '10 at 11:18p
posts3
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase