FAQ
I need to open a Nautilus window on a headless server, but no matter
what I try it complains about the display:

?dcl:~$ xhost + localhost
localhost being added to access control list
?dcl:~$ ssh -X user at ip.address
[user at CentOS-55-32-minimal ~]$ export DISPLAY=localhost:0.0
[user at CentOS-55-32-minimal ~]$ nautilus --display=0:0
cannot open display: 0:0
Run 'nautilus --help' to see a full list of available command line options.
[user at CentOS-55-32-minimal ~]$

Googling the situation it looks like I've covered all the steps:
enabling remote X, X forwarding, display export and telling Nautilus
which display to use. Any other ideas? Thanks!

Search Discussions

  • Simon Billis at Aug 6, 2010 at 4:43 am
    Hi Dotan,

    I need to open a Nautilus window on a headless server, but no matter
    what I try it complains about the display:

    ?dcl:~$ xhost + localhost
    localhost being added to access control list
    ?dcl:~$ ssh -X user at ip.address
    [user at CentOS-55-32-minimal ~]$ export DISPLAY=localhost:0.0
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0:0
    cannot open display: 0:0
    Run 'nautilus --help' to see a full list of available command line
    options.
    [user at CentOS-55-32-minimal ~]$

    Googling the situation it looks like I've covered all the steps:
    enabling remote X, X forwarding, display export and telling Nautilus
    which display to use. Any other ideas? Thanks!
    Check that you have X11Forwarding yes in sshd.conf

    Rgds

    Simon
  • Dotan Cohen at Aug 6, 2010 at 4:48 am

    On Fri, Aug 6, 2010 at 11:43, Simon Billis wrote:
    Check that you have X11Forwarding yes in sshd.conf

    Rgds

    Simon
    Thanks, Simon, it appears so:

    [root at CentOS-55-32-minimal ~]# cat /etc/ssh/sshd_config | grep X11Forwarding
    #X11Forwarding no
    X11Forwarding yes

    The SSH server (and the machine itself) had been reset since that
    change has been made, of course.
  • Simon Billis at Aug 6, 2010 at 5:05 am

    On Fri, Aug 6, 2010 at 11:43, Simon Billis wrote:
    Check that you have X11Forwarding yes in sshd.conf

    Rgds

    Simon
    Thanks, Simon, it appears so:

    [root at CentOS-55-32-minimal ~]# cat /etc/ssh/sshd_config | grep
    X11Forwarding
    #X11Forwarding no
    X11Forwarding yes

    The SSH server (and the machine itself) had been reset since that
    change has been made, of course.
    Having reread your OP - try running nautilus without the display setting at
    the end (it's superfluous considering that you have a exported the display
    variable) as you had a typo in the incatation or replace the ":" with a "."

    HTH

    S.
  • Dotan Cohen at Aug 6, 2010 at 5:54 am

    On Fri, Aug 6, 2010 at 12:05, Simon Billis wrote:
    On Fri, Aug 6, 2010 at 11:43, Simon Billis wrote:
    Check that you have X11Forwarding yes in sshd.conf

    Rgds

    Simon
    Thanks, Simon, it appears so:

    [root at CentOS-55-32-minimal ~]# cat /etc/ssh/sshd_config ?| grep
    X11Forwarding
    #X11Forwarding no
    X11Forwarding yes

    The SSH server (and the machine itself) had been reset since that
    change has been made, of course.
    Having reread your OP - try running nautilus without the display setting at
    the end (it's superfluous considering that you have a exported the display
    variable) as you had a typo in the incatation or replace the ":" with a "."

    HTH

    S.
    Still no luck:
    [user at CentOS-55-32-minimal ~]$ nautilus
    cannot open display:
    Run 'nautilus --help' to see a full list of available command line options.
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0.0
    cannot open display: 0.0
    Run 'nautilus --help' to see a full list of available command line options.
    [user at CentOS-55-32-minimal ~]$
  • Simon Billis at Aug 6, 2010 at 5:59 am
    Hi,
    On Fri, Aug 6, 2010 at 12:05, Simon Billis wrote:
    On Fri, Aug 6, 2010 at 11:43, Simon Billis wrote:
    CUT
    Still no luck:
    [user at CentOS-55-32-minimal ~]$ nautilus
    cannot open display:
    Run 'nautilus --help' to see a full list of available command line
    options.
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0.0
    cannot open display: 0.0
    Run 'nautilus --help' to see a full list of available command line
    options.
    [user at CentOS-55-32-minimal ~]$
    Ah yes - Hakan Koseoglu has correctly identified the problem in his recent sorry to have wasted your time :-)

    S.
  • Dotan Cohen at Aug 6, 2010 at 6:04 am

    On Fri, Aug 6, 2010 at 12:59, Simon Billis wrote:
    Ah yes - Hakan Koseoglu has correctly identified the problem in his recent sorry to have wasted your time :-)
    No, I feel that I had wasted yours! But if we both had learned
    something then the time was invested, not wasted. Thanks!
  • Keith Roberts at Aug 6, 2010 at 8:49 am

    On Fri, 6 Aug 2010, Dotan Cohen wrote:

    To: CentOS mailing list <centos at centos.org>
    From: Dotan Cohen <dotancohen at gmail.com>
    Subject: Re: [CentOS] Remote nautilus, X display forwarding problem
    On Fri, Aug 6, 2010 at 12:05, Simon Billis wrote:
    On Fri, Aug 6, 2010 at 11:43, Simon Billis wrote:
    Check that you have X11Forwarding yes in sshd.conf

    Rgds

    Simon
    Thanks, Simon, it appears so:

    [root at CentOS-55-32-minimal ~]# cat /etc/ssh/sshd_config ?| grep
    X11Forwarding
    #X11Forwarding no
    X11Forwarding yes

    The SSH server (and the machine itself) had been reset since that
    change has been made, of course.
    Having reread your OP - try running nautilus without the display setting at
    the end (it's superfluous considering that you have a exported the display
    variable) as you had a typo in the incatation or replace the ":" with a "."

    HTH

    S.
    Still no luck:
    [user at CentOS-55-32-minimal ~]$ nautilus
    cannot open display:
    Run 'nautilus --help' to see a full list of available command line options.
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0.0
    cannot open display: 0.0
    Run 'nautilus --help' to see a full list of available command line options.
    [user at CentOS-55-32-minimal ~]$
    Hi Dotan.

    Give me a temporary login (sent directly via email) as
    user at CentOS-55-32-minimal, and I'll see if I can login and
    run Nautilus from here.

    Are there any other X apps that you can run on the remote
    box that will work over ssh -X ?

    Kind Regards,

    Keith Roberts

    -----------------------------------------------------------------
    Websites:
    http://www.php-debuggers.net
    http://www.karsites.net
    http://www.raised-from-the-dead.org.uk

    All email addresses are challenge-response protected with
    TMDA [http://tmda.net]
    -----------------------------------------------------------------
  • Hakan Koseoglu at Aug 6, 2010 at 5:31 am
    Dotan,

    Do not do these steps:
    On 6 August 2010 09:24, Dotan Cohen wrote:
    [user at CentOS-55-32-minimal ~]$ export DISPLAY=localhost:0.0
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0:0
    cannot open display: 0:0
    When you connect with sssh -X, it will create the tunnel and assign a
    DISPLAY variable.
    hakan at hakan-laptop:10:29:51:~$ ssh -X hobbit
    Last login: Thu Aug 5 09:45:59 2010 from 10.15.1.99
    more cowbells!
    _________________________________________
    / It is impossible to defend perfectly \
    against the attack of those who want to |
    \ die. /
    -----------------------------------------
    \ ^__^
    \ (oo)\_______
    (__)\ )\/\
    ----w |
    [hakan at hobbit ~]$ echo $DISPLAY
    localhost:10.0

    and then you can run Nautilus w/o a problem, with no options necessary.

    --
    Hakan (m1fcj) - http://www.hititgunesi.org
  • Dotan Cohen at Aug 6, 2010 at 5:59 am

    On Fri, Aug 6, 2010 at 12:31, Hakan Koseoglu wrote:
    Dotan,

    Do not do these steps:
    On 6 August 2010 09:24, Dotan Cohen wrote:
    [user at CentOS-55-32-minimal ~]$ export DISPLAY=localhost:0.0
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0:0
    cannot open display: 0:0
    When you connect with sssh -X, it will create the tunnel and assign a
    DISPLAY variable.
    hakan at hakan-laptop:10:29:51:~$ ssh -X hobbit
    Last login: Thu Aug ?5 09:45:59 2010 from 10.15.1.99
    more cowbells!
    ?_________________________________________
    / It is impossible to defend perfectly ? ?\
    against the attack of those who want to |
    \ die. ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?/
    ?-----------------------------------------
    ? ? ? ?\ ? ^__^
    ? ? ? ? \ ?(oo)\_______
    ? ? ? ? ? ?(__)\ ? ? ? )\/\
    ? ? ? ? ? ? ? ?||----w |
    ? ? ? ? ? ? ? ?|| ? ? ||
    [hakan at hobbit ~]$ echo $DISPLAY
    localhost:10.0

    and then you can run Nautilus w/o a problem, with no options necessary.
    For some reason, now I can just SSH -X in and then start Nautilus.
    This was _not_ working earlier, which is why I hit google and found
    the "display" playthings. Maybe I was forgetting the -X (I don't have
    a history to check, arh!). I don't know, but it works now.

    Thanks, sorry for the noise.
  • Keith Roberts at Aug 6, 2010 at 9:31 am

    On Fri, 6 Aug 2010, Dotan Cohen wrote:

    To: CentOS mailing list <centos at centos.org>
    From: Dotan Cohen <dotancohen at gmail.com>
    Subject: Re: [CentOS] Remote nautilus, X display forwarding problem *snipped*
    For some reason, now I can just SSH -X in and then start Nautilus.
    This was _not_ working earlier, which is why I hit google and found
    the "display" playthings. Maybe I was forgetting the -X (I don't have
    a history to check, arh!). I don't know, but it works now.

    Thanks, sorry for the noise.
    If you ran the following from bash:

    ?dcl:~$ xhost + localhost
    localhost being added to access control list
    ?dcl:~$ ssh -X user at ip.address

    There should be a file in your dcl home directory, called
    .bash_history . Each command you type at the bash prompt
    will be saved to that file, including any command line
    options.

    Kind Regards,

    Keith Roberts

    -----------------------------------------------------------------
    Websites:
    http://www.php-debuggers.net
    http://www.karsites.net
    http://www.raised-from-the-dead.org.uk

    All email addresses are challenge-response protected with
    TMDA [http://tmda.net]
    -----------------------------------------------------------------
  • Dotan Cohen at Aug 7, 2010 at 7:44 am

    On Fri, Aug 6, 2010 at 15:49, Keith Roberts wrote:
    Give me a temporary login (sent directly via email) as
    user at CentOS-55-32-minimal, and I'll see if I can login and run Nautilus from
    here.

    Are there any other X apps that you can run on the remote box that will work
    over ssh -X ?
    Thanks, Keith. I cannot reproduce the issue, but if it crops up again
    (ie, if the problem wasn't bkac) then I'll ping you. Thanks.

    If you ran the following from bash:

    ?dcl:~$ xhost + localhost
    localhost being added to access control list
    ?dcl:~$ ssh -X user at ip.address

    There should be a file in your dcl home directory, called .bash_history .
    Each command you type at the bash prompt will be saved to that file,
    including any command line options.
    My local machine has history disabled, due to an unrelated issue.
  • Eero Volotinen at Aug 7, 2010 at 7:56 am

    2010/8/6 Dotan Cohen <dotancohen at gmail.com>:
    I need to open a Nautilus window on a headless server, but no matter
    what I try it complains about the display:

    ?dcl:~$ xhost + localhost
    localhost being added to access control list
    ?dcl:~$ ssh -X user at ip.address
    [user at CentOS-55-32-minimal ~]$ export DISPLAY=localhost:0.0
    [user at CentOS-55-32-minimal ~]$ nautilus --display=0:0
    cannot open display: 0:0
    Run 'nautilus --help' to see a full list of available command line options.
    [user at CentOS-55-32-minimal ~]$

    Googling the situation it looks like I've covered all the steps:
    enabling remote X, X forwarding, display export and telling Nautilus
    which display to use. Any other ideas? Thanks!
    install xorg-x11-xauth on server and then just ssh -X user at ip

    --
    Eero

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedAug 6, '10 at 4:24a
activeAug 7, '10 at 7:56a
posts13
users5
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase