FAQ
I have a need to run a centos server CUT-off from any connected network.
So the NTP server that is running on this very small network cannot
connect to
any other site to do what NTP does.

however, I have devices on this small network that I wish to use the
centos server
as the time source and run ntpd.

However - it seems like ntpd server does not like to run this way.
There is a LONG delay before it finally says OK - no one to talk to so
I'll just give
the time anyway. Then things start working.

Is there some method to SKIP this long delay??? It seems like its 15 or
20 minutes.
I need to bypass that delay or tell ntpd "I dont care about others time"
just provide the time you have.

Thanks,

Jerry

Search Discussions

  • Brunner, Brian T. at Jul 1, 2010 at 10:51 am

    -----Original Message-----
    From: centos-bounces at centos.org
    [mailto:centos-bounces at centos.org] On Behalf Of Jerry Geis
    Sent: Thursday, July 01, 2010 10:28 AM
    To: CentOS ML
    Subject: [CentOS] ntp server

    I have a need to run a centos server CUT-off from any
    connected network.
    So the NTP server that is running on this very small network
    cannot connect to any other site to do what NTP does.

    however, I have devices on this small network that I wish to
    use the centos server as the time source and run ntpd.
    N.B. Windows does not (easily) speak ntp with a *real* ntp client,
    Microsoft has its own way of doing things.
    However - it seems like ntpd server does not like to run this way.
    There is a LONG delay before it finally says OK - no one to
    talk to so I'll just give the time anyway. Then things start working.

    Is there some method to SKIP this long delay??? It seems like
    its 15 or 20 minutes.
    I need to bypass that delay or tell ntpd "I dont care about
    others time"
    just provide the time you have.
    /etc/ntp.conf
    server (IP address of the machine running REAL ntp)
    server 127.127.1.0
    fudge 127.127.1.0 stratum 10

    N.B. stuff that goes in /etc/ntp.conf to keep the clocks secure is
    omitted. This is just the three lines to keep clocks synchronized in a
    perfect world.
    *******************************************************************
    This email and any files transmitted with it are confidential and
    intended solely for the use of the individual or entity to whom
    they are addressed. If you have received this email in error please
    notify the system manager. This footnote also confirms that this
    email message has been swept for the presence of computer viruses.
    www.Hubbell.com - Hubbell Incorporated**
  • Craig White at Jul 1, 2010 at 11:18 am

    On Thu, 2010-07-01 at 10:51 -0400, Brunner, Brian T. wrote:
    -----Original Message-----
    From: centos-bounces at centos.org
    [mailto:centos-bounces at centos.org] On Behalf Of Jerry Geis
    Sent: Thursday, July 01, 2010 10:28 AM
    To: CentOS ML
    Subject: [CentOS] ntp server

    I have a need to run a centos server CUT-off from any
    connected network.
    So the NTP server that is running on this very small network
    cannot connect to any other site to do what NTP does.

    however, I have devices on this small network that I wish to
    use the centos server as the time source and run ntpd.
    N.B. Windows does not (easily) speak ntp with a *real* ntp client,
    Microsoft has its own way of doing things.
    ----
    as an administrator on Windows system...

    net time /setsntp:"hostname_OR_IP_Address"

    Craig


    --
    This message has been scanned for viruses and
    dangerous content by MailScanner, and is
    believed to be clean.
  • Les Mikesell at Jul 1, 2010 at 11:24 am

    On 7/1/2010 9:28 AM, Jerry Geis wrote:
    I have a need to run a centos server CUT-off from any connected network.
    So the NTP server that is running on this very small network cannot
    connect to
    any other site to do what NTP does.

    however, I have devices on this small network that I wish to use the
    centos server
    as the time source and run ntpd.

    However - it seems like ntpd server does not like to run this way.
    There is a LONG delay before it finally says OK - no one to talk to so
    I'll just give
    the time anyway. Then things start working.

    Is there some method to SKIP this long delay??? It seems like its 15 or
    20 minutes.
    I need to bypass that delay or tell ntpd "I dont care about others time"
    just provide the time you have.
    You can get an assortment of devices that receive time signals from
    satellites to act as good authoritative time sources on your private
    network if you are willing to spend some money. If you just want to
    fake it, I think the trick is to lower the stratum number in the 'fudge'
    setting in ntpd.conf.

    --
    Les Mikesell
    lesmikesell at gmail.com
  • Jerry Geis at Jul 1, 2010 at 12:44 pm

    You can get an assortment of devices that receive time signals from
    satellites to act as good authoritative time sources on your private
    network if you are willing to spend some money. If you just want to
    fake it, I think the trick is to lower the stratum number in the 'fudge'
    setting in ntpd.conf.
    Les

    I have tried dropping the stratum to 2,1 and 0 - did notice any effect
    Of course doing service ntpd restart each time.

    Thanks,

    jerry
  • Bowie Bailey at Jul 1, 2010 at 12:51 pm

    Jerry Geis wrote:
    You can get an assortment of devices that receive time signals from
    satellites to act as good authoritative time sources on your private
    network if you are willing to spend some money. If you just want to
    fake it, I think the trick is to lower the stratum number in the 'fudge'
    setting in ntpd.conf.
    Les

    I have tried dropping the stratum to 2,1 and 0 - did notice any effect
    Of course doing service ntpd restart each time.
    Try setting it like this:

    fudge 127.127.1.0 stratum 10
    server 127.127.1.0 prefer

    And make sure that there are no other "server" lines in the config. I
    haven't tried this myself, but if you don't have any other servers
    listed, then it shouldn't waste any time waiting on them.

    --
    Bowie
  • Jerry Geis at Jul 1, 2010 at 4:47 pm

    Try setting it like this:

    fudge 127.127.1.0 stratum 10
    server 127.127.1.0 prefer
    Bowie

    That did not work either.

    jerry
  • Blake Hudson at Jul 7, 2010 at 5:25 pm
    Seems like a well thought out and thorough explanation of how to do what
    you're looking for.

    http://ubuntuforums.org/showthread.php?tW9418

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedJul 1, '10 at 10:28a
activeJul 7, '10 at 5:25p
posts8
users6
websitecentos.org
irc#centos

People

Translate

site design / logo © 2021 Grokbase