FAQ

On Wed, 2009-11-04 at 10:43 +0000, Timothy Murphy wrote:
Adam Nielsen wrote:
When you mount the share, specify a Windows username to connect as
(mount ... -o username=tim)
Thanks for your response.
But sadly, this does not make the slightest difference.
Incidentally, the machine is running Windows XP Pro,
and I am the Administrator.

I can browse in one share, but not the other,
although as far as I can see everything about them is identical,
except that they are on different drives:

-----------------------------------------
[root at helen ~]# mount -t cifs -o user=tim,password=****,rw //harriet/EAGD
/mnt/win
[root at helen ~]# ls /mnt/win
The Sims 2
[root at helen ~]# umount /mnt/win
[root at helen ~]# mount -t cifs -o user=tim,password=****,rw //harriet/EAGC
/mnt/win
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
-----------------------------------------
----
no matter how many lists you ask or how many different ways you want to
keep asking the question, your problem is always Windows permissions are
blocking you. This is not a Linux question. If you don't have
permissions to mount a share or descend into a subdirectory, your
problem lies with Windows permissions.

Your first example demonstrates that it works. Your second example
demonstrates that a permissions issue from the Windows 'server' is
blocking you. There's no guarantee that even if you are the
administrator that you can access a share, folder or file. Windows has a
fairly sophisticated ACL system and you would probably be better served
learning it than asking so many lists the same questions.

Craig


--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Search Discussions

  • Scott Ehrlich at Nov 6, 2009 at 11:45 am

    On Wed, Nov 4, 2009 at 9:50 PM, Craig White wrote:
    On Wed, 2009-11-04 at 10:43 +0000, Timothy Murphy wrote:
    Adam Nielsen wrote:
    When you mount the share, specify a Windows username to connect as
    (mount ... -o username=tim)

    When I mount smb-based systems, I have successfully used:

    mount -t cifs //server/share_point /mnt/local_mount_point -o
    user=your_creds_on_server, domain=name_of_domain_or_workgroup


    Of course, make sure local_mount_point already exists as a directory
    under /mnt, if it doesn't, create it.

    You _might_ be able to drop the domain piece.

    Server above is the destination you want to mount, be it a fully
    DNS-qualified hostname or its IP equivalent.

    The above can work straight for root, or you'd need to precede it with
    sudo if non-root.

    Just remember, if as sudo, the first password is sudo challenging you
    for sudo rights. The second password is the challenge from the remote
    smb-based system (Windows, Samba, etc). Of course, you need a known
    account on the remote system to successfully gain access to it.

    Hope that helps.

    Scott
    Thanks for your response.
    But sadly, this does not make the slightest difference.
    Incidentally, the machine is running Windows XP Pro,
    and I am the Administrator.

    I can browse in one share, but not the other,
    although as far as I can see everything about them is identical,
    except that they are on different drives:

    -----------------------------------------
    [root at helen ~]# mount -t cifs -o user=tim,password=****,rw ?//harriet/EAGD
    /mnt/win
    [root at helen ~]# ls /mnt/win
    The Sims 2
    [root at helen ~]# umount /mnt/win
    [root at helen ~]# mount -t cifs -o user=tim,password=****,rw ?//harriet/EAGC
    /mnt/win
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    -----------------------------------------
    ----
    no matter how many lists you ask or how many different ways you want to
    keep asking the question, your problem is always Windows permissions are
    blocking you. This is not a Linux question. If you don't have
    permissions to mount a share or descend into a subdirectory, your
    problem lies with Windows permissions.

    Your first example demonstrates that it works. Your second example
    demonstrates that a permissions issue from the Windows 'server' is
    blocking you. There's no guarantee that even if you are the
    administrator that you can access a share, folder or file. Windows has a
    fairly sophisticated ACL system and you would probably be better served
    learning it than asking so many lists the same questions.

    Craig


    --
    This message has been scanned for viruses and
    dangerous content by MailScanner, and is
    believed to be clean.

    _______________________________________________
    CentOS mailing list
    CentOS at centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Timothy Murphy at Nov 6, 2009 at 5:30 pm

    Craig White wrote:

    no matter how many lists you ask or how many different ways you want to
    keep asking the question, your problem is always Windows permissions are
    blocking you. This is not a Linux question. If you don't have
    permissions to mount a share or descend into a subdirectory, your
    problem lies with Windows permissions.
    Well, I didn't know originally if it was a Linux or Windows problem.
    I have now come to the same conclusion as you, that it is a Windows problem.

    The reason I suspected Linux was that BackupPC used to work perfectly
    backing up this Windows XP machine, but then ceased to,
    although I did not remember making any big change on the Windows machine
    (which I don't actually use), whereas of course
    I have made a billion updates on the CentOS machine.

    But I think I may be mistaken; I suspect that it stopped working
    when I installed SP3 (which I had forgotten about).

    Anyway BackupPC is now working fine again on the Windows machine.

    As to your suggestion that I asked the question on too many lists,
    there were only 3: this list (as my samba server is running under CentOS),
    the Fedora list because I have found that one is more likely
    to get helpful responses there than anywhere else,
    and the samba list because it was a Samba problem.
    There's no guarantee that even if you are the
    administrator that you can access a share, folder or file. Windows has a
    fairly sophisticated ACL system and you would probably be better served
    learning it than asking so many lists the same questions.
    Well, I did actually get the vital information after asking the question
    several times - File and Folder ownership was not showing up.
    The solution was:
    ----------------------------------------------
    IF you don't see a Security tab, go to Start->My Computer, then click
    Tools->Folder Options in the top of the resultant dialog box. Click the
    "View" tab, scroll to the bottom of the "Advanced Settings", and turn
    off "Use simple file sharing".
    ----------------------------------------------

    I did actually google briefly for "NTFS Permissions" but decided
    life was too short to get into what seemed an absurdly complicated issue.

    --
    Timothy Murphy
    e-mail: gayleard /at/ eircom.net
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedNov 5, '09 at 1:50a
activeNov 6, '09 at 5:30p
posts3
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase