FAQ
I have the following gnome terminal profile settings:

Backspace = ASCII DEL
Delete Key = Escape Sequence

If the logged in session in the terminal window is my own user id
then the delete key does nothing. If however, I su -l in the same
terminal window then the delete key removes the character under the
cursor and left shifts the rest of the line.

I am fairly confident that the delete key worked in the same fashion
for my usual user id up until quite recently. Does anyone know of
why or how this behaviour could differ between two separate users in
the same terminal window?


--
*** E-Mail is NOT a SECURE channel ***
James B. Byrne mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited http://www.harte-lyne.ca
9 Brockley Drive vox: +1 905 561 1241
Hamilton, Ontario fax: +1 905 561 0757
Canada L8E 3C3

Search Discussions

  • Beartooth at May 22, 2009 at 4:58 pm

    On Fri, 22 May 2009 12:49:43 -0400, James B. Byrne wrote:

    I have the following gnome terminal profile settings:

    Backspace = ASCII DEL
    Delete Key = Escape Sequence [....]
    I am fairly confident that the delete key worked in the same fashion for
    my usual user id up until quite recently. Does anyone know of why or
    how this behaviour could differ between two separate users in the same
    terminal window?
    I have my gnome-terminal (under Fedora, not CentOS) set to
    Control-H and Escape Sequence; that works fine for all users here, and
    does what I'm guessing you want.

    --
    Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
    Remember I know precious little of what I am talking about.
  • Filipe Brandenburger at May 24, 2009 at 4:36 am
    Hi,
    On Fri, May 22, 2009 at 12:49, James B. Byrne wrote:
    If the logged in session in the terminal window is my own user id
    then the delete key does nothing. ?If however, I su -l in the same
    terminal window then the delete key removes the character under the
    cursor and left shifts the rest of the line.

    I am fairly confident that the delete key worked in the same fashion
    for my usual user id up until quite recently. ?Does anyone know of
    why or how this behaviour could differ between two separate users in
    the same terminal window?
    I believe it is probably something to do with the profile settings of your user.

    Does .bash_profile contain these lines?

    if [ -f ~/.bashrc ]; then
    . ~/.bashrc

    Does .bashrc contain these lines?

    if [ -f /etc/bashrc ]; then
    . /etc/bashrc

    Are you using the stty command on any of those files?

    Are you resetting the value of the TERM variable?

    What are the output of "stty" and "echo $TERM" when you run them from
    a shell inside your gnome-terminal?

    For reference, these are mine:

    $ stty
    speed 38400 baud; line = 0;
    eol = M-^?; eol2 = M-^?; swtch = M-^?;
    ixany iutf8
    $ echo $TERM
    xterm

    You can also compare the output of these commands when you run as root
    after doing "su -".

    If you create a new user account and log in as the new user in GNOME,
    open a new gnome-terminal, do the keys work as you expect them to?

    HTH,
    Filipe
  • James B. Byrne at May 25, 2009 at 2:55 pm

    On: Fri, 22 May 2009 16:58:26 +0000 (UTC), Beartooth wrote:
    On Fri, 22 May 2009 12:49:43 -0400, James B. Byrne wrote:

    I have the following gnome terminal profile settings:

    Backspace = ASCII DEL
    Delete Key = Escape Sequence [....]
    I am fairly confident that the delete key worked in the same
    fashion for my usual user id up until quite recently. Does
    anyone know of why or how this behaviour could differ between
    two separate users in the same terminal window?
    I have my gnome-terminal (under Fedora, not CentOS) set to
    Control-H and Escape Sequence; that works fine for all users here,
    and does what I'm guessing you want.
    That setting does not change the observed behaviour. If I su -l
    then the Escape Sequence DEL removes the character under the cursor
    and left shifts the line. If I am not the superuser, even in
    exactly the same gnome terminal window instance, then the DEL has no
    evident effect.

    --
    *** E-Mail is NOT a SECURE channel ***
    James B. Byrne mailto:ByrneJB at Harte-Lyne.ca
    Harte & Lyne Limited http://www.harte-lyne.ca
    9 Brockley Drive vox: +1 905 561 1241
    Hamilton, Ontario fax: +1 905 561 0757
    Canada L8E 3C3

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedMay 22, '09 at 4:49p
activeMay 25, '09 at 2:55p
posts4
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase