FAQ
Hi!

I finally tried enabling the desktop effects yesterday. I'm using an old
Nvidia card (GeForce 4 MX440) with, of course, Nvidia's drivers. this is
on a fully updated Centos 5 system.

Enabling from the gnome menu doesn't exactly work compltely, one needs to
google around a bit to find out the remaining magic incantations to make
it fully work. So, I've done that and it's working.

Issues:
1. I notice that the text in the bar at the top of each window appears to be
a different font, and it is outlined in black. Is there any way to tweak
that setting?
2. If I have a window that is slid partially off the edge of an individual
desktop it now oveerlaps the edge of the one "next" to it, when it never
did before. Not sure if I like that or not, is there any way to change
that behavior should I decide I don't like it?
3. I have (and always have had) the panel settings set to "autohide". I
now notice that it sometimes does not hide itself until I explicitly
click in an empty part of the panel, then somewhere else on the desktop.
Anyone know if there's a way to resovle this?

Question:
Should I decide I want to revert to the way it was before I enabled these
effects, how would I go about that? there is no "disable" button on the
gnome menu, only the "enable" button. I know how to un-do the changes I
made manually in the xorg.conf file, but no idea how to undo whatever it
is that the "enable desktop effects" button does. Clues would be appreciated.

Thanks in advance!

--
---- Fred Smith -- fredex@fcshome.stoneham.ma.us -----------------------------
"For him who is able to keep you from falling and to present you before his
glorious presence without fault and with great joy--to the only God our Savior
be glory, majesty, power and authority, through Jesus Christ our Lord, before
all ages, now and forevermore! Amen."
----------------------------- Jude 1:24,25 (niv) -----------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20080615/ef05a5eb/attachment.bin

Search Discussions

  • Dag Wieers at Jun 16, 2008 at 4:43 pm

    On Sun, 15 Jun 2008, fred smith wrote:

    I finally tried enabling the desktop effects yesterday. I'm using an old
    Nvidia card (GeForce 4 MX440) with, of course, Nvidia's drivers. this is
    on a fully updated Centos 5 system.

    Enabling from the gnome menu doesn't exactly work compltely, one needs to
    google around a bit to find out the remaining magic incantations to make
    it fully work. So, I've done that and it's working.

    Issues:
    1. I notice that the text in the bar at the top of each window appears to be
    a different font, and it is outlined in black. Is there any way to tweak
    that setting?
    2. If I have a window that is slid partially off the edge of an individual
    desktop it now oveerlaps the edge of the one "next" to it, when it never
    did before. Not sure if I like that or not, is there any way to change
    that behavior should I decide I don't like it?
    3. I have (and always have had) the panel settings set to "autohide". I
    now notice that it sometimes does not hide itself until I explicitly
    click in an empty part of the panel, then somewhere else on the desktop.
    Anyone know if there's a way to resovle this?

    Question:
    Should I decide I want to revert to the way it was before I enabled these
    effects, how would I go about that? there is no "disable" button on the
    gnome menu, only the "enable" button. I know how to un-do the changes I
    made manually in the xorg.conf file, but no idea how to undo whatever it
    is that the "enable desktop effects" button does. Clues would be appreciated.
    Not sure if this is helpful to you, but here is my experience:

    I have an older/cheaper onboard nvidia in my mediacenter. It was hooked up
    to a 1920x1200 TFT screen. compiz was terribly slow and play video's did
    not work with some error message.

    I tried both the nvidia drivers as well as the Open Source nv driver and
    was disappointed, blamed the old/cheap nvidia and the high resolution as
    the cause for not being able to use compiz.

    Initially I also had problems with display-errors that were attributed to
    a very simple fix described here:

    http://wiki.centos.org/TipsAndTricks/Compiz

    I finally found that by increasing the video memory size in the BIOS from
    32MB to 128MB (system was upgraded from 512MB to 1536MB) compiz worked
    very fast and the video-overlay/XV problems were gone.

    My advice would be:

    - Use the nvidia driver (we have dkms-enabled packages in RPMforge)
    - Look at the tips in the wiki for compiz
    - Increase the Video memory size in the BIOS to at least 128MB

    And let me add that last point to the wiki, so people can find it there.
    --
    -- dag wieers, dag@centos.org, http://dag.wieers.com/ --
    [Any errors in spelling, tact or fact are transmission errors]
  • Fred smith at Jun 16, 2008 at 10:33 pm

    On Mon, Jun 16, 2008 at 06:43:49PM +0200, Dag Wieers wrote:
    On Sun, 15 Jun 2008, fred smith wrote:

    I finally tried enabling the desktop effects yesterday. I'm using an old
    Nvidia card (GeForce 4 MX440) with, of course, Nvidia's drivers. this is
    on a fully updated Centos 5 system.

    Enabling from the gnome menu doesn't exactly work compltely, one needs to
    google around a bit to find out the remaining magic incantations to make
    it fully work. So, I've done that and it's working.

    Issues:
    1. I notice that the text in the bar at the top of each window appears to
    be
    a different font, and it is outlined in black. Is there any way to tweak
    that setting?
    2. If I have a window that is slid partially off the edge of an individual
    desktop it now oveerlaps the edge of the one "next" to it, when it never
    did before. Not sure if I like that or not, is there any way to change
    that behavior should I decide I don't like it?
    3. I have (and always have had) the panel settings set to "autohide". I
    now notice that it sometimes does not hide itself until I explicitly
    click in an empty part of the panel, then somewhere else on the desktop.
    Anyone know if there's a way to resovle this?

    Question:
    Should I decide I want to revert to the way it was before I enabled these
    effects, how would I go about that? there is no "disable" button on the
    gnome menu, only the "enable" button. I know how to un-do the changes I
    made manually in the xorg.conf file, but no idea how to undo whatever it
    is that the "enable desktop effects" button does. Clues would be
    appreciated.
    Dag, thanks for the reply!
    Not sure if this is helpful to you, but here is my experience:

    I have an older/cheaper onboard nvidia in my mediacenter. It was hooked up
    to a 1920x1200 TFT screen. compiz was terribly slow and play video's did
    not work with some error message.

    I tried both the nvidia drivers as well as the Open Source nv driver and
    was disappointed, blamed the old/cheap nvidia and the high resolution as
    the cause for not being able to use compiz.

    Initially I also had problems with display-errors that were attributed to
    a very simple fix described here:

    http://wiki.centos.org/TipsAndTricks/Compiz

    I finally found that by increasing the video memory size in the BIOS from
    32MB to 128MB (system was upgraded from 512MB to 1536MB) compiz worked
    very fast and the video-overlay/XV problems were gone.

    My advice would be:

    - Use the nvidia driver (we have dkms-enabled packages in RPMforge)
    I'm using a driver I got directly from Nvidia. Are you saying that some
    of the re-packaged nvidia drivers are better (in other ways than that
    they make use of the distro's packaging, I mean)?
    - Look at the tips in the wiki for compiz
    I think I already did but I'll go check again in case I missed something.
    I assume you mean the Centos wiki...
    - Increase the Video memory size in the BIOS to at least 128MB
    Sorry, no can do. It's a dedicated card with 64MB. I'm thinking of
    picking up something less obsolete, though. I probably ought to do it
    soon, as it looks like AGP cards are now being relegated to the low-end
    and it's probably getting worse as time moves on. My display is "only"
    1280x1024, so that 64 megs may not be too terrible a limitation.

    performance isn't a big issue (except for resizing windows which sometimes
    is fairly painful--I read somewhere else (possibly on compiz' own site)
    that this is due to something other than compiz but right now I don't
    remember the details.) I can rotate the cube quickly and easily, and
    the jello windows jiggle nicely, assuming one likes jiggly windows.
    And let me add that last point to the wiki, so people can find it there.
    --
    -- dag wieers, dag@centos.org, http://dag.wieers.com/ --
    [Any errors in spelling, tact or fact are transmission errors]
    --
    ---- Fred Smith -- fredex@fcshome.stoneham.ma.us -----------------------------
    "For the word of God is living and active. Sharper than any double-edged
    sword, it penetrates even to dividing soul and spirit, joints and marrow;
    it judges the thoughts and attitudes of the heart."
    ---------------------------- Hebrews 4:12 (niv) ------------------------------
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20080616/bc38d140/attachment.bin
  • Alfred von Campe at Jun 17, 2008 at 12:40 am

    On Jun 15, 2008, at 12:39, fred smith wrote:

    Enabling from the gnome menu doesn't exactly work compltely, one
    needs to
    google around a bit to find out the remaining magic incantations to
    make
    it fully work. So, I've done that and it's working.
    Can you enlighten the rest of us? That is, post the instruction on
    how to do this either on the wiki or on this list? It's been on my
    list of things to try, but things have been to busy lately to devote
    some time to this...

    Thanks,
    Alfred
  • Fred smith at Jun 17, 2008 at 12:51 am

    On Mon, Jun 16, 2008 at 08:40:11PM -0400, Alfred von Campe wrote:
    On Jun 15, 2008, at 12:39, fred smith wrote:

    Enabling from the gnome menu doesn't exactly work compltely, one
    needs to
    google around a bit to find out the remaining magic incantations to
    make
    it fully work. So, I've done that and it's working.
    Can you enlighten the rest of us? That is, post the instruction on
    how to do this either on the wiki or on this list? It's been on my
    list of things to try, but things have been to busy lately to devote
    some time to this...
    Actually, I found it right on the Centos wiki:

    http://wiki.centos.org/TipsAndTricks/Compiz?highlight=(compiz)

    what I haven't yet figured out is how to turn it all OFF should
    I decide to revert.

    Oh, and one other small issue: Now when I grab the edge of a window
    and drag to resize it, it no longer gives me the little popup that
    shows the size of the window (i.e., an xterm or similar).
    I assume it's a function of the window decorator, but have no clue
    how one accesses/modifies it.


    --
    ---- Fred Smith -- fredex@fcshome.stoneham.ma.us -----------------------------
    The Lord is like a strong tower.
    Those who do what is right can run to him for safety.
    --------------------------- Proverbs 18:10 (niv) -----------------------------
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20080616/83420b68/attachment.bin
  • Dag Wieers at Jun 20, 2008 at 1:52 am

    On Mon, 16 Jun 2008, fred smith wrote:

    Oh, and one other small issue: Now when I grab the edge of a window
    and drag to resize it, it no longer gives me the little popup that
    shows the size of the window (i.e., an xterm or similar).
    I assume it's a function of the window decorator, but have no clue
    how one accesses/modifies it.
    Yes, when you use the Desktop Effects you are basicly swapping the normal
    window manager called metacity, but a 3D window manager called compiz.

    compiz apparently does not have that feature (showing the dimensions of a
    window). I guess you have to choose...

    --
    -- dag wieers, dag@centos.org, http://dag.wieers.com/ --
    [Any errors in spelling, tact or fact are transmission errors]

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedJun 15, '08 at 4:39p
activeJun 20, '08 at 1:52a
posts6
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase