FAQ
Hi,

I was doing updates on a server and I think that the network connection
got reset. So I guess the yum update didn't complete and I now get this
when I run 'yum update':

=======================
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package system-config-printer-gui.i386 0:0.6.116.10-1.2 set to be
updated
---> Package system-config-packages.noarch 0:1.2.23-2 set to be updated
---> Package cvs.i386 0:1.11.17-9.RHEL4 set to be updated
---> Package kernel-hugemem-devel.i686 0:2.6.9-67.0.4.EL set to be updated
---> Package kudzu.i386 0:1.1.95.23-1 set to be updated
---> Package glibc-kernheaders.i386 0:2.4-9.1.100.EL set to be updated
---> Package procps.i386 0:3.2.3-8.9 set to be updated
---> Package postgresql-contrib.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package gnome-keyring.i386 0:0.4.0-1.2.EL4 set to be updated
---> Package tcpdump.i386 14:3.8.2-12.el4_6.1 set to be updated
---> Package at.i386 0:3.1.8-80_EL4 set to be updated
---> Package system-config-date.noarch 0:1.7.15-0.RHEL4.3 set to be updated
---> Package cyrus-sasl.i386 0:2.1.19-14 set to be updated
---> Package postgresql-libs.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package foomatic.i386 0:3.0.2-3.1 set to be updated
---> Package kdelibs.i386 6:3.3.1-9.el4 set to be updated
---> Package nss_ldap.i386 0:226-20 set to be updated
---> Package cups.i386 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package dbus-glib.i386 0:0.22-12.EL.9 set to be updated
---> Package nfs-utils.i386 0:1.0.6-84.EL4 set to be updated
---> Package gd-devel.i386 0:2.0.28-5.4E set to be updated
---> Package kernel.i686 0:2.6.9-67.0.4.EL set to be installed
---> Package dbus-python.i386 0:0.22-12.EL.9 set to be updated
---> Package postgresql-server.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package samba-common.i386 0:3.0.25b-1.el4_6.4 set to be updated
---> Package system-config-lvm.noarch 0:1.0.23-1.0 set to be updated
---> Package authconfig-gtk.i386 0:4.6.10-rhel4.3 set to be updated
---> Package xorg-x11-xauth.i386 0:6.8.2-1.EL.33.0.2 set to be updated
---> Package bind.i386 20:9.2.4-28.el4 set to be updated
---> Package pciutils.i386 0:2.1.99.test8-3.4 set to be updated
---> Package nscd.i386 0:2.3.4-2.39 set to be updated
---> Package gnupg.i386 0:1.2.6-9 set to be updated
---> Package openssh-clients.i386 0:3.9p1-8.RHEL4.24 set to be updated
---> Package gcc-java.i386 0:3.4.6-9 set to be updated
---> Package curl-devel.i386 0:7.12.1-11.el4 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.19-14 set to be updated
---> Package gnome-vfs2.i386 0:2.8.2-8.6.EL4 set to be updated
---> Package mc.i386 1:4.6.1-0.8.5 set to be updated
---> Package squid.i386 7:2.5.STABLE14-1.4E.el4_6.1 set to be updated
---> Package authconfig.i386 0:4.6.10-rhel4.3 set to be updated
---> Package yum-utils.noarch 0:0.5-2.el4.centos set to be updated
---> Package bind-libs.i386 20:9.2.4-28.el4 set to be updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package crypto-utils.i386 0:2.1-4.2 set to be updated
---> Package libwnck.i386 0:2.8.1-7.el4 set to be updated
---> Package qt.i386 1:3.3.3-13.RHEL4 set to be updated
---> Package logwatch.noarch 0:5.2.2-2.EL4 set to be updated
---> Package NetworkManager.i386 0:0.3.1-4.el4 set to be updated
---> Package postgresql-pl.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package pam_krb5.i386 0:2.1.17-1 set to be updated
---> Package pam_ccreds.i386 0:3-3.rhel4.2 set to be updated
---> Package bluez-utils.i386 0:2.10-2.2 set to be updated
---> Package ntp.i386 0:4.2.0.a.20040617-6.el4 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.19-14 set to be updated
---> Package dhcpv6_client.i386 0:0.10-17_EL4 set to be updated
---> Package openssl-devel.i586 0:0.9.7a-43.17.el4_6.1 set to be updated
---> Package libxml2-devel.i386 0:2.6.16-10.1 set to be updated
---> Package mdadm.i386 0:1.12.0-5 set to be updated
---> Package mkinitrd.i386 0:4.2.1.13-1 set to be updated
---> Package emacs.i386 0:21.3-19.EL.4 set to be updated
---> Package bind-utils.i386 20:9.2.4-28.el4 set to be updated
---> Package python-urlgrabber.noarch 0:2.9.8-2 set to be updated
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.33.0.2 set to be updated
---> Package system-config-samba.noarch 0:1.2.21-1.el4.1 set to be updated
---> Package initscripts.i386 0:7.93.31.EL-2.centos4 set to be updated
---> Package krb5-workstation.i386 0:1.3.4-54 set to be updated
---> Package xorg-x11-font-utils.i386 0:6.8.2-1.EL.33.0.2 set to be updated
---> Package libxml2-python.i386 0:2.6.16-10.1 set to be updated
---> Package glibc-devel.i386 0:2.3.4-2.39 set to be updated
---> Package postgresql-tcl.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package curl.i386 0:7.12.1-11.el4 set to be updated
---> Package libgcj.i386 0:3.4.6-9 set to be updated
---> Package hal.i386 0:0.4.2-7.EL4 set to be updated
---> Package gd.i386 0:2.0.28-5.4E set to be updated
---> Package system-config-network-tui.noarch 0:1.3.22.0.EL.4.4-1 set to
be updated
---> Package lm_sensors.i386 0:2.8.7-2.40.5 set to be updated
---> Package pdksh.i386 0:5.2.14-30.6 set to be updated
---> Package system-config-printer.i386 0:0.6.116.10-1.2 set to be updated
---> Package netdump.i386 0:0.7.16-14 set to be updated
---> Package rhnlib.noarch 0:2.1.1-3.el4 set to be updated
---> Package SysVinit.i386 0:2.85-34.4 set to be updated
---> Package quota.i386 1:3.12-6.el4 set to be updated
---> Package policycoreutils.i386 0:1.18.1-4.13 set to be updated
---> Package usermode-gtk.i386 0:1.74-2 set to be updated
---> Package system-config-network.noarch 0:1.3.22.0.EL.4.4-1 set to be
updated
---> Package openldap.i386 0:2.2.13-8.el4_6.2 set to be updated
---> Package vixie-cron.i386 4:4.1-49.EL4 set to be updated
---> Package rpm.i386 0:4.3.3-23_nonptl set to be updated
---> Package dhclient.i386 7:3.0.1-59.EL4 set to be updated
---> Package dovecot.i386 0:0.99.11-8.EL4 set to be updated
---> Package setools.i386 0:2.3-4 set to be updated
---> Package libpcap.i386 14:0.8.3-12.el4_6.1 set to be updated
---> Package glibc-headers.i386 0:2.3.4-2.39 set to be updated
---> Package slocate.i386 0:2.7-13.el4.8 set to be updated
---> Package tcsh.i386 0:6.13-9.el4.1 set to be updated
---> Package kernel-smp-devel.i686 0:2.6.9-67.0.4.EL set to be updated
---> Package system-config-users.noarch 0:1.2.27-0.EL4.5 set to be updated
---> Package postgresql-python.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package fetchmail.i386 0:6.2.5-6.0.1.el4 set to be updated
---> Package postgresql.i386 0:7.4.19-1.el4_6.1 set to be updated
---> Package xorg-x11-xfs.i386 0:6.8.2-1.EL.33.0.2 set to be updated
---> Package kbd.i386 0:1.12-2.el4.5 set to be updated
---> Package autofs.i386 1:4.1.3-231 set to be updated
---> Package net-snmp.i386 0:5.1.2-11.el4_6.11.2 set to be updated
---> Package sendmail.i386 0:8.13.1-3.2.el4 set to be updated
---> Package up2date.i386 0:4.6.2-7.el4_6.1 set to be updated
---> Package kernel-devel.i686 0:2.6.9-67.0.4.EL set to be installed
---> Package python-devel.i386 0:2.3.4-14.4.el4_6.1 set to be updated
---> Package mod_ssl.i386 1:2.0.52-38.ent.centos4.2 set to be updated
---> Package ipsec-tools.i386 0:0.3.3-6.rhel4.1 set to be updated
---> Package elinks.i386 0:0.9.2-3.3.5.2 set to be updated
---> Package lockdev.i386 0:1.0.1-6.2 set to be updated
---> Package wireshark.i386 0:0.99.7-1 set to be updated
---> Package vsftpd.i386 0:2.0.1-5.EL4.7 set to be updated
---> Package openssh.i386 0:3.9p1-8.RHEL4.24 set to be updated
---> Package mutt.i386 5:1.4.1-12.0.3.el4 set to be updated
---> Package rp-pppoe.i386 0:3.5-22.2.RHEL4.1 set to be updated
---> Package createrepo.noarch 0:0.4.4-2 set to be updated
---> Package selinux-policy-targeted.noarch 0:1.17.30-2.149 set to be
updated
---> Package system-config-language.noarch 0:1.1.8-4 set to be updated
---> Package samba.i386 0:3.0.25b-1.el4_6.4 set to be updated
---> Package krb5-devel.i386 0:1.3.4-54 set to be updated
---> Package python-elementtree.i386 0:1.2.6-5.el4.centos set to be updated
---> Package rpm-python.i386 0:4.3.3-23_nonptl set to be updated
---> Package yum.noarch 0:2.4.3-4.el4.centos set to be updated
---> Package cyrus-sasl-devel.i386 0:2.1.19-14 set to be updated
---> Package openldap-devel.i386 0:2.2.13-8.el4_6.2 set to be updated
---> Package kernel-utils.i386 1:2.4-13.1.105 set to be updated
---> Package gcc.i386 0:3.4.6-9 set to be updated
---> Package openssh-server.i386 0:3.9p1-8.RHEL4.24 set to be updated
---> Package kernel-smp.i686 0:2.6.9-67.0.4.EL set to be installed
---> Package httpd.i386 0:2.0.52-38.ent.centos4.2 set to be updated
---> Package module-init-tools.i386 0:3.1-0.pre5.3.4.el4_6.1 set to be
updated
---> Package samba-client.i386 0:3.0.25b-1.el4_6.4 set to be updated
---> Package GConf2.i386 0:2.8.1-1.el4 set to be updated
---> Package oprofile.i386 0:0.8.1-33 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.5 for package: libtool
--> Processing Dependency: httpd = 2.0.52-22.ent.centos4 for package:
httpd-manual
--> Processing Conflict: python-devel conflicts python < 2.3.4-14.4.el4_6.1
--> Processing Dependency: rpm = 4.3.3-13_nonptl for package: rpm-devel
--> Processing Dependency: libgssapi for package: nfs-utils
--> Processing Dependency: httpd = 2.0.52-22.ent.centos4 for package:
httpd-suexec
--> Processing Dependency: libgcj = 3.4.5 for package: libgcj-devel
--> Processing Dependency: base-fonts for package: xorg-x11-xfs
--> Processing Dependency: gcc = 3.4.5-2 for package: gcc-g77
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: bind = 20:9.2.4-2 for package: bind-chroot
--> Processing Dependency: rpm = 4.3.3-13_nonptl for package: rpm-build
--> Processing Dependency: gcc = 3.4.5-2 for package: gcc-c++
--> Processing Dependency: nfs-utils-lib for package: nfs-utils
--> Processing Dependency: postgresql = 7.4.8-1.RHEL4.1 for package:
postgresql-docs
--> Processing Dependency: postgresql = 7.4.8-1.RHEL4.1 for package:
postgresql-test
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Processing Dependency: lockdev = 1.0.1-6.1 for package: lockdev-devel
--> Processing Dependency: libnfsidmap.so.0 for package: nfs-utils
--> Processing Dependency: postgresql-server = 7.4.8-1.RHEL4.1 for
package: postgresql-test
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package fonts-xorg-base.noarch 0:6.8.2-1.EL set to be updated
---> Package libgssapi.i386 0:0.8-1 set to be updated
---> Package nfs-utils-lib.i386 0:1.0.6-8.z1 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.5 for package: libtool
--> Processing Conflict: python-devel conflicts python < 2.3.4-14.4.el4_6.1
--> Processing Dependency: postgresql = 7.4.8-1.RHEL4.1 for package:
postgresql-docs
--> Processing Dependency: httpd = 2.0.52-22.ent.centos4 for package:
httpd-suexec
--> Processing Dependency: libgcj = 3.4.5 for package: libgcj-devel
--> Processing Dependency: bind = 20:9.2.4-2 for package: bind-chroot
--> Processing Dependency: rpm = 4.3.3-13_nonptl for package: rpm-build
--> Processing Dependency: gcc = 3.4.5-2 for package: gcc-c++
--> Processing Dependency: rpm = 4.3.3-13_nonptl for package: rpm-devel
--> Processing Dependency: gcc = 3.4.5-2 for package: gcc-g77
--> Processing Dependency: postgresql = 7.4.8-1.RHEL4.1 for package:
postgresql-test
--> Processing Dependency: httpd = 2.0.52-22.ent.centos4 for package:
httpd-manual
--> Processing Dependency: lockdev = 1.0.1-6.1 for package: lockdev-devel
--> Processing Dependency: postgresql-server = 7.4.8-1.RHEL4.1 for
package: postgresql-test
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.5 is needed by package libtool
Error: Missing Dependency: httpd = 2.0.52-22.ent.centos4 is needed by
package httpd-manual
Error: python-devel conflicts with python < 2.3.4-14.4.el4_6.1
Error: Missing Dependency: rpm = 4.3.3-13_nonptl is needed by package
rpm-devel
Error: Missing Dependency: httpd = 2.0.52-22.ent.centos4 is needed by
package httpd-suexec
Error: Missing Dependency: libgcj = 3.4.5 is needed by package libgcj-devel
Error: Missing Dependency: gcc = 3.4.5-2 is needed by package gcc-g77
Error: Missing Dependency: bind = 20:9.2.4-2 is needed by package
bind-chroot
Error: Missing Dependency: rpm = 4.3.3-13_nonptl is needed by package
rpm-build
Error: Missing Dependency: gcc = 3.4.5-2 is needed by package gcc-c++
Error: Missing Dependency: postgresql = 7.4.8-1.RHEL4.1 is needed by
package postgresql-docs
Error: Missing Dependency: postgresql = 7.4.8-1.RHEL4.1 is needed by
package postgresql-test
Error: Missing Dependency: lockdev = 1.0.1-6.1 is needed by package
lockdev-devel
Error: Missing Dependency: postgresql-server = 7.4.8-1.RHEL4.1 is needed
by package postgresql-test
===========================

Is there a way I can clean that mess up? I think I got into some kind
of circular dependencies. Example:

[root@server ~]# yum update lockdev
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package lockdev.i386 0:1.0.1-6.2 set to be updated
--> Running transaction check
--> Processing Dependency: lockdev = 1.0.1-6.1 for package: lockdev-devel
--> Finished Dependency Resolution
Error: Missing Dependency: lockdev = 1.0.1-6.1 is needed by package
lockdev-devel

Then,

[root@server ~]# yum update lockdev-devel
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for lockdev-devel
No Packages marked for Update/Obsoletion

rpm --rebuilddb didn't help.

Any help would be appreciated.

Regards,

Ugo

Search Discussions

  • Akemi Yagi at Feb 4, 2008 at 9:10 pm

    On Feb 4, 2008 12:27 PM, Ugo Bellavance wrote:
    Hi,

    I was doing updates on a server and I think that the network connection
    got reset. So I guess the yum update didn't complete and I now get this
    when I run 'yum update':
    Looks like your problem is similar to the one reported in this forum thread:

    http://www.centos.org/modules/newbb/viewtopic.php?topic_id139&forum'&post_id2527

    Try the solution given in that thread.

    Hope that works,

    Akemi

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedFeb 4, '08 at 8:27p
activeFeb 4, '08 at 9:10p
posts2
users2
websitecentos.org
irc#centos

2 users in discussion

Akemi Yagi: 1 post Ugo Bellavance: 1 post

People

Translate

site design / logo © 2022 Grokbase