FAQ
I have a Centos 5 64-bit server that has ntp service enabled. Windows XP
with SP2 cannot properly sync to it for time, but can communicate with it
via samba, ssh, and anything else. I also disabled the Windows
Firewall. The C5 system does not have any firewall enabled.

Other C5 workstations can successfully sync to it via ntpdate.

What else could cause the XP machine to not be able to time sync with the
C5 server?

Thanks.

Scott

Search Discussions

  • James D. Parra at Feb 1, 2008 at 7:43 pm
    -----Original Message-----
    From: Scott Ehrlich
    Sent: Friday, February 01, 2008 11:37 AM
    To: centos@centos.org
    Subject: [CentOS] NTP server


    I have a Centos 5 64-bit server that has ntp service enabled. Windows XP
    with SP2 cannot properly sync to it for time, but can communicate with it
    via samba, ssh, and anything else. I also disabled the Windows
    Firewall. The C5 system does not have any firewall enabled.

    Other C5 workstations can successfully sync to it via ntpdate.

    What else could cause the XP machine to not be able to time sync with the
    C5 server?
    ~~~~~~

    Try this; create a DNS entry called ntp.yourinternaldomain.com, then plug
    that name into XP's internet time. I had a similar problem and changing the
    IP address to FQDN fixed it.

    Perhaps it will work for you.

    Good luck,

    ~James
  • Jason Ross at Feb 1, 2008 at 8:49 pm

    On Fri, 2008-02-01 at 11:43 -0800, James D. Parra wrote:
    -----Original Message-----
    From: Scott Ehrlich
    Sent: Friday, February 01, 2008 11:37 AM
    To: centos@centos.org
    Subject: [CentOS] NTP server


    I have a Centos 5 64-bit server that has ntp service enabled. Windows XP
    with SP2 cannot properly sync to it for time, but can communicate with it
    via samba, ssh, and anything else. I also disabled the Windows
    Firewall. The C5 system does not have any firewall enabled.

    Other C5 workstations can successfully sync to it via ntpdate.

    What else could cause the XP machine to not be able to time sync with the
    C5 server?
    ~~~~~~

    Try this; create a DNS entry called ntp.yourinternaldomain.com, then plug
    that name into XP's internet time. I had a similar problem and changing the
    IP address to FQDN fixed it.

    Perhaps it will work for you.

    Good luck,

    ~James
    Try running these from the command line

    net time /setsntp:10.0.0.87 <====your NTP ip here

    net time /querysntp

    net stop w32time && net start w32time

    -Jason
  • Craig White at Feb 1, 2008 at 10:46 pm

    On Fri, 2008-02-01 at 13:49 -0700, Jason Ross wrote:
    On Fri, 2008-02-01 at 11:43 -0800, James D. Parra wrote:
    -----Original Message-----
    From: Scott Ehrlich
    Sent: Friday, February 01, 2008 11:37 AM
    To: centos@centos.org
    Subject: [CentOS] NTP server


    I have a Centos 5 64-bit server that has ntp service enabled. Windows XP
    with SP2 cannot properly sync to it for time, but can communicate with it
    via samba, ssh, and anything else. I also disabled the Windows
    Firewall. The C5 system does not have any firewall enabled.

    Other C5 workstations can successfully sync to it via ntpdate.

    What else could cause the XP machine to not be able to time sync with the
    C5 server?
    ~~~~~~

    Try this; create a DNS entry called ntp.yourinternaldomain.com, then plug
    that name into XP's internet time. I had a similar problem and changing the
    IP address to FQDN fixed it.

    Perhaps it will work for you.

    Good luck,

    ~James
    Try running these from the command line

    net time /setsntp:10.0.0.87 <====your NTP ip here

    net time /querysntp

    net stop w32time && net start w32time
    ----
    I think that you have to have administrative privileges or group policy
    permissions to be able to do those commands in Windows.

    Craig
  • Dennis McLeod at Feb 1, 2008 at 8:03 pm
    XP command line:

    net time \\servername returns what?

    Perhaps the response will give a clue.


    To set it:

    net time \\servername /set /yes




    -----Original Message-----
    From: centos-bounces@centos.org On Behalf
    Of Scott Ehrlich
    Sent: Friday, February 01, 2008 11:37 AM
    To: centos@centos.org
    Subject: [CentOS] NTP server

    I have a Centos 5 64-bit server that has ntp service enabled. Windows XP
    with SP2 cannot properly sync to it for time, but can communicate with it
    via samba, ssh, and anything else. I also disabled the Windows
    Firewall. The C5 system does not have any firewall enabled.

    Other C5 workstations can successfully sync to it via ntpdate.

    What else could cause the XP machine to not be able to time sync with the
    C5 server?

    Thanks.

    Scott
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Scott Silva at Feb 1, 2008 at 9:14 pm

    on 2/1/2008 12:03 PM Dennis McLeod spake the following:
    XP command line:

    net time \\servername returns what?

    Perhaps the response will give a clue.


    To set it:

    net time \\servername /set /yes
    Net time is only used to set time from a domain controller, not an ntp server.
    They use two completely different protocols.

    --
    MailScanner is like deodorant...
    You hope everybody uses it, and
    you notice quickly if they don't!!!!

    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 187 bytes
    Desc: OpenPGP digital signature
    Url : http://lists.centos.org/pipermail/centos/attachments/20080201/4b873087/signature.bin
  • John R Pierce at Feb 1, 2008 at 9:29 pm

    Scott Silva wrote:
    on 2/1/2008 12:03 PM Dennis McLeod spake the following:
    XP command line:

    net time \\servername returns what?

    Perhaps the response will give a clue.


    To set it:

    net time \\servername /set /yes
    Net time is only used to set time from a domain controller, not an ntp
    server.
    They use two completely different protocols.

    however,

    NET TIME /SETSNTP:ip-of-ntp-server

    WILL set the windows 'internet time' server IP.

    NET TIME /QUERYSNTP

    will show the current 'internet time' server(s).

    note that the default Windows NTP client is really braindead, it just
    'sets' the system clock once a day, its not a proper NTP
    implementation. for most users, this is fine, but realize oddities can
    happen like the clock being set back a few seconds such that a given
    time happens twice.
  • Jason Ross at Feb 1, 2008 at 9:39 pm

    On Fri, 2008-02-01 at 13:29 -0800, John R Pierce wrote:
    Scott Silva wrote:
    on 2/1/2008 12:03 PM Dennis McLeod spake the following:
    XP command line:

    net time \\servername returns what?

    Perhaps the response will give a clue.


    To set it:

    net time \\servername /set /yes
    Net time is only used to set time from a domain controller, not an ntp
    server.
    They use two completely different protocols.

    however,

    NET TIME /SETSNTP:ip-of-ntp-server

    WILL set the windows 'internet time' server IP.

    NET TIME /QUERYSNTP

    will show the current 'internet time' server(s).

    note that the default Windows NTP client is really braindead, it just
    'sets' the system clock once a day, its not a proper NTP
    implementation. for most users, this is fine, but realize oddities can
    happen like the clock being set back a few seconds such that a given
    time happens twice.
    Very true.

    You can modify the time interval by editing your registry.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time
    \TimeProviders\NtpClient]

    "SpecialPollInterval"=dword:00001c20

    This will set it to update every two hours. The dword can be modified to
    set it for 1 hour to whatever.

    -jason
  • Scott Silva at Feb 1, 2008 at 9:57 pm

    on 2/1/2008 1:29 PM John R Pierce spake the following:
    Scott Silva wrote:
    on 2/1/2008 12:03 PM Dennis McLeod spake the following:
    XP command line:

    net time \\servername returns what?

    Perhaps the response will give a clue.


    To set it:

    net time \\servername /set /yes
    Net time is only used to set time from a domain controller, not an ntp
    server.
    They use two completely different protocols.

    however,

    NET TIME /SETSNTP:ip-of-ntp-server

    WILL set the windows 'internet time' server IP.

    NET TIME /QUERYSNTP

    will show the current 'internet time' server(s).

    note that the default Windows NTP client is really braindead, it just
    'sets' the system clock once a day, its not a proper NTP
    implementation. for most users, this is fine, but realize oddities can
    happen like the clock being set back a few seconds such that a given
    time happens twice.
    I stand partially corrected, as the originally posted command line of
    "net time \\servername /set /yes" would not query a ntp server.

    --
    MailScanner is like deodorant...
    You hope everybody uses it, and
    you notice quickly if they don't!!!!

    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 187 bytes
    Desc: OpenPGP digital signature
    Url : http://lists.centos.org/pipermail/centos/attachments/20080201/bce1c8f6/signature.bin
  • Stephen John Smoogen at Feb 1, 2008 at 8:56 pm

    Scott Ehrlich wrote:
    I have a Centos 5 64-bit server that has ntp service enabled. Windows
    XP with SP2 cannot properly sync to it for time, but can communicate
    with it via samba, ssh, and anything else. I also disabled the
    Windows Firewall. The C5 system does not have any firewall enabled.
    The following would stop this:

    1) DNS with a fully qualified name.
    2) CentOS-5 server does not have port 123 open on its firewall
    iptables -nxvL | grep 123

    should give you an answer to that
    3) CentOS-5 server is not serving NTP to your network

    netstat -nalp | grep :123

    should have something other than
    udp 0 0 127.0.0.1:123 0.0.0.0:*

    This is configured in the /etc/ntp.conf file.

    --
    --
    Stephen J Smoogen. -- CSIRT/Linux System Administrator
    How far that little candle throws his beams! So shines a good deed
    in a naughty world. = Shakespeare. "The Merchant of Venice"
    smooge@gmail.com
  • Rainer Traut at Feb 4, 2008 at 9:43 am

    Scott Ehrlich schrieb:
    I have a Centos 5 64-bit server that has ntp service enabled. Windows
    XP with SP2 cannot properly sync to it for time, but can communicate
    with it via samba, ssh, and anything else. I also disabled the
    Windows Firewall. The C5 system does not have any firewall enabled.

    Other C5 workstations can successfully sync to it via ntpdate.

    What else could cause the XP machine to not be able to time sync with
    the C5 server?
    I'd double-check the c5 ntpd config. Are the xp machines really in the
    same allowed subnet like the c5 workstations?

    Personally I don't use Windows' time sync anymore, I use the ntp
    implementation for windows from here:

    http://www.meinberg.de/english/sw/ntp.htm

    Install/config is very easy, you even get the ntpdc command.

    Rainer

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedFeb 1, '08 at 7:37p
activeFeb 4, '08 at 9:43a
posts11
users9
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase