FAQ
I can't mount the cdrom when the user account has an nfs home directory.
It works fine on the gnome side with the same user. It also works fine
if I create a brand new local account, with no nfs mounted home directory.

This error is affecting all users on all computers; not just one
account. The one thing in common is that they all are using nfs mounted
home directories and that CentOS is the distro. Older systems that are
still using fc3 dont have this issue.

Any ideas? Suggestions?

Search Discussions

  • Alfred von Campe at Dec 4, 2006 at 6:55 pm

    On Dec 4, 2006, at 13:40, Jean Figarella wrote:

    I can't mount the cdrom when the user account has an nfs home
    directory. It works fine on the gnome side with the same user. It
    also works fine if I create a brand new local account, with no nfs
    mounted home directory.
    Can you not mount the CDROM at all or does it merely not auto-mount?
    I have the latter problem, which is a little annoying at times.
    Doing a "mount /media/cdrom" as root mounts the CDROM and puts it on
    the Desktop of the currently logged in Gnome user. I never made the
    correlation with having an NFS mounted home directory. In our
    environment, root can not access (read or write) the users' home
    directories.

    Alfred
  • Jean Figarella at Dec 4, 2006 at 7:14 pm
    Ok this is my sequence,

    I put a cd on the drive, then close it. It never automounts. So I click
    (double click) on the cd icon that is always on the desktop and then I
    get this error:
    mount: block device /dev/hdc is write, protected, mounting read-only
    mount: /dev/hdc already mounted or /media/cdrom busy
    Please check that the disk is entered correctly

    And nothing happens.

    Then if I do open a shell and as root I do mount /media/cdrom, it does
    mount the cd and then I can access it from konqueror.

    Again, the whole process works fine under gnome, no need to mount cd as
    root, the gui will mount it for you. But under kde it just does not work.

    I don't know if this is related to nfs or not, but this (nfs), they are
    part of my network's users, and that they are using centos is the only
    thing in common.

    Thanks Alfred

    - Jean


    Alfred von Campe wrote:
    On Dec 4, 2006, at 13:40, Jean Figarella wrote:

    I can't mount the cdrom when the user account has an nfs home
    directory. It works fine on the gnome side with the same user. It also
    works fine if I create a brand new local account, with no nfs mounted
    home directory.
    Can you not mount the CDROM at all or does it merely not auto-mount? I
    have the latter problem, which is a little annoying at times. Doing a
    "mount /media/cdrom" as root mounts the CDROM and puts it on the Desktop
    of the currently logged in Gnome user. I never made the correlation
    with having an NFS mounted home directory. In our environment, root can
    not access (read or write) the users' home directories.

    Alfred

    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Administrator at Dec 4, 2006 at 9:28 pm
    i had a similar issue the other day with a file server i was setting up,
    it was solved by specifically mounting the type of drive that i was using:

    mount -t vfat

    before the mount paths

    hope that helps.

    Noah


    Alfred von Campe wrote:
    On Dec 4, 2006, at 13:40, Jean Figarella wrote:

    I can't mount the cdrom when the user account has an nfs home
    directory. It works fine on the gnome side with the same user. It also
    works fine if I create a brand new local account, with no nfs mounted
    home directory.
    Can you not mount the CDROM at all or does it merely not auto-mount? I
    have the latter problem, which is a little annoying at times. Doing a
    "mount /media/cdrom" as root mounts the CDROM and puts it on the Desktop
    of the currently logged in Gnome user. I never made the correlation
    with having an NFS mounted home directory. In our environment, root can
    not access (read or write) the users' home directories.

    Alfred

    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Stephen C. Rigler at Dec 4, 2006 at 7:00 pm

    On Mon, 2006-12-04 at 13:40 -0500, Jean Figarella wrote:
    I can't mount the cdrom when the user account has an nfs home directory.
    It works fine on the gnome side with the same user. It also works fine
    if I create a brand new local account, with no nfs mounted home directory.

    This error is affecting all users on all computers; not just one
    account. The one thing in common is that they all are using nfs mounted
    home directories and that CentOS is the distro. Older systems that are
    still using fc3 dont have this issue.

    Any ideas? Suggestions?
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
    Hi Jean,

    This is just a "me too". I've just observed the same issue on RHEL 4.
    What's worse is that once the user has tried to mount the CD they can't
    eject it without superuser intervention (from the GUI or the button on
    the CD drive).

    -Steve

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedDec 4, '06 at 6:40p
activeDec 4, '06 at 9:28p
posts5
users4
websitecentos.org
irc#centos

People

Translate

site design / logo © 2021 Grokbase