FAQ
Hi,

I'm trying to install Centos 4.3 x86 on a PE 1400SC but the install doesn't
find any HD's.

So then I get the option to load a module, so I choose for the megaraid_mbox
module for the LSI LOGIC 4CH PERC but my RAID5 still doesn't get recognised.

Had the same problem 2 years ago with FC3 wich was due to the megaraid
module wich got obsolete in the 2.6 kernel but somebody filed a bug and a
driver disk was provided to solve this percy problem.

Also tried installing the new shiney Ubuntu Dapper server release, but the
install also suffered from the same problem.

Could someone provide a loadable driver disk for centos?

kind regards,

GB
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20060605/6ed31261/attachment.htm

Search Discussions

  • Johnny Hughes at Jun 5, 2006 at 10:27 am

    On Mon, 2006-06-05 at 09:14 +0200, Geert Batsleer wrote:
    Hi,

    I'm trying to install Centos 4.3 x86 on a PE 1400SC but the install
    doesn't find any HD's.

    So then I get the option to load a module, so I choose for the
    megaraid_mbox module for the LSI LOGIC 4CH PERC but my RAID5 still
    doesn't get recognised.

    Had the same problem 2 years ago with FC3 wich was due to the megaraid
    module wich got obsolete in the 2.6 kernel but somebody filed a bug
    and a driver disk was provided to solve this percy problem.

    Also tried installing the new shiney Ubuntu Dapper server release, but
    the install also suffered from the same problem.

    Could someone provide a loadable driver disk for centos?

    kind regards,

    GB
    _______________________________________________
    Your problem is that the LSI driver in the 2.6 kernel does not include
    the older megaraid devices.

    Look here (and search for megaraid_mbox):

    http://mirror.centos.org/centos/4/docs/html/release-notes/as-x86/

    I don't know if there is a driver that still works, but this device is
    probably supported on CentOS-3.

    Thanks,
    Johnny Hughes
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20060605/68c01352/attachment.bin
  • Fabian Arrotin at Jun 5, 2006 at 11:17 am

    On Mon, 2006-06-05 at 05:27 -0500, Johnny Hughes wrote:
    On Mon, 2006-06-05 at 09:14 +0200, Geert Batsleer wrote:
    Hi,

    I'm trying to install Centos 4.3 x86 on a PE 1400SC but the install
    doesn't find any HD's.

    So then I get the option to load a module, so I choose for the
    megaraid_mbox module for the LSI LOGIC 4CH PERC but my RAID5 still
    doesn't get recognised.

    Had the same problem 2 years ago with FC3 wich was due to the megaraid
    module wich got obsolete in the 2.6 kernel but somebody filed a bug
    and a driver disk was provided to solve this percy problem.

    Also tried installing the new shiney Ubuntu Dapper server release, but
    the install also suffered from the same problem.

    Could someone provide a loadable driver disk for centos?

    kind regards,

    GB
    _______________________________________________
    Your problem is that the LSI driver in the 2.6 kernel does not include
    the older megaraid devices.

    Look here (and search for megaraid_mbox):

    http://mirror.centos.org/centos/4/docs/html/release-notes/as-x86/

    I don't know if there is a driver that still works, but this device is
    probably supported on CentOS-3.

    Thanks,
    Johnny Hughes
    Normally all PERC 4 and 3 controllers should be supported in CentOS
    4 ... Support for older Perc 2 was removed from 2.6 kernels but you said
    that you're using a Perc 4 ...
    You'd better have a look at http://linux.dell.com in the storage section
    about support for your controller in 2.6 kernel ...
    Anyway, on the support website for your pe1400 i don't see this PERC
    4CH, but other Perc 4x controllers ... are you sure about the raid
    controller model you have ?
  • Steve Huff at Jun 5, 2006 at 1:39 pm

    On Jun 5, 2006, at 3:14 AM, Geert Batsleer wrote:

    I'm trying to install Centos 4.3 x86 on a PE 1400SC but the install
    doesn't find any HD's.

    So then I get the option to load a module, so I choose for the
    megaraid_mbox module for the LSI LOGIC 4CH PERC but my RAID5 still
    doesn't get recognised.

    Had the same problem 2 years ago with FC3 wich was due to the
    megaraid module wich got obsolete in the 2.6 kernel but somebody
    filed a bug and a driver disk was provided to solve this percy
    problem.

    Also tried installing the new shiney Ubuntu Dapper server release,
    but the install also suffered from the same problem.

    Could someone provide a loadable driver disk for centos?
    i have a similar problem (i'm running CentOS 4 on some older HP
    servers), and i was able to fix it by following these instructions:

    http://www.tuxyturvy.com/blog/index.php?url=archives/4-Installing-
    RHEL4-on-Systems-with-Legacy-Megaraid-Drivers.html

    i keep meaning to roll up my own RPM for the legacy kernel module;
    this reminded me of that project.

    -steve

    ---
    If this were played upon a stage now, I could condemn it as an
    improbable fiction. - Fabian, Twelfth Night, III,v
  • Geert Batsleer at Jun 5, 2006 at 2:14 pm
    2006/6/5, Steve Huff <shuff@vecna.org>:

    i keep meaning to roll up my own RPM for the legacy kernel module;
    this reminded me of that project.

    -steve

    Hi Steve,
    Sounds promising but what todo with this rpm if you can't even install the
    OS in the first place? I presume that a driver disk would be a better
    soulution in this case, and I'm going to try the link you provided in the
    meantime.

    Thanks for the feedback!

    Geert
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.centos.org/pipermail/centos/attachments/20060605/e8a1e7f3/attachment.htm
  • Geert Batsleer at Jun 6, 2006 at 9:58 am
    Hi,

    just succesfully installed Centos 4.3 on a PE 1400SC with e Perc ATA100/4Ch
    card.

    I've build a working driver for i586 and i686 arch on a 2.6.9-34 kernel
    (centos 4.3) wich can be d/l from:

    http://users.telenet.be/studioo/megaraid-i586.ko
    http://users.telenet.be/studioo/megaraid-i686.ko

    and this is the step by step howto:

    http://lists.centos.org/pipermail/centos/2005-August/010021.html

    Hope this is useful for others with the same problem.

    kind regards,

    Geert
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.centos.org/pipermail/centos/attachments/20060606/95fb93fc/attachment.htm

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedJun 5, '06 at 7:14a
activeJun 6, '06 at 9:58a
posts6
users4
websitecentos.org
irc#centos

People

Translate

site design / logo © 2022 Grokbase